LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 07-29-2004, 03:22 PM   #1
iankh
LQ Newbie
 
Registered: Jul 2004
Location: Chicago, IL
Posts: 2

Rep: Reputation: 0
libX11 problem


Hi All,

I've been trying to install some software that requires libx11.so. I downloaded Xfree86-libs-4.3.0-62.EL.i386.rpm and installed it.

While installing, there are no errors. However, when I try to install my software it still says libX11 needs to be installed.

Any suggestions?

Thanks in advance,
Ian
 
Old 07-29-2004, 03:59 PM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
You probably need a package called something like libx11 I don't know the proper redhat name for it but in debian it's libx11(-dev). But it's completely different from XF86
 
Old 07-29-2004, 04:20 PM   #3
iankh
LQ Newbie
 
Registered: Jul 2004
Location: Chicago, IL
Posts: 2

Original Poster
Rep: Reputation: 0
Hi,

Thanks for the prompt reply...but I'm a bit of a newbie, so you'll have to be a bit more specifiic if you can.

When I extracted the original XF86, I did get a libX11.so

Thus, are you suggesting that there is a completely different libX11 out there?

Thanks again,
Ian
 
Old 07-29-2004, 06:30 PM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
It's the dev part that counts. You need to install the development libs if you want to compile against them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install libX11 error! (xproto) totallybored Linux - Software 6 11-18-2010 03:46 AM
Not loading gdm;"libX11.so.6 cannot open shared object" zlobby Linux - Newbie 6 03-03-2004 04:30 PM
pango-1.0.5 can't find libX11.so.6, but it is on my system behmjose Linux - Newbie 3 02-21-2004 10:15 PM
libx11.so.6 and Tactical Ops greendemon Linux - Newbie 0 01-25-2004 09:29 AM
VectorLinux lilo not working and libX11.so.7 not found aalaap Linux - Newbie 0 11-06-2003 03:19 PM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration