Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-15-2005, 02:23 AM   #1
Registered: Nov 2004
Location: Finland
Distribution: fedora core 3
Posts: 38

Rep: Reputation: 15
Unhappy libtool error (openobex)


I'm trying to install openobex/usbopex but when running make install I get:

[root@theones lib]# make install
Making install in m4macros
make[1]: Entering directory `/root/openobex/lib/m4macros'
make[2]: Entering directory `/root/openobex/lib/m4macros'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/root/usbobex/share/aclocal" || mkdir -p --
/usr/bin/install -c -m 644 'openobex.m4'
make[2]: Leaving directory `/root/openobex/lib/m4macros'
make[1]: Leaving directory `/root/openobex/lib/m4macros'
Making install in src
make[1]: Entering directory `/root/openobex/lib/src'
if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.
-I.. -I../src -O2 -MT obex.lo -MD -MP -MF ".deps/obex.Tpo" -c -o obex.lo
obex.c; \
then mv -f ".deps/obex.Tpo" ".deps/obex.Plo"; else rm -f ".deps/obex.Tpo";
exit 1; fi
libtool: unrecognized option `--tag=CC'
Try `libtool --help' for more information.
make[1]: *** [obex.lo] Error 1
make[1]: Leaving directory `/root/openobex/lib/src'
make: *** [install-recursive] Error 1

I'm using fedora core 4 and 2.6.12 kernel but same problem was in FC3 and with 2.6.11 kernel. I haev tried to search google and forums but I can't get any information about how to solve this!!

please help me on this!!!!!
Old 07-15-2005, 11:27 PM   #2
Senior Member
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
first thing to try is just to find that tag
in the Makefile
if it's in the one in /root/openobex/lib/src
or at a higher level

and take it out

sourceforge is down now so i can't check it out but man do i hate those unix packages that make you start as root typing "make install"

some packages like that can be hard nuts to crack but i bet it's doable


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
libtool error xushi Slackware 4 01-27-2009 02:28 PM
FreeBSD PHP5 ports error - is not a valid libtool archive *BSD 2 08-18-2005 10:27 AM
libtool link error tibbar66 Linux - Newbie 1 04-09-2005 05:14 PM
GTK+-2.6.2 compile error: libtool looking in wrong place for Locura Linux - Software 5 02-17-2005 03:51 PM
make error "libtool: link: cannot find the library `' " jdolluc Linux - Software 2 10-15-2003 09:51 PM

All times are GMT -5. The time now is 01:26 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration