LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-04-2012, 11:29 AM   #1
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 347

Rep: Reputation: 31
Libreoffice: writing aids not working [en-us]


Hi all,

I am using LibreOffice v3.5.6.2 under Fedora 17. I have the latest English language pack installed.

I make sure the document I am working on has the language properly defined (US English).

Yet the writing aids aren't working. Interactive spell check doesn't do anything. If I press F7, the spellchecker appears to check the document without finding anything.

In Options --> Language settings --> Writing aids, "check spelling as you type" is activated.

Yet neither interactive nor batch spellchecking works.

What I am missing here?

I am absolutely desperate to solve this as my work depends on it. Anyone have any ideas for me?
 
Old 10-04-2012, 01:21 PM   #2
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 347

Original Poster
Rep: Reputation: 31
Studying things more closely, I see under Options --> Language settings --> Writing aids that under "Available language modues" only hyphenation and thesaurus are listed. It would appear that a US spelling dictionary isn't installed.

On the Ubunti wiki, I find the following:
Quote:
Language localization, spell checking, dictionary, hyphenation, thesaurus, and help

To install proper support for language writing aids you may install the corresponding packages libreoffice-l10n-*, myspell-*, hyphen-*, mythes-*, libreoffice-help-* followed by your language ISO 639-1 code. A complete list of such language codes is available at: http://en.wikipedia.org/wiki/List_of_ISO_639-1_codes

For example, the corresponding French packages are:

libreoffice-l10n-fr
myspell-fr
hyphen-fr
mythes-fr
libreoffice-help-fr
https://wiki.ubuntu.com/LibreOffice
I don't have any myspell packages on my system. Searching yum for 'myspell' only returns two hunspell(!) packages:
Quote:
$ yum search myspell
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: nl.mirror.eurid.eu
* rpmfusion-free: mirror01.th.ifl.net
* rpmfusion-free-updates: mirror01.th.ifl.net
* rpmfusion-nonfree: mirror01.th.ifl.net
* rpmfusion-nonfree-updates: mirror01.th.ifl.net
* updates: nl.mirror.eurid.eu
====================================================================== Matched: myspell ======================================================================
hunspell-ku-0.21-8.fc17.noarch : Kurdish hunspell dictionaries
hunspell-sq-1.6.4-2.fc17.noarch : Albanian hunspell dictionaries
Hmmm........................
 
Old 10-05-2012, 01:15 PM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,191

Rep: Reputation: 815Reputation: 815Reputation: 815Reputation: 815Reputation: 815Reputation: 815Reputation: 815
The spellchecker used to be myspell, but it's now hunspell. You should have it, and you can certainly get it with yum. I'm surprised you didn't get the dictionary, but it's probably quickest to get that from the LibreOffice site.
 
Old 10-05-2012, 01:24 PM   #4
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 347

Original Poster
Rep: Reputation: 31
I seem to have it:

Code:
$ rpm -qa | grep hunspell
hunspell-en-GB-0.20110318-8.fc17.noarch
hunspell-1.3.2-8.fc17.x86_64
hunspell-en-US-0.20110318-8.fc17.noarch
hunspell-en-0.20110318-8.fc17.noarch
Wonder why it isn't showing up.
 
Old 10-06-2012, 12:06 PM   #5
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,191

Rep: Reputation: 815Reputation: 815Reputation: 815Reputation: 815Reputation: 815Reputation: 815Reputation: 815
Someone at the LibreOffice forum had this problem and used "Tools - Language - For all text" to change the language and then to change it back again; that seems too good to be true, but it worked. Otherwise, you could uninstall LibreOffice and replace Fedora's version (usually tweaked) with the one down-loadable from LibreOffice. This is the sort of thing that made me switch from Fedora to CentOS.
 
Old 10-08-2012, 06:36 AM   #6
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 347

Original Poster
Rep: Reputation: 31
OK, I think I figured it out. I installed these hunspell packages with yum:

Code:
Oct 05 19:49:04 Installed: hunspell-en-GB-0.20110318-8.fc17.noarch
Oct 05 19:49:04 Installed: hunspell-en-US-0.20110318-8.fc17.noarch
Oct 05 19:49:05 Installed: hunspell-en-0.20110318-8.fc17.noarch
I then needed to go back to Options --> Language settings --> Writing aids. "Hunspell SpellChecker" is displayed but it isn't selected. I selected it (switched it on), selected OK, then went back to my document. Set the language to default, then to en-US. Now interactive spellchecking is working again.

Whew.

Last edited by Kropotkin; 10-11-2012 at 07:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LibreOffice not working in Arch matrix13 Linux - Software 2 11-29-2012 06:48 AM
LXer: Build Your Business Around LibreOffice, LibreOffice Certification Program Announced LXer Syndicated Linux News 0 05-07-2012 01:10 PM
LXer: LibreOffice Tips: Inserting QurĂ¢??an text in LibreOffice Writer LXer Syndicated Linux News 0 04-16-2012 03:50 PM
[SOLVED] LibreOffice 3.3 not working sudeepkulkarni Slackware 5 04-10-2011 08:28 AM
openoffice writing aids Riuujin Linux - Software 0 08-01-2005 10:35 AM


All times are GMT -5. The time now is 01:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration