LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-12-2003, 03:20 PM   #1
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
libqt.so.3 needed


I need to have libqt.so.3. I found it in this package qt-3.0.3-11.i386.rpm. When i install it it fails cause i have a newer version qt-3.1.1-6 allready installed. Is there a way to just add the libqt.so.3.? Any body know what i should do? I need libqt.so.3 to have a different file run.
 
Old 08-12-2003, 04:49 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
ok tell us exactly what your doing, and what the error your getting is...
it could be a simple case of the installer of whatever you are doing, is not finding qt's path, and in turn not finding that file...
or something related...
if you are saying you have that version of qt installed then that file you are looking for should be located in:
/usr/lib/qt-3.1/lib/
but i would imagine the installer for the program you are trying to put on your machine is looking in the folder /usr/lib/qt3/lib which in turn can't find it....
but i am not totally sure of this cause i can't see the exact error of your problem, and i dont' know how you are installing whatever you are installing....
so give us that info and we'll go from there..
 
Old 08-12-2003, 07:16 PM   #3
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Original Poster
Rep: Reputation: 15
I am trying to install a file i get this message

"error: Failed dependencies:
libqt.so.3 is needed "

So i do a search for "libqt.so.3" and i find it in this package "qt-3.0.3-11.i386.rpm"

when i run it
#rpm -ivh ./qt-3.0.3-11.i386.rpm


i get this

Preparing... ########################################### [100%]
package qt-3.1.1-6 (which is newer than qt-3.0.3-11) is already installed

If you need more info let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libqt-mt lord_didger Linux - Software 2 08-23-2005 11:42 AM
libqt-mt.so.3 - I cant find it! aze Slackware 1 11-30-2004 09:18 AM
libqt 3 compat? hulkt Linux - General 2 11-03-2003 02:55 PM
libqt.so missing? supenguin Slackware 5 01-08-2003 01:26 PM
libqt-mt question Kostko Linux - General 3 10-13-2002 10:56 AM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration