LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-12-2005, 10:32 PM   #1
reeseslover531
Member
 
Registered: Nov 2005
Distribution: Fedora Core 5
Posts: 64

Rep: Reputation: 15
libpthread.so.0?


I am currently running Suse 10.0 I can run amarok, or other apps for a while and then they will quit and I am not able to get them up again. with amarok, It has the splash screen than nothing. the worst part is it affects yast. well when I start up yast it has all of these dependencies issues, here is my dependencies file.

Code:
#### YaST2 conflicts list - generated 2005-11-12 22:10:10 ####

amarok 1.3.1-7 conflict
    Broken Dependencies of Installed:
        amarok requires libpthread.so.0
        amarok requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade amarok-1.3.1-8.2 to Version 1.3.1-7
        ( ) Ignore Conflict and Risk System Inconsistencies
banshee 0.9.7-3 conflict
    Broken Dependencies of Installed:
        banshee requires libpthread.so.0
    Conflict Resolution:
        ( ) Downgrade banshee-0.9.7-4.3 to Version 0.9.7-3
        ( ) Ignore Conflict and Risk System Inconsistencies
dia 0.94-13 conflict
    Broken Dependencies of Installed:
        dia requires libpthread.so.0
        dia requires libpthread.so.0(GLIBC_2.0)
        dia requires libpthread.so.0(GLIBC_2.1)
        dia requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade dia-0.94-13.2 to Version 0.94-13
        ( ) Ignore Conflict and Risk System Inconsistencies
evolution 2.4.0-3 conflict
    Required by:
        evolution-pilot requires evolution = 2.4.0-3
        evolution-pilot requires evolution = 2.4.0-3
    Broken Dependencies of Installed:
        evolution requires libpthread.so.0
        evolution requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade evolution-2.4.0-3.2 to Version 2.4.0-3
        ( ) Remove the Referring Package
            Delete evolution-pilot
        ( ) Ignore Conflict and Risk System Inconsistencies
evolution-data-server 1.4.0-5 conflict
    Broken Dependencies of Installed:
        evolution-data-server requires libpthread.so.0
        evolution-data-server requires libpthread.so.0(GLIBC_2.0)
        evolution-data-server requires libpthread.so.0(GLIBC_2.1)
        evolution-data-server requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade evolution-data-server-1.4.0-5.2 to Version 1.4.0-5
        ( ) Ignore Conflict and Risk System Inconsistencies
evolution-pilot 2.4.0-3 conflict
    Broken Dependencies of Installed:
        evolution-pilot requires libpthread.so.0
    Conflict Resolution:
        ( ) Downgrade evolution-pilot-2.4.0-3.2 to Version 2.4.0-3
        ( ) Ignore Conflict and Risk System Inconsistencies
gnome-vfs2 2.12.0-9 conflict
    Broken Dependencies of Installed:
        gnome-vfs2 requires libpthread.so.0
        gnome-vfs2 requires libpthread.so.0(GLIBC_2.0)
        gnome-vfs2 requires libpthread.so.0(GLIBC_2.1)
        gnome-vfs2 requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade gnome-vfs2-2.12.0-9.2 to Version 2.12.0-9
        ( ) Ignore Conflict and Risk System Inconsistencies
grip 3.2.0-14 conflict
    Broken Dependencies of Installed:
        grip requires libpthread.so.0
        grip requires libpthread.so.0(GLIBC_2.0)
        grip requires libpthread.so.0(GLIBC_2.1)
    Conflict Resolution:
        ( ) Downgrade grip-3.2.0-14.2 to Version 3.2.0-14
        ( ) Ignore Conflict and Risk System Inconsistencies
iproute2 2.6.13-2 conflict
    Broken Dependencies of Installed:
        iproute2 requires libpthread.so.0
        iproute2 requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade iproute2-2.6.13-2.2 to Version 2.6.13-2
        ( ) Ignore Conflict and Risk System Inconsistencies
kdebase3 3.4.2-26 conflict
    Broken Dependencies of Installed:
        kdebase3 requires libpthread.so.0
        kdebase3 requires libpthread.so.0(GLIBC_2.0)
        kdebase3 requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade kdebase3-3.4.2-27.2 to Version 3.4.2-26
        ( ) Ignore Conflict and Risk System Inconsistencies
koffice-wordprocessing 1.4.1-10 conflict
    Broken Dependencies of Installed:
        koffice-wordprocessing requires libpthread.so.0
        koffice-wordprocessing requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade koffice-wordprocessing-1.4.1-10.2 to Version 1.4.1-10
        ( ) Ignore Conflict and Risk System Inconsistencies
libgda 1.3.91-5 conflict
    Broken Dependencies of Installed:
        libgda requires libpthread.so.0
        libgda requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade libgda-1.3.91-5.2 to Version 1.3.91-5
        ( ) Ignore Conflict and Risk System Inconsistencies
libgnomecups 0.2.1-4 conflict
    Broken Dependencies of Installed:
        libgnomecups requires libpthread.so.0
        libgnomecups requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade libgnomecups-0.2.2-0.2 to Version 0.2.1-4
        ( ) Ignore Conflict and Risk System Inconsistencies
libgnomesu 1.0.0-3 conflict
    Broken Dependencies of Installed:
        libgnomesu requires libpthread.so.0
        libgnomesu requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade libgnomesu-1.0.0-3.2 to Version 1.0.0-3
        ( ) Ignore Conflict and Risk System Inconsistencies
librsvg 2.11.1-3 conflict
    Broken Dependencies of Installed:
        librsvg requires libpthread.so.0
        librsvg requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade librsvg-2.11.1-3.2 to Version 2.11.1-3
        ( ) Ignore Conflict and Risk System Inconsistencies
liferea 0.9.4-3 conflict
    Broken Dependencies of Installed:
        liferea requires libpthread.so.0
        liferea requires libpthread.so.0(GLIBC_2.0)
        liferea requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade liferea-0.9.4-3.2 to Version 0.9.4-3
        ( ) Ignore Conflict and Risk System Inconsistencies
mozilla 1.7.11-9 conflict
    Broken Dependencies of Installed:
        mozilla requires libpthread.so.0
        mozilla requires libpthread.so.0(GLIBC_2.0)
        mozilla requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade mozilla-1.7.11-9.2 to Version 1.7.11-9
        ( ) Ignore Conflict and Risk System Inconsistencies
mozilla-devel 1.7.11-9 conflict
    Broken Dependencies of Installed:
        mozilla-devel requires libpthread.so.0
        mozilla-devel requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade mozilla-devel-1.7.11-9.2 to Version 1.7.11-9
        ( ) Ignore Conflict and Risk System Inconsistencies
MozillaFirefox 1.0.6-16 conflict
    Broken Dependencies of Installed:
        MozillaFirefox requires libpthread.so.0
        MozillaFirefox requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade MozillaFirefox-1.0.7-0.1 to Version 1.0.6-16
        ( ) Ignore Conflict and Risk System Inconsistencies
net-snmp 5.2.1-10 conflict
    Broken Dependencies of Installed:
        net-snmp requires libpthread.so.0
        net-snmp requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade net-snmp-5.2.1-10.2 to Version 5.2.1-10
        ( ) Ignore Conflict and Risk System Inconsistencies
OpenOffice_org-gnome 1.9.125-5 conflict
    Broken Dependencies of Installed:
        OpenOffice_org-gnome requires OpenOffice_org = 2.0.0-1.2
        OpenOffice_org-gnome requires libcomphelp4gcc3.so
        OpenOffice_org-gnome requires libdbtools680li.so
        OpenOffice_org-gnome requires libfile680li.so
        OpenOffice_org-gnome requires libpsp680li.so
        OpenOffice_org-gnome requires libpsp680li.so(LIBPSPRINT_1_0)
        OpenOffice_org-gnome requires libpthread.so.0
        OpenOffice_org-gnome requires libsot680li.so
        15 more...
    Conflict Resolution:
        ( ) Downgrade OpenOffice_org-gnome-2.0.0-1.2 to Version 1.9.125-5
        ( ) Ignore Conflict and Risk System Inconsistencies
OpenOffice_org-kde 1.9.125-5 conflict
    Broken Dependencies of Installed:
        OpenOffice_org-kde requires OpenOffice_org = 2.0.0-1.2
        OpenOffice_org-kde requires libcomphelp4gcc3.so
        OpenOffice_org-kde requires libdbtools680li.so
        OpenOffice_org-kde requires libfile680li.so
        OpenOffice_org-kde requires libpsp680li.so
        OpenOffice_org-kde requires libpsp680li.so(LIBPSPRINT_1_0)
        OpenOffice_org-kde requires libpthread.so.0
        OpenOffice_org-kde requires libpthread.so.0(GLIBC_2.0)
        16 more...
    Conflict Resolution:
        ( ) Downgrade OpenOffice_org-kde-2.0.0-1.2 to Version 1.9.125-5
        ( ) Ignore Conflict and Risk System Inconsistencies
OpenOffice_org-mono 1.9.125-5 conflict
    Broken Dependencies of Installed:
        OpenOffice_org-mono requires OpenOffice_org = 2.0.0-1.2
        OpenOffice_org-mono requires libpthread.so.0
        OpenOffice_org-mono requires libstlport_gcc.so
        OpenOffice_org-mono requires libuno_cppu.so.3
        OpenOffice_org-mono requires libuno_cppu.so.3(UDK_3_0_0)
        OpenOffice_org-mono requires libuno_cppuhelpergcc3.so.3
        OpenOffice_org-mono requires libuno_cppuhelpergcc3.so.3(UDK_3.1)
        OpenOffice_org-mono requires libuno_cppuhelpergcc3.so.3(UDK_3_0_0)
        4 more...
    Conflict Resolution:
        ( ) Downgrade OpenOffice_org-mono-2.0.0-1.2 to Version 1.9.125-5
        ( ) Ignore Conflict and Risk System Inconsistencies
RealPlayer 10.0.5-8 conflict
    Broken Dependencies of Installed:
        RealPlayer requires libpthread.so.0
        RealPlayer requires libpthread.so.0(GLIBC_2.0)
        RealPlayer requires libpthread.so.0(GLIBC_2.1)
    Conflict Resolution:
        ( ) Downgrade RealPlayer-10.0.6-3.2 to Version 10.0.5-8
        ( ) Ignore Conflict and Risk System Inconsistencies
xine-lib 1.1.0-12 conflict
    Broken Dependencies of Installed:
        xine-lib requires libpthread.so.0
        xine-lib requires libpthread.so.0(GLIBC_2.0)
        xine-lib requires libpthread.so.0(GLIBC_2.1)
        xine-lib requires libpthread.so.0(GLIBC_2.2)
    Conflict Resolution:
        ( ) Downgrade xine-lib-1.1.0-12.2 to Version 1.1.0-12
        ( ) Ignore Conflict and Risk System Inconsistencies
xorg-x11 6.8.2-100 conflict
    Broken Dependencies of Installed:
        xorg-x11 requires libpthread.so.0
        xorg-x11 requires libpthread.so.0(GLIBC_2.0)
        xorg-x11 requires libpthread.so.0(GLIBC_2.1)
    Conflict Resolution:
        ( ) Downgrade xorg-x11-6.8.2-100.2 to Version 6.8.2-100
        ( ) Ignore Conflict and Risk System Inconsistencies
yast2-packagemanager 2.12.20-2 conflict
    Broken Dependencies of Installed:
        yast2-packagemanager requires libpthread.so.0
        yast2-packagemanager requires libpthread.so.0(GLIBC_2.0)
    Conflict Resolution:
        ( ) Downgrade yast2-packagemanager-2.12.21-0.1 to Version 2.12.20-2
        ( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###
as you can see it has something to do with libpthread.so.0. I can't seem to find it anywhere. can anyone help me?
 
Old 11-13-2005, 06:51 AM   #2
reeseslover531
Member
 
Registered: Nov 2005
Distribution: Fedora Core 5
Posts: 64

Original Poster
Rep: Reputation: 15
so can anyone help me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Libpthread NewStudent Linux - Software 3 09-19-2005 02:07 PM
update libpthread kernelvn *BSD 1 07-01-2005 12:23 PM
libpthread.so.0(GLIBC_2.3.2) feathersmcgraw Linux - Newbie 4 02-17-2005 03:09 AM
what's the difference between libpthread.so and libpthread.a? mmiglia Linux - Software 1 09-16-2004 08:53 AM
UT2003 - anyone know anything about libpthread? kabads Linux - General 1 10-24-2002 10:21 AM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration