LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-15-2010, 07:10 AM   #1
gich
LQ Newbie
 
Registered: Jun 2010
Posts: 2

Rep: Reputation: 0
Unhappy Libpcre error when installing snort


Hi,
I am trying to install snort on debian linux. The following error appears ERROR! Libpcre library not found. Get it from http://www.pcre.org. Well..., I have installed the Libpcre3-dev library but the error is still on.
What could I be doing wrong?
Any help will be appreciated

thanks
 
Old 06-15-2010, 09:48 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,181

Rep: Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527
Did you install a debian package? Hunt. Try finding it. check libpcre is in the pkgconfig directory. Sonmetimes you solve this with
PKG_CONFIG_PATH=[LONG LIST]
 
Old 06-15-2010, 10:36 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
Welcome to LQ.

To compile a new snort, say 2.8.5.2 .. 2.8.6,
libpcre3-dev version 6.0 or later is required.
http://www.linuxquestions.org/linux/...Ask_a_Question
But you forgot to tell which Debian and which snort.


Also : why not do # apt-get install snort
.. which will provide version 2.7.0 on Lenny.
..
 
Old 06-16-2010, 11:12 AM   #4
gich
LQ Newbie
 
Registered: Jun 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks knudfl/business_kid for the response,

Sorry I forgot to mention that I installing snort-2.8.6 on Debian Linux 4.0. I also installed debian package and my libpcre-dev is version 7.6-2.1

business_kid, I am relatively new on linux, what is the format of PKG_CONFIG_PATH=[LONG LIST]?

knudfl, apt-get install didnt work for me but is it right to assume that this will work only on lenny

Thanks again
 
Old 06-16-2010, 11:46 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
Debian 4 Etch :

Package: libpcre3 (6.7+7.4-4) :
http://packages.debian.org/etch/libpcre3
Package: libpcre3-dev (6.7+7.4-4) :
http://packages.debian.org/etch/libpcre3-dev

Where have you got libpcre-dev version 7.6-2.1 ? ?
That is the Debian 5 Lenny package.
Suggest : remove this alien? package and install the right one.

Snort-2.8.6 has no problems with pcre "6.7+7.4-4"

cd snort-2.8.6/ && ./configure && make : No errors !


About PKG_CONFIG , please use a command like this :
export PKG_CONFIG_LIBDIR=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig/
..
P.S. : The version of snort in Synaptic is 2.3.3 !
Are you quite sure of the Debian "4" ?
The command : 'cat /etc/issue' will show.
..

Last edited by knudfl; 06-16-2010 at 12:06 PM.
 
Old 06-17-2010, 03:15 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,181

Rep: Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527
For Debian:
PKGCONFIG_PATH=/usr/lib/pkgconfig:/usr/lib32/pkgconfig:/usr/local/lib/pkgconfig:/usr/local/lib32/pkgconfig; and if there's pkgconfig directories in /opt add them in as well. colons between the directories, and semicolon at the end.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting snort: ERROR: User "snort" unknown games1 Linux - Software 3 02-07-2007 08:21 PM
Error when starting up snort: bash:!/bin/sh/usr/local/bin/snort :Eent not found cynthia_thomas Linux - Software 1 11-11-2005 02:59 PM
Gtk and libpcre Gins Linux - General 13 08-31-2005 11:38 AM
snort failed: snort: symbol lookup error: undefined symbol: usmAES192PrivProtocol Emmanuel_uk Linux - Security 1 07-10-2005 10:29 AM
libpcre invalid ELF header error. geoffd4 Linux - Software 0 05-10-2004 09:30 PM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration