LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/../lib/libstdc++.s (http://www.linuxquestions.org/questions/linux-software-2/libgcc_s-so-1-version-%60gcc_4-2-0-not-found-required-by-usr-bin-lib-libstdc-s-510927/)

hferretluv 12-15-2006 09:54 PM

libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/../lib/libstdc++.s
 
libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/../lib/libstdc++.so.6)

libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/../lib/libstdc++.so.5)


Has anyone run into this one on fedora core 6 2.6.18-1.2849.fc6 i386/i686, running in smp mode. It's driving me up the wall trying to fix it and I can't find ANY fix googling for it. Have some games and some applications that have suddenly stopped working and giving me one of the two examples above, depending on what I am trying to run.

I've run into other people on other sites that are having the same problem.

If more info is needed, let me know, I will be MORE than happy to provide it.

Thank you in advance for any help you can give.

Chuong 12-16-2006 01:46 AM

What program are you trying to run.

It's a bug I think because GCC 4.2.0 is not out yet.

hferretluv 12-16-2006 10:36 AM

libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/../lib/libstdc++.s
 
Yeah, I know. gcc 4.2.0 is not out yet for most linux brands.
:confused:
The programs are SEAR & Ember from worldforge, FModxxx, and a various and few progs give me that error msg when I try to run "make". For apps, K image viewer. Keeps crashing and shows that there is a bug, but after showing the message, it starts running again. Adobe Acrobat has quit working, too, since that message about GCC has been popping up.

It's not not a virus, I have run f-prot, and it only shows the test file as the only virus on the sys.

Chkroot also shows no problems found.
I just don't know. If I still had hair, I'd be pulling it out by out in just shear frustation. Your knowing what it is or even a good swag might help. Mine are just wags.

Thank you.

Chuong 12-17-2006 01:36 AM

Well, I think it might be that the application you're trying to run is missing the libGLU.so.1.3 file. . .or was it libGLU.so.1?

Anyways, try copying the libGLU.so.1.3 file from your system /usr/lib directory and pasting it into each software's library directory.

I think that was the error that's occuring that's causing this message.

You should try searching Google if you haven't already done so.

As I've said, I have came across this error before and searching Google returned some good results. At least it made me aware that it's older software not being able to run in newer version of Linux without messing around with library files :)

Good luck anyhow.

hferretluv 12-18-2006 12:31 PM

Thread: libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/
 
Thanks, I'll give it a try. I have done some looking on google but no luck with what I have found yet, or I can't figure out what they are driving at :confused: :)

Let you know what happens, and again, Thank you.


All times are GMT -5. The time now is 10:11 AM.