LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-08-2007, 10:40 AM   #1
adasiak
LQ Newbie
 
Registered: Sep 2007
Location: Fairbanks, Alaska
Distribution: MEPIS
Posts: 18

Rep: Reputation: 0
libdvdcss and w32codecs installation blocked by missing (?) libc6


I'm trying to install libdvdcss2 and w32codecs in MEPIS 6.5. The feedback I get is:
Quote:
The following packages have unmet dependencies:
libdvdcss2: Depends: libc6 (>= 2.5-0ubuntu1) but 2.3.6-0ubuntu20.5 is to be installed
The following packages have unmet dependencies:
w32codecs: Depends: libc6 (>= 2.5-0ubuntu1) but 2.3.6-0ubuntu20.5 is to be installed
E: Broken packages
-- yet, according to APT, "libc6 is already the newest version."

According to this review of MEPIS, a person could get a repository of non-free packages called Medibuntu that would include w32codecs and libdvdcss. I added this repository to my /etc/apt/sources.list according to the instructions for Feisty Fawn here:
Code:
echo "deb http://packages.medibuntu.org/ feisty free non-free" | sudo tee -a /etc/apt/sources.list
wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update
(Naturally, I logged in as root and took out the sudo.)

Any idea why my already-installed libc6 won't do the job? Do I need a different repository?

--Paul
 
Old 10-09-2007, 10:44 AM   #2
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Not being a Mepis user I'm just guessing. I use Debian and there are various versions at different stages of maturity (stable, testing, unstable, experimental). Mixing them indiscriminately is likely to lead to the sort of errors you are seeing. My version of libc6 is 2.6.1 which suggests your Mepis install is pretty old. Although your package manager says it's the newest, it may be checking against an old list. I suspect you are trying to install packages that belong with a more recent version.

I am always a bit suspicious of these cross-distro package schemes. It's a complicated enough job for a single distro to keep its own packages consistent.

Last edited by maroonbaboon; 10-09-2007 at 10:46 AM.
 
  


Reply

Tags
libdvdcss, libdvdcss2, mepis, nonfree, repositories, repository, w32codecs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing file libstdc++-libc6.1-1.so.2 kantor_98 Linux - Newbie 3 06-06-2007 05:39 AM
Cant play movies in Mandrake - libdvdcss missing alan.daniels Linux - Newbie 2 11-29-2006 04:06 PM
libc6 is bad and files missing need to downgrade HELP!!! hisnumber666 Linux - Software 0 05-01-2006 01:24 AM
Missing the libstdc++-libc6.1.-1.so.2 library-- AAGH mst3kman Linux - Newbie 3 01-03-2006 05:50 PM
blender 3d missing libstdc++-libc6.2-2.so.3 arkamir Linux - Newbie 5 04-19-2004 11:49 AM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration