LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 06-08-2004, 12:38 AM   #1
borrrden
Member
 
Registered: May 2004
Location: Philadelphia
Distribution: Fedora Core 3
Posts: 98

Rep: Reputation: 15
libdv.so.4 is needed by (installed) gstreamer-plugins-0.8.1-1


Alright, someone please explain to me what THIS error message means.

"libdv.so.4 is needed by (installed) gstreamer-plugins-0.8.1-1"

I downloaded an rpm to install this library, and it said that it was installed already.

So what do I need to do to fix this problem (2.6.5-1 i686)
 
Old 06-08-2004, 02:25 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
I suspect it means that you're trying to install something (else) that will overwrite libdv.so.4 and doing so will break gstreamer-plugins-0.8.1-1 (which you presumably don't want to happen, or at least FC2 doesn't want it to happen on your behalf).

Therefore, libdv.so.4 cannot be removed or overwritten, which means that whatever you're installing that is trying to overwrite it can't be installed.

So what were you doing when you got this message?
 
Old 06-09-2004, 07:48 PM   #3
borrrden
Member
 
Registered: May 2004
Location: Philadelphia
Distribution: Fedora Core 3
Posts: 98

Original Poster
Rep: Reputation: 15
I was installing another program (VLC Media Player to be precise) and this error message came up.
 
Old 06-10-2004, 04:43 AM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
It looks, then, like you need to choose what you're going to use, as these two packages appear to be incompatible with each other (although there may be a later version of gstreamer-plugins that does not have this problem, or a later version of VLC than the one you're installing, which perhaps doesn't have this problem).

Or, you could use rpm with the --force-overwrite switch to force the RPM to install its version of libdv.so.4. This might still break gstreamer-plugins, though.

You might want to read man rpm or look at the Maximum RPM site to learn more about the alternative ways to use the rpm command.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GStreamer Plugins for FC3 FunkyRes Fedora 7 12-22-2004 11:29 AM
yum, gstreamer-plugins-mp3, and rhythmbox corso64 Fedora 3 10-15-2004 09:51 AM
Cant install gstreamer-plugins-mp3 short101 Linux - Software 0 07-13-2004 09:54 PM
libdv.so.4 is needed by (installed) gstreamer-plugins-0.8.1-1 borrrden Linux - General 1 06-06-2004 01:50 PM
gstreamer plugins, dependency problems donbellioni Linux - Software 1 04-04-2004 08:51 AM


All times are GMT -5. The time now is 09:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration