LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-06-2003, 02:54 AM   #1
sudhir
Member
 
Registered: Feb 2003
Distribution: redhat
Posts: 58

Rep: Reputation: 15
lib errors


Hi People

I am using RHL 7.3 on an i686 machine.

I have been facing errors while installing few files... say latest version of xpdf for example !!!

For example, they look like the following....
**
error: failed dependencies:
libc.so.6(GLIBC_2.3) is needed by xpdf-2.01-11.1
libgcc_s.so.1 is needed by xpdf-2.01-11.1
libgcc_s.so.1(GCC_3.0) is needed by xpdf-2.01-11.1
libstdc++.so.5 is needed by xpdf-2.01-11.1
libstdc++.so.5(CXXABI_1.2) is needed by xpdf-2.01-11.1
libstdc++.so.5(GLIBCPP_3.2) is needed by xpdf-2.01-11.1
**

Such errors occur sometime for other file installations too.... but similar stuff...

I guess that these library files need to be part of my comp... I have something called openmotif ... But then when I tried to get something called lesstif---.rpm, coz I found that it provides some lib files that are not currently present in my system, I get a message saying

error: failed dependencies:
lesstif <= 0.92.32-6 conflicts with openmotif-2.2.2-5

So obviously I cant have both I guess...

Please bear with me.... mez not familiar with these things... cud someone please help me with adv on what to do next ???

TIA
-- S
 
Old 11-06-2003, 04:39 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you just need to make those conditions happy. for example, go get a newer verion of lesstif, 0.92.32 or greater and upgrade to it. please look at the stiky thread in the top of Linux - General for rpm installation help
 
Old 11-08-2003, 10:58 PM   #3
sudhir
Member
 
Registered: Feb 2003
Distribution: redhat
Posts: 58

Original Poster
Rep: Reputation: 15
Thanks for ur reply.

I got lesstif-0.93.18-2.i386.rpm and installed it...

But still I get the same message ... as in my first post... Same error message..

Though, I saw this

$ locate libc.so.6
/usr/lib/debug/libc.so.6
/lib/i686/libc.so.6
/lib/libc.so.6
$

So this means that this library is present but there is some other problem right ???

And also still the other lib's like libt1.so.1 are not there...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
APT/dpkg errors! /var/lib/dpkg/status bassclarinet Debian 16 12-01-2011 10:24 AM
"Locking in" Glibc (replace prob /lib/ld-linux.so.2 with /tools/lib/ld-linux.so.2 irfanali Linux From Scratch 11 06-29-2006 11:19 AM
Error while "unzipping" rpm files, and lots of lib errors! Einar Magnus Linux - Software 0 10-09-2004 06:58 PM
Compromised? Files "/usr/lib.hwm", "/usr/lib.pwd", "/usr/lib.pwi" Klaus Pforte Linux - Security 4 09-29-2004 12:33 AM
iiimf-client-lib & iiimf-protocol-lib cooldownguy86 Linux - Software 1 06-29-2004 07:25 AM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration