LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-19-2004, 10:23 PM   #1
koodailar
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
lfs-cvs: cannot delete /tools


the cimpilation is over and system can boot normal. but if i remove the /tools directory, the init script will say udev*** cannot find , and system halt. the lfs document says the /tools can be safely removed , so i think i misoperated in lfs compilation. does any one have the same problem? or solutions .
 
Old 07-20-2004, 08:06 PM   #2
slyman
Member
 
Registered: Jun 2004
Location: Sydney, Australia
Distribution: FC3, Linux From Scratch, Knoppix
Posts: 99

Rep: Reputation: 15
*** for moderators: this should be in Linux From Scratch Forum ***

From chapter 5:

http://www.linuxfromscratch.org/lfs/...er05/udev.html

" The udevstart program hardcodes the path to the udev program in itself, which is bad since we install udev in a non-standard location. Fix this by running the following:

sed -i 's@/sbin/udev@/tools/sbin/udev@g' udevstart.c

Also assure that udev knows the correct location to look for its configuration files:

sed -i 's@/etc@/tools/etc@g' etc/udev/udev.conf.in"

I guess you did the same thing, or did not use freshly unpacked source, for the chapter 6 install of udev?

Rebuilding udev using the chapter 6 instructions should sove this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
net-tools in LFS 6.0? TLV Linux From Scratch 2 10-25-2004 03:55 AM
$LFS/tools empty after binutils install? awgriff279 Linux From Scratch 2 08-28-2004 05:57 PM
pkg-tools > 1.3.2 for LFS 5.1.1? t0mmyp Linux From Scratch 4 08-10-2004 09:11 AM
Installing X on LFS CVS euangray Linux From Scratch 1 10-18-2003 03:00 PM
cvs lfs blackcat Linux From Scratch 12 09-13-2002 12:42 PM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration