LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-13-2008, 12:40 AM   #1
aldennis
LQ Newbie
 
Registered: Feb 2004
Distribution: Gentoo
Posts: 1

Rep: Reputation: 0
Unhappy kword won't run - fails with libtool warning


I am running gentoo, and I recently got annoyed enough with abiword that I thought I would jump ship from gnome to kde to try kword.

So I emerged kword, and tried to run it. I get the following:

Code:
koffice (lib kofficecore): WARNING: Library files for ".la" not found in paths.
I tried recompiling kword, and compiling koffice-meta ebuild first (following the gentoo KDE howto), but nothing changed the failure. I tried to find out what .la files were, and ran into a dead-end in libtool land. Google was unhelpful - am I the only person experiencing this failure?

The funny thing is if I login as root, kword starts fine. However, doing all my word processing as root is not an acceptable solution (and hard to explain to my wife!).
 
Old 02-13-2008, 11:58 AM   #2
weisso5
Member
 
Registered: Oct 2007
Location: New York City
Distribution: Gentoo, FC
Posts: 133

Rep: Reputation: 16
Have you tried re-merging libtool?

Since you stated that you just switched from gnome to KDE, i assume you just performed an similar world update command:

emerge -avuD --newuse world


As Per the Gentoo documentation it is always a good practice to re-merge libtool after performing a global update.


So try this:
emerge libtool kword

see what happens. Post a Compile or further info from logs.


-weisso
 
  


Reply

Tags
gentoo, kword, libtool


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
autogen.sh fails: libtool.m4 / ltmain.sh version mismatch jrtayloriv Linux - Software 1 01-09-2008 01:06 PM
cant run desktop apps as root [Gtk-WARNING **] tidiman07 Ubuntu 1 04-12-2007 04:57 PM
Libtool link warning when upgrading pango jrdioko Linux - Software 0 01-19-2006 05:57 PM
Whenever I run Mandrake/Mandriva, a warning /hda6 exited with signal 11 dlaneir_lee Mandriva 2 07-16-2005 04:06 AM
ut2003 fails when trying to run stunix Linux - Games 5 11-29-2003 07:32 PM


All times are GMT -5. The time now is 01:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration