-   Linux - Software (
-   -   Kubuntu 9.10-some programs don't work (

PL5 11-13-2009 05:48 AM

Kubuntu 9.10-some programs don't work
Programs compiled with Lazarus (and have been working on Kubuntu 6.10, 8.04, 9.04, Suse 10, Fedora 5 etc.) don't work on K_9.10 / KDE 4.3.
(Upgrade K_9.04 -> 9.10). They started, but after first trial to select file for reading ended.
Error after 'Smith4VNA' started:
TApplication.HandleException Invalid floating point operation
Stack trace:
TApplication.HandleException: there was another exception during showing the first exception
Stack trace:
[FORMS.PP] ExceptionOccurred

(Smith4VNA:2067): Gtk-CRITICAL **: gtk_style_detach: assertion `style->attach_count > 0' failed
[FORMS.PP] ExceptionOccurred

Any similar oppinion?

PL5 11-13-2009 07:19 AM

Now i found that all works OK with root privileges only.

PL5 11-16-2009 01:21 AM

After libraries were updated (15.11.2009) it seems to be OK.

wollepatong 11-18-2009 03:15 AM

Could you please tell me, where and which libraries you updated? I am stuck in a project and cannot continue because of this problem :-(
Thank you.

PL5 11-18-2009 06:56 AM

Sorry, I don't know. It was common update from rep - about 30 packages. But the problem is not solved yet - on another comp it persists. The only difference is:
- new installation K_9.10 from DVD: now OK
- upgrade from 9.04 (CD 'alternate') - persists.

The problem occurs after the file for *reading* is selected in dialog. If the file is selected *without* dialog (its name is defined inside the program), it works OK.

The selection file name for *writing* works OK every time.

All is OK if the program is started with root privileges (i.e. sudo <prog_name> ).

wollepatong 11-18-2009 11:34 PM


Originally Posted by PL5 (Post 3761217)
But the problem is not solved yet - on another comp it persists. The only difference is:
- new installation K_9.10 from DVD: now OK
- upgrade from 9.04 (CD 'alternate') - persists.

I did an upgrade with the alternate CD, too. The fastest way to reproduce the error here is to open the menu 'Package', then select 'Open package file'. The follwing dialog will show for a blink of the eye and then it goes boom :-(

I am not in a mood to do a complete reinstall, but if that is the only way to get up and running...

PL5 11-19-2009 02:44 AM

Yes. But what about 'sudo startlazarus' ? It works for me.

wollepatong 11-19-2009 10:55 PM

sudo startlazarus works here, too. The problem is, you can compile programs using sudo, but these will only run as sudo, if run by a 'normal' user they will crash and burn :-( I will try lazarus now on another machine which is a clean setup, and if that works I will do a re-install of Karmic. Grrrr....

PL5 11-20-2009 04:16 AM

May be solution: change Widget style from 'QtCurve' to 'Raleigh'.
( Appearance -> GTK+Appearance -> Widget style )
Now all works OK :-)

wollepatong 11-20-2009 04:32 AM

Amazing! You are a genius! This is it! It works!

Whenever you come to Phuket, we will have some beers on your findings... Thank you for this hint.

Edited to add:

I tried to run Lazarus on a clean install from CD before I read your comment, I did not work. In another desperate move, I tried it on a live system running from the DVD, no dice. But re-thinking it was all this QTCurve-appearance, which - by the way - I don't like anyway. Now I will have to explain this to the customers :-( Hopefully it will be fixed some day. Raleigh does it.

All times are GMT -5. The time now is 07:14 PM.