LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-09-2003, 06:34 AM   #1
guerilla fighta
Member
 
Registered: Feb 2002
Distribution: SuSE 8.2
Posts: 62

Rep: Reputation: 15
KPPP - wrong option 'passwordfd'


Im tyring to use kppp to connect to the internet using my modem (a connexant one, btw). When i try to connect the modem dials, but before it can finish dialing i get a message box pop up and say the pppd daemon died unexpectedly.

I get this error: exit code 2, wrong option "passwordfd"

This is the contents of the error file it rights:

Feb 9 11:27:32 linux pppd[2137]: unrecognized option 'passwordfd'

Any suggestions?
 
Old 02-09-2003, 06:50 AM   #2
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Where's you get the drivers? Do you have a HCF or HSF modem? Did you get the right drivers for type? Have you put anything in the kppp box of extra options to pass to ppp?
 
Old 02-09-2003, 04:49 PM   #3
guerilla fighta
Member
 
Registered: Feb 2002
Distribution: SuSE 8.2
Posts: 62

Original Poster
Rep: Reputation: 15
Ive got the right drivers, for my modem and my distro. Ive got an HCF modem so i got the conexant HCF drivers from linmodems.org for the 2.4.19_4GB kernel (suse 8.1).

The only things i set up in kppp was the account information (dialing number .etc) and i checked the 'query modem' worked fine. The strange thing is i havent added any extra info to pass to ppp. I also check through the ppp man page and i couldnt even find a parameter called 'passwordfd'; kppp is obviously trying to pass info to a parameter in ppp that doesnt exist.

I had some trouble getting kppp to work at first as it was asking for some file or whatever. I created the file in the /etc dir, and gave the file the same options as all the other files. I dont think ive tried using kppp as root, so i might re-install the package and try again.
 
Old 02-10-2003, 02:13 PM   #4
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Tried a different verification method, eg PAP not CHAP? Just an idea...
 
Old 02-10-2003, 05:33 PM   #5
guerilla fighta
Member
 
Registered: Feb 2002
Distribution: SuSE 8.2
Posts: 62

Original Poster
Rep: Reputation: 15
I erased the kppp package (kdenetwork3-dialup on suse 8.1) and then re-installed it from my suse disc. It said I didnt have the right permissions, so I did a:

chmod a+s /opt/kde3/bin/kppp

on the kppp file. Now i can access kppp fine, which pretty much clears up the problem above.

Now a new problem has developed. I dont think this is anything taxing, but the dial-up decides to restart when it is just about to complete. Im not sure why this is ?
 
Old 02-10-2003, 07:45 PM   #6
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 7
Posts: 1,253

Rep: Reputation: 55
http://sdb.suse.de/en/sdb/html/randall_kppp_suid.html

The above link may be of help to you.

I gave up and use kinternet and wvdial in SuSE 8.0

Good Luck
 
Old 02-12-2003, 04:00 PM   #7
guerilla fighta
Member
 
Registered: Feb 2002
Distribution: SuSE 8.2
Posts: 62

Original Poster
Rep: Reputation: 15
KPPP now opens up fine. Its just that the dialing process stops before it can complete, and then restarts itself; like a never ending loop. I just need to know how to stop kppp from entering this 'loop' and dial up properly.

The troubleshooting info in the kppp help didnt seem to be much use, and ive had little luck finding some info about this problem on google.
 
Old 02-12-2003, 05:00 PM   #8
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Tried increasing the timeout settings?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shaded automatic dns option in kppp awl Linux - Software 0 08-28-2005 04:04 PM
kppp kde 3.2 suse 9.0 unknown option passwordfd thk33 Linux - Software 0 11-20-2004 12:32 PM
I chose the wrong option for kernel. Do I need to re install? [Slack 10] madbrain Slackware - Installation 6 09-06-2004 03:41 PM
wrong fs type, bad option, etc. etc. lyceum Linux - Newbie 4 06-28-2004 03:18 PM
Cannot Mount a Partition, wrong FS type, bad option etc. dsuratman Linux - Newbie 13 11-16-2003 07:07 AM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration