LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-09-2004, 05:24 PM   #1
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Rep: Reputation: 15
kmail - cannot connect to smtp server.


I can receive mail using kmail, but I cannot send. I'm at wits end trying to find out what the problem is. I keep getting the following message:-

Quote:
Send failed:
Could not connect to host smtphost.suffolk.lib.ny.us.
This message will remain in your outbox .. etc.
The mail logs always have the following kind of messages:-
Nov 9 16:38:03 linux postfix/smtp[4264]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 16:38:03 linux postfix/smtp[4264]: 79E0B16EC9: to=<[my_user_name]@suffolk.lib.ny.us>, relay=none, delay=98379, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)
Nov 9 16:38:04 linux postfix/smtp[4259]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 16:38:04 linux postfix/smtp[4259]: 15CDD32B2E: to=<[my_user_name]@suffolk.lib.ny.us>, relay=none, delay=97894, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)

From my lookup of the term postfix - it is a mail server. So presumably kmail is transferring the request to send out the mail to postfix, rather than sending them out itself. I don't see postfix running on my system and have no idea how to start or configure it.

I know for a fact that the smtphost.suffolk.lib.ny.us is fine because I use it with outlook express all the time. I even connect to it using my personal (handwritten) mail client.

Would be grateful to anyone who can help.
 
Old 11-09-2004, 06:18 PM   #2
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 31
Bizarre!

Have you tried configuring an alternative mail client - eg, mozilla, evolution, etc..?
 
Old 11-09-2004, 09:18 PM   #3
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Original Poster
Rep: Reputation: 15
I tried you suggestion with ximian evolution. Same thing, I get:
Quote:
Error while performing operation:
Could not connect to smtphost.suffolk.lib.ny.us (port 25): Connection timed out
I haven't looked at var/log/mail yet. I've to log on as root to read that. I'll post another
msg in a few minutes with that info.

Also I found the postfix configuration file. Based on my limited understanding, I cant see
any obvious issues except perhaps for this:-

Quote:
## Type: yesno
## Default: no
## Config: postfix
## ServiceRestart: postfix
#
# A null client is a machine that can only send mail. It receives no
# mail from the network, and it does not deliver any mail locally.
# A null client typically uses POP or NFS for mailbox access.
# NOTE: This overrides the following variable: POSTFIX_LOCALDOMAINS
#
POSTFIX_NULLCLIENT="no"
Since I'm on a standalone system, I guess that it should be POSTFIX_NULLCLIENT="yes".
I dont know if changing it would make any difference.

Last edited by emeskay; 11-09-2004 at 09:19 PM.
 
Old 11-09-2004, 10:15 PM   #4
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Original Poster
Rep: Reputation: 15
Here are the messages fro var/log/mail :

Quote:
Nov 9 22:48:59 linux postfix/qmgr[3314]: 15CDD32B2E: from=<lxuser@linux.site>, size=478, nrcpt=1 (queue active)
Nov 9 22:48:59 linux postfix/qmgr[3314]: 1F26332A2A: from=<lxuser@linux.site>, size=458, nrcpt=1 (queue active)
Nov 9 22:48:59 linux postfix/qmgr[3314]: 26AC732A2E: from=<lxuser@linux.site>, size=478, nrcpt=1 (queue active)
Nov 9 22:48:59 linux postfix/qmgr[3314]: 31F0F16CC3: from=<lxuser@linux.site>, size=1811, nrcpt=1 (queue active)
Nov 9 22:49:00 linux postfix/qmgr[3314]: 79E0B16EC9: from=<lxuser@linux.site>, size=478, nrcpt=1 (queue active)
Nov 9 22:49:31 linux postfix/smtp[4502]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 22:49:31 linux postfix/smtp[4502]: 31F0F16CC3: to=<[some_user].com>, relay=none, delay=125881, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)
Nov 9 22:49:31 linux postfix/smtp[4500]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 22:49:31 linux postfix/smtp[4500]: 1F26332A2A: to=<[me]@suffolk.lib.ny.us>, relay=none, delay=124238, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)
Nov 9 22:49:32 linux postfix/smtp[4498]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 22:49:32 linux postfix/smtp[4498]: 15CDD32B2E: to=<[me]@suffolk.lib.ny.us>, relay=none, delay=120182, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)
Nov 9 22:49:32 linux postfix/smtp[4501]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 22:49:32 linux postfix/smtp[4501]: 26AC732A2E: to=<[me]@suffolk.lib.ny.us>, relay=none, delay=120469, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)
Nov 9 22:49:32 linux postfix/smtp[4503]: connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out (port 25)
Nov 9 22:49:32 linux postfix/smtp[4503]: 79E0B16EC9: to=<[me]@suffolk.lib.ny.us>, relay=none, delay=120668, status=deferred (connect to smtphost.suffolk.lib.ny.us[209.139.23.58]: Connection timed out)
Also I just realized (from the time stamps) that this one track automaton - postfix - keeps trying to send these messages every few minutes. So the mail file keeps getting bigger and bigger. I'm not sure if these messages are the kmail ones, the evolution ones or both.

Notice the "from" address in the first few [qmgr] lines. That doesn't seem right. But maybe they are from a much older session when I hadn't set the name of the mail server - I dont know how to tell.

I just rebooted to NT and sent an e-mail to myself using this smtp server. So the server is definitely ok.

Thanks for any help.

Last edited by emeskay; 11-09-2004 at 10:21 PM.
 
Old 11-10-2004, 12:08 PM   #5
chrisbkillian
LQ Newbie
 
Registered: May 2004
Location: Delaware, USA
Posts: 8

Rep: Reputation: 0
turn off the encryption

i had the same problem.

in your server settings, turn off all of the TLS, etc etc options for your smtp server.

i don't think the autodetect feature is 100% accurate.

that solved my problem.
 
Old 11-10-2004, 01:24 PM   #6
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Original Poster
Rep: Reputation: 15
I never turned it on to start with - I don't think the server supports it. The authentication method is also plaintext because that is what the server supports.

I suspect that I need to configure postfix. But I'm not sure what parameters I need to set. I am on a single machine connected via cable and a hardware router to my ISP. Anyone know how to configure postfix in this case? I suspect that the issue is the "from" address which postfix thinks is "linux.site". See the var/log messages a couple of posts above. How can I get it to put a valid "from" address?

Also there seems to be no way to empty the deferred messages queue in postfix. Messages that fail to be sent the first time are put in this queue and periodically retried. Since I know these are never going to be sent I would like to purge the queue as all it is doing is taking up resources and filling up the mail log.

How irritating! Can't even send a simple e-mail!

Last edited by emeskay; 11-10-2004 at 01:30 PM.
 
Old 11-10-2004, 05:13 PM   #7
chrisbkillian
LQ Newbie
 
Registered: May 2004
Location: Delaware, USA
Posts: 8

Rep: Reputation: 0
out of curiosity, why are you using postfix?
 
Old 11-10-2004, 06:55 PM   #8
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Original Poster
Rep: Reputation: 15
Kmail is using postfix.
 
Old 11-10-2004, 10:34 PM   #9
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Original Poster
Rep: Reputation: 15
OK, the problem is finally solved.

The story is as follows:-

First I got rid of the "from" address <lxuser@linux.site> that postfix was using that isn't a fully qualified domain name. I did this by adding an entry:

lxuser@linux.site [me]@[my_email_provider].com

to the "sender_canonical" file in /etc/postfix.

There also needs to be an entry in main.cf in /etc/postfix like:
sender_canonical_maps = hash:/etc/postfix/sender_canonical
which tells postfix that the map is in sender_canonical. This entry was already there.

Once I did this and refreshed postfix, at least the mail logs started showing my email address as the "from" address. However I still could not connect. I was getting the same error!!

[Now here comes the embarassing bit]:-

Then I thought - let me boot into NT, send an e-mail using Outlook express and see what the detailed headers look like. I did this and to my surprise I didn't see "smtphost.suffolk.lib.ny.us" anywhere in the headers. In other words OE wasn't using the mail server that I had thought it was using at all! In fact it was using hotmail servers and the hotmail servers had been set as default. So could the problem be with the .lib server?

So I set the default server back to the .lib server and voila - I could not connect with OE. Then a memory came flooding back - Sometime last year I had changed the default e-mail account in OE to hotmail because .lib server had mysteriously stopped working. I had forgotten about it and all the time I thought that I was using the .lib server for SMTP. The reason it had stopped working was that my ISP (optimum online) had silently filtered out port 25 requests because of spam issues. But hotmail's account continued working because it is http based. So in fact I cannot use any e-mail server on port 25.

However I can use optimum online's mail server on port 25. So I changed the smtp settings to mail.optonline.com and to my relief everything worked - and not a moment too soon.

Such was the manner in which an imminent nervous breakdown was prevented.
Thanks for your moral support :-)

Last edited by emeskay; 11-10-2004 at 10:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KMail could not connect to host joe2280 Linux - Software 1 09-26-2005 07:12 AM
Kontact/Kmail not keeping SMTP settings Ishkabibble Linux - Software 3 02-24-2005 02:53 PM
SuSE 9.0 with KDE 3.21 - KMail SMTP failure ima Linux - Distributions 0 04-05-2004 03:47 PM
Can't connect to RedHat 9 SMTP server from XP bper Linux - Networking 1 10-22-2003 09:07 AM
SMTP and KMail and SMTP and Netscape Mail jazz... Linux - Newbie 5 10-11-2003 03:49 AM


All times are GMT -5. The time now is 07:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration