LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   klauncher error (http://www.linuxquestions.org/questions/linux-software-2/klauncher-error-466180/)

Valkyrie_of_valhalla 07-21-2006 05:55 AM

klauncher error
 
For a while now I get this error in many programs, such as amarok when it tries to get album covers from amazon.com, and ktorrent and dc_qt don't work any more because of this as well.
The error says something like
Could not start process Unable to create io-slave: klauncher said Error loading "kio_http"

What is this error about? Did I install or uninstall something I shouldn't have? It appeard all of a sudden, after at first amarok didn't want to start at all, but after an update, it starts, and works ok, except for this message. Also, some programs have in Help a web page address, If I click on that, it opens firefox and displays the same error.

Any idea what and why this could be? I don't even know what to search about, as I don't know what klauncher is, or why this is happening. Sorry to bother everyone so much with my questions, I am trying to learn. Thanks again. Any info is welcomed.

gkiagia 07-26-2006 09:00 AM

I don't really know the answer to it but I have some ideas.
Both klauncher and kio_http are parts of kde. kde uses qt. Sometimes, using different versions of different parts of kde and qt causes problems. Maybe you upgraded either qt or some parts of kde and kio_http doesn't work anymore.
What I suggest is either reinstall kde and qt from the suse dvd or cds or upgrade to the latest stable version of qt and kde (qt 3.3.6 and kde 3.5.3)

Now I see kio_http is a shared library. Maybe you uninstalled another library that was necessary for kio_http. You can do
Code:

ldd /opt/kde3/lib/kde3/kio_http.so | grep found
to see if you are missing any shared libraries that kio_http uses (although I think the problem is not there).

Valkyrie_of_valhalla 07-26-2006 01:34 PM

Well, as usual, you have good ideas.
On these occasions, I found out what a messed-up system I have... I need to reinstall everything, but that will happen in a month from now.

So let's see what we have...
1) when I type that thing in the console, I get
/opt/kde3/lib/kde3/kio_http.so: /usr/kerberos/lib/libgssapi_krb5.so.2: no version information available (required by /opt/kde3/lib/kde3/kio_http.so)

2) I checked what my good ol' Yast has to say about this. The package that contains kio_http.so is kdelibs3, which has an upgrade available on one of the servers I have set as "instalation source". I put it to check the dependencies... I think this might be relevant:

#### YaST2 conflicts list - generated 2006-07-23 12:12:09 ####

evolution-data-server 1.4.0-5 conflict
Conflict Resolution:
( ) Downgrade evolution-data-server-1.4.0-5.2 to Version 1.4.0-5
( ) Ignore Conflict and Risk System Inconsistencies
gnome-vfs2 2.12.0-9 conflict
Conflict Resolution:
( ) Downgrade gnome-vfs2-2.12.0-9.2 to Version 2.12.0-9
( ) Ignore Conflict and Risk System Inconsistencies
heimdal-lib 0.6.2-8.1 conflict
Required by:
MPlayer requires libgssapi.so.1
kdelibs3 requires libgssapi.so.1
Conflicts with:
nfs-utils requires libgssapi_krb5.so.2(gssapi_krb5_2_MIT)
cyrus-sasl-saslauthd requires libkrb5.so.3(krb5_3_MIT)
nfs-utils requires libkrb5.so.3(krb5_3_MIT)
nfs-utils requires libkrb5support.so.0
Conflict Resolution:
( ) Remove All 2 Conflicting Packages
Delete nfs-utils
Delete cyrus-sasl-saslauthd
( ) Remove All 75 Referring Packages
Delete susehelp_en
Delete kdepim3-kpilot
Delete knights
Delete kdemultimedia3-extra
Delete kaffeine-gstreamer
Delete kdebase3-session
Delete kdegraphics3-postscript
Delete kdenetwork3-vnc
67 more...
( ) Ignore Conflict and Risk System Inconsistencies
libdirectfb-0.9.so.24 not available
Required by:
MPlayer requires libdirectfb-0.9.so.24
Conflict Resolution:
( ) Remove the Referring Package
Do Not Install MPlayer
( ) Ignore Conflict and Risk System Inconsistencies
libldap-2.3.so.0 not available
Required by:
MPlayer requires libldap-2.3.so.0
Conflict Resolution:
( ) Remove the Referring Package
Do Not Install MPlayer
( ) Ignore Conflict and Risk System Inconsistencies
libslang.so.2 not available
Required by:
MPlayer requires libslang.so.2
Conflict Resolution:
( ) Remove the Referring Package
Do Not Install MPlayer
( ) Ignore Conflict and Risk System Inconsistencies
libslang.so.2(SLANG2) not available
Required by:
MPlayer requires libslang.so.2(SLANG2)
Conflict Resolution:
( ) Remove the Referring Package
Do Not Install MPlayer
( ) Ignore Conflict and Risk System Inconsistencies
libsmbclient 3.0.20-4 conflict
Conflict Resolution:
( ) Downgrade libsmbclient-3.0.20b-3.5 to Version 3.0.20-4
( ) Ignore Conflict and Risk System Inconsistencies
libx264.so.47 not available
Required by:
MPlayer requires libx264.so.47
Conflict Resolution:
( ) Remove the Referring Package
Do Not Install MPlayer
( ) Ignore Conflict and Risk System Inconsistencies
MozillaFirefox 1.0.6-16 conflict
Conflict Resolution:
( ) Downgrade MozillaFirefox-1.0.8-0.2 to Version 1.0.6-16
( ) Ignore Conflict and Risk System Inconsistencies
MPlayer 1.0pre8-4 conflict
Unresolved Requirements:
MPlayer requires libdirectfb-0.9.so.24
MPlayer requires libldap-2.3.so.0
MPlayer requires libslang.so.2
MPlayer requires libslang.so.2(SLANG2)
MPlayer requires libtheora.so.0(libtheora.so.1.0)
MPlayer requires libx264.so.47
MPlayer requires libxvidcore.so.4
Conflict Resolution:
( ) Do Not Install MPlayer
( ) Ignore Conflict and Risk System Inconsistencies
openssh 4.1p1-10 conflict
Conflict Resolution:
( ) Downgrade openssh-4.1p1-10.4 to Version 4.1p1-10
( ) Ignore Conflict and Risk System Inconsistencies
samba 3.0.20-4 conflict
Conflict Resolution:
( ) Downgrade samba-3.0.20b-3.5 to Version 3.0.20-4
( ) Ignore Conflict and Risk System Inconsistencies
samba-client 3.0.20-4 conflict
Conflict Resolution:
( ) Downgrade samba-client-3.0.20b-3.5 to Version 3.0.20-4
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###


Now, what do I have to do about this? Downgrade everything and install the upgrade?
Another issue is that everything that begins with "kde" has an upgrade available. What do I need to upgrade exactly (if anything)?
And the qt3 also has an upgrade. Do I upgrade this too?

Thanks again, you got the third beer. And please excuse all my newbie questions.

PS the weird thing is that I remember I uninstalled mplayer a few weeks ago (because it never worked), and I installed heimdal-lib when I was trying to install mplayer, also a long time ago, and now it says it's not installed... weird...

gkiagia 07-27-2006 11:46 AM

First of all, delete MPlayer. It is not usable with all these missing dependencies anyway.
Your problem is that you installed heimdal-lib (which is an alternative for kerberos5) although kio_http, nfs-utils and cyrus-sasl-saslauthd probably require kerberos5 (krb5).
However kdelibs3 was upgraded and requires libgssapi.so.1 which is part of heimdal-lib but it is also provided as a separate package, libgssapi.

To solve it, remove heimdal-lib and install the newest versions of krb5 and libgssapi as well as the newest version of kdebase3 and all the other kde* packages (qt must be upgraded too for that). Any questions? :)

Quote:

Originally Posted by Valkyrie_of_valhalla
Another issue is that everything that begins with "kde" has an upgrade available. What do I need to upgrade exactly (if anything)?
And the qt3 also has an upgrade. Do I upgrade this too?

You upgrade only the packages that are already installed. Yes, you upgrade qt3 too but only those qt3* packages that are already installed. (Those that are not installed are probably useless for you and that's why you haven't installed them yet ;) )
Quote:

Originally Posted by Valkyrie_of_valhalla
PS the weird thing is that I remember I uninstalled mplayer a few weeks ago (because it never worked), and I installed heimdal-lib when I was trying to install mplayer, also a long time ago, and now it says it's not installed... weird...

heimdal-lib IS installed and you probably reinstalled mplayer ignoring its dependencies.
Quote:

Originally Posted by Valkyrie_of_valhalla
Thanks again, you got the third beer.

I didn't get that beer yet. I will get it when you solve the problem with kio_http.so :D
Quote:

Originally Posted by Valkyrie_of_valhalla
And please excuse all my newbie questions.

I forgive you :jawa: :Pengy: :D

Valkyrie_of_valhalla 07-27-2006 02:35 PM

Lots of questions.

1) How do I delete mplayer? True, I installed it once ignoring the dependencies. I was pissed off because I couldn't get my mpegs working, and thought what the heck, I'll give this a try too... When I saw it didn't work, I uninstalled that rpm. Now it doesn't show that it's installed. I also ran a search for any files or folders named mplayer. I have one empty /etc/mplayer (that is 0 files, including hidden folders), and that's about it in the system folders.
with a find / -name *mplayer* I also found:
/usr/lib/libvisual/input/input_mplayer.la
/usr/lib/libvisual/input/input_mplayer.so
But I think that comes from a libvisual-plugins rpm that is installed...

2) Heimdal doesn't appear installed as well. I have krb5 and libgssapi installed, and at the maximum version yast can find on that server. What I might have done is that maybe - i don't remember for sure - I might have tried to install heimdal from source... but I doubt it worked. I never manage to install anything from source! Also, I can't find any files or folders containing the word heimdal.

3) When I try to install kdebase3, it shows it has basicly the same dependencies as kdelibs... (Probably because it automaticaly sellects kdelibs too...)
And I also have something called kdebase-SUSE installed, and it is red... the version I have is 10.0-21.5 and it wants me to downgrade it to 10.0-21 I guess it is a more stable version or something... Do I downgrade?

4) Tried upgrading qt3. It says it can't acces the upgrade server to get it! I tried searching for it on rpm.pbone.net, but it doesn't seem to have it...

5) Is it me or is it easier to just format everything and reinstall? Nah, I never take the easy way, this is the only way I can learn...

6) An off-topic yes/no question from another topic nobody replied to...
If I need to install the spca5xx driver from source (as I can't find the rpm for my kernel version, darn kernel upgrade!), do I need to install kernel-source too? I just thought I should ask before installing a 200Mb rpm, and in order not to mess up my system more than it already is...

And trust me, you deserve even a fourth beer :)

gkiagia 07-28-2006 09:14 AM

Quote:

Originally Posted by Valkyrie_of_valhalla
1) How do I delete mplayer? True, I installed it once ignoring the dependencies. I was pissed off because I couldn't get my mpegs working, and thought what the heck, I'll give this a try too... When I saw it didn't work, I uninstalled that rpm. Now it doesn't show that it's installed. I also ran a search for any files or folders named mplayer. I have one empty /etc/mplayer (that is 0 files, including hidden folders), and that's about it in the system folders.
with a find / -name *mplayer* I also found:
/usr/lib/libvisual/input/input_mplayer.la
/usr/lib/libvisual/input/input_mplayer.so
But I think that comes from a libvisual-plugins rpm that is installed...

Damn! According to the Yast conflicts list, I can say that mplayer is either installed or that yast is trying to install it. Try
Code:

sudo rpm -e MPlayer --nodeps
to remove it if it is installed. Also verify that you don't have any local directory as an installation source and MPlayer.rpm is in that directory. If the search has provided correct results, then mplayer is not actually installed but it may be installed in the packages database only. Try also
Code:

sudo rpm -e MPlayer --nodeps --justdb
EDIT: Now that I see it again, mplayer is not installed. Either you selected to install it accidentally or yast is trying to install it from somewhere. Do a search for it in yast, and if you find it, set it to the taboo state so that it cannot be installed automatically.

Quote:

Originally Posted by Valkyrie_of_valhalla
2) Heimdal doesn't appear installed as well. I have krb5 and libgssapi installed, and at the maximum version yast can find on that server. What I might have done is that maybe - i don't remember for sure - I might have tried to install heimdal from source... but I doubt it worked. I never manage to install anything from source! Also, I can't find any files or folders containing the word heimdal.

That's really strange. Try again the commands above with heimdal-lib in the place of MPlayer. If heimdal was installed from source, it wouldn't display in yast. Also reinstall (the same way you would update them) krb5 and libgssapi. You might want to use the suse 10.1 versions from http://download.opensuse.org/distrib...ss-inst-source (this is a yast installation source, the rpms are in the suse/i586 subdirectory). Or try some more unstable but recent packages from the suse factory repository (see my answer to question 4)

Quote:

Originally Posted by Valkyrie_of_valhalla
3) When I try to install kdebase3, it shows it has basicly the same dependencies as kdelibs... (Probably because it automaticaly sellects kdelibs too...)
And I also have something called kdebase-SUSE installed, and it is red... the version I have is 10.0-21.5 and it wants me to downgrade it to 10.0-21 I guess it is a more stable version or something... Do I downgrade?

NO. Don't downgrade. The more stable is the newer version that you have. Yast is just so stupid to understand that (I hope novell do something about this).
kdebase3 requires kdelibs3 and yes, it selects it automatically. what's the problem here?

Quote:

Originally Posted by Valkyrie_of_valhalla
4) Tried upgrading qt3. It says it can't acces the upgrade server to get it! I tried searching for it on rpm.pbone.net, but it doesn't seem to have it...

Add this server as an installation source: http://download.opensuse.org/distrib...y/inst-source/ and get kde and qt3 from there. (This repository contains quite unstable packages but they do work! They might have minor bugs that you may never notice)

Quote:

Originally Posted by Valkyrie_of_valhalla
5) Is it me or is it easier to just format everything and reinstall? Nah, I never take the easy way, this is the only way I can learn...

Well, it is easier to format but I like the hard way too. Self-education is important :study:

Quote:

Originally Posted by Valkyrie_of_valhalla
6) An off-topic yes/no question from another topic nobody replied to...
If I need to install the spca5xx driver from source (as I can't find the rpm for my kernel version, darn kernel upgrade!), do I need to install kernel-source too? I just thought I should ask before installing a 200Mb rpm, and in order not to mess up my system more than it already is...

If you install from source, you need kernel-source (because you said it is a driver. I don't know what it really is). If you install an rpm, you don't need kernel-source. As simple as that.

Quote:

Originally Posted by Valkyrie_of_valhalla
And trust me, you deserve even a fourth beer :)

lol :p :p

gkiagia 07-28-2006 09:27 AM

And some things I forgot.

1) Conflicts like this...
Quote:

gnome-vfs2 2.12.0-9 conflict
Conflict Resolution:
( ) Downgrade gnome-vfs2-2.12.0-9.2 to Version 2.12.0-9
( ) Ignore Conflict and Risk System Inconsistencies
...are not conflicts. As I said, yast is so stupid to understand that you have installed a newer version and it wants to install the version shipped with suse 10.0

2)A more quick solution is: remove all internet installation sources, add the suse factory repository installation source (the link is in my answer to question 4 above), then select to upgrade all kde* and qt3 packages that are installed, also select to upgrade krb5 and libgssapi even if you have the latest version installed and click on accept. Yast will handle all the dependencies and about 1-2 hours later, you will have everything fixed. (I hope) :jawa: ...and don't forget to reboot after the upgrade.

3) If the above solution doesn't work, FORMAT EVERYTHING AND REINSTALL!!! :D It is a lot easier...

Valkyrie_of_valhalla 07-28-2006 09:38 AM

Tried uninstalling from the console. Result:
error: MPlayer is not installed
error: heimdal-lib is not installed

I reinstalled krb5 and libgssapi. No change.

Trying to add the server as source. It just gets to the "reading package information" bit and that's it... I can't even kill it! It freezes there. I think it's better to just install them from rpm.pbone.net.
BRB after I figure out how to kill that window...

Valkyrie_of_valhalla 07-28-2006 09:49 AM

Eh, too much trouble... To reinstall every package and redownload everything will take ages... But I'l ldo this too, just not now. I'm too lazy...
I will format everything anyway in a month, because I need to clean and repartition my hard-drive.

spca5xx is a webcam driver. darn, so I do have to wait and download the 200Mb kernel source... and I don't even know if I will be able to use it...

Anyway, another short off-topic question. You don't happen to know of a linux version that can be installed from a floppy, do you? I'm thinking of reinstalling my old 286 computer, mostly for experimenting and learning purposes, and it has a 40MB hard drive, and just a floppy drive. Maybe an edition with a window manager if it's not too much to ask...

gkiagia 07-28-2006 10:48 AM

Quote:

Originally Posted by Valkyrie_of_valhalla
Trying to add the server as source. It just gets to the "reading package information" bit and that's it... I can't even kill it! It freezes there..

It doesn't freeze. It downloads the list of packages and yes, you can't kill it (stupid yast). It took me about half an hour for this message to disappear when I added it and I have a 512 Kbit download bandwidth, which means it downloaded about 100 MB of data.

Anyway, too much trouble for nothing. If you are going to repartition the drive...

By the way, if you are going to reinstall both windows and linux, you won't need to do all these changes to menu.lst and run bootcfg from the winxp cdrom as I told you in the other post. You just reinstall everything (windows first).

Quote:

Originally Posted by Valkyrie_of_valhalla
Anyway, another short off-topic question. You don't happen to know of a linux version that can be installed from a floppy, do you? I'm thinking of reinstalling my old 286 computer, mostly for experimenting and learning purposes, and it has a 40MB hard drive, and just a floppy drive. Maybe an edition with a window manager if it's not too much to ask...

Yes, I do. That's muLinux. Search for it! It can even run from the floppy for systems without a hard disk. It has old but stable versions of linux software that can even run on a system with 8 MB RAM.

I hope moderators are not so angry that we talk about all topics in all of your threads. :D

Valkyrie_of_valhalla 07-29-2006 03:14 AM

Ok, that explains why it took so much for my 128kb bandwidth to get the package list from the server... :)

Hmm... nah, I don't think the mods are too upset, it is kinda related...

Anyway, if you want to talk about more topics, my ymess id is dark_ky_666. You seem like a nice guy, and people like that are hard to find. Maybe this way I'll have a chance to help you with something, who knows, I owe you a lot (besides those 4 beers).


All times are GMT -5. The time now is 12:05 AM.