LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-26-2007, 12:40 PM   #1
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Rep: Reputation: 30
keyboard shortcut in xfce/beryl


I am having some difficulty getting certain keyboard shortcuts to work in xfce with beryl as window manager. What I'd like to do is have the main xfce menu open up when I hit, say, <Control><Alt>m. I can get the menu to open if I open up a terminal and type "xfce4-popup-menu" but nothing at all happens after I set the keyboard shortcut I want to run the same command. Other shortcuts work just fine. For example <Alt>a opens up a terminal, and my shortcut for that simply consists of the command "gnome-terminal." All of this is set in the beryl-manager. Is there something I am missing about the way terminal emulators or window managers work that would prevent me from doing what I want here?

I used to use fluxbox with a ton of different keyboard shortcuts including one to open the fluxbox menu, but I seem to have gotten, um, hooked on the whole 3d desktop thang.

Any ideas anyone?

Thanks,
geo

BTW I am running Slackware 12.0, with dropline gnome and the default version of xfce that is included with Slack 12.0.
 
Old 09-27-2007, 05:14 AM   #2
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Gentoo developers has mask Beryl, so it is still experimental and may not work as expected. In Xfce4, change its keyboard shortcuts. I suggest to make sure the shortcuts work in Xfce4, do not use Beryl. If the shortcuts work, than you can blame Beryl.
 
Old 09-27-2007, 12:15 PM   #3
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Original Poster
Rep: Reputation: 30
Thanks for the response. I did manage to get it working by deleting the default shortcut key for the menu in xfce and then adding my own new one.

-geo
 
Old 09-28-2007, 02:57 AM   #4
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
You do not have to delete the default keyboard shortcut. You just create a new keyboard shortcut profile.
 
Old 09-28-2007, 11:35 AM   #5
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Original Poster
Rep: Reputation: 30
OK, thanks. I suppose that is the better way to do it.
Cheers,
geo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard shortcut for a link? newbiesforever Linux - General 2 08-02-2007 02:38 PM
emerged xfce, beryl, and XGL... mouse buttons no longer work hedpe Linux - Software 3 02-02-2007 06:17 PM
Keyboard and it's shortcut keys ZakuSage Linux - Hardware 4 06-13-2005 03:11 PM
Keyboard-shortcut mystery Ander Linux - Software 2 01-15-2005 02:45 PM
Keyboard Shortcut wildcat22 Linux - General 1 09-27-2004 11:33 AM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration