LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-21-2004, 02:17 PM   #1
janisj
Member
 
Registered: Jul 2003
Location: Hesse, Germany
Distribution: Fedora Core 1
Posts: 38

Rep: Reputation: 15
Keyboard problem after deleting /var, installing Ximian and other !#$"&$


My keyboard does not display some characters correctly anymore. For example, for pipe it shows:
1) here or OO: (nothing);
2) in xterm: ^[<
3) virtual terminals (<ctrl>+<alt><1-6>): show pipe ok

delete shows:
1) here or OO: (no action);
2) in xterm: ^[[3~
3) virtual terminals: function fine

other keys around 'delete' show similar things, only the 3 is replaced with sth else. Basically nothing where more that lower- or uppercase works. With my German keyboard I use <Alt-Gr>+<the key next to SHIFT> for pipe, but nothing else with <Alt-Gr> works. This includes 'at' for e-mail and 'tilde' for home directory. A real headache!

In XFree86.0.log it says:

(II) Keyboard "Keyboard0" handled by legacy driver
(**) Option "Protocol" "IMPS/2"
(**) DevInputMice: Protocol: "IMPS/2"
(**) Option "AlwaysCore"
(**) DevInputMice: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) DevInputMice: ZAxisMapping: buttons 4 and 5
(**) DevInputMice: Buttons: 5
(II) XINPUT: Adding extended input device "DevInputMice" (type: MOUSE)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
Couldn't load XKB keymap, falling back to pre-XKB keymap

Could this mean the driver is gone/not found? I made the big mistake of deleting my /var while trying to relocate /tmp and /var/tmp to /usr/tmp (which became necessary for downloading Eclipse again when it stopped working after installing Ximian, but I digress ...). I have re-created it best I could (now I only get one error about NFS statd failing at shutdown and I can not rebuild the RPM database ... ), but could there be something missing?

In the /var/log/messages it says the following about keymap:

Feb 21 18:58:00 localhost keytable: Loading keymap:
Feb 21 18:58:00 localhost kernel: Starting kswapd
Feb 21 18:58:00 localhost keytable:
Feb 21 18:58:00 localhost kernel: allocated 32 pages and 32 bhs reserved for the highmem bounces
Feb 21 18:58:00 localhost keytable:
Feb 21 18:58:00 localhost kernel: VFS: Disk quotas vdquot_6.5.1
Feb 21 18:58:00 localhost rc: Starting keytable: succeeded

Do you see a problem here?

There is also sth about gdm and NVIDIA:

Feb 21 18:58:22 localhost gdm[1253]: gdm_server_spawn: Could not open logfile for display :0!
Feb 21 18:58:22 localhost rcd[1158]: id=2 COMPLETE 'Downloading http://red-carpet.ximian.com/ximian-...on/channel.png' time=1s (failed)
Feb 21 18:58:22 localhost rcd[1158]: id=3 COMPLETE 'Downloading http://red-carpet.ximian.com/ximian-...on/channel.png' time=1s (failed)
Feb 21 18:58:23 localhost kernel: 0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-5328 Wed Dec 17 13:54:51 PST 2003
Feb 21 18:58:23 localhost insmod: Warning: loading /lib/modules/2.4.20-28.8/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
Feb 21 18:58:23 localhost insmod: See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Feb 21 18:58:23 localhost insmod: Module nvidia loaded, with warnings

I have installed Ximian Desktop recently. I noticed that it removed some Sun font (did not note the name). I think I/the install program changed /etc/X11/fs/config because of this. Also, /home/<usr>/.gnome is empty. I copied mime-types there from a backup version, but it does not help. I also re-installed the Java SDK, but that alone does not help. /etc/fonts/fonts.conf has also changed around the time Ximian was installed.

Other possibly relevant info.

janis@/home/janis: whence xterm
/usr/X11R6/bin/xterm
janis@/home/janis: echo $LANG
en_US.UTF-8

How could I fix this? What is the best place to start -- the xkbmap, keyboard driver, the Sun font? How do I do it? Help!?

Janis

XF86Config attached. It is the same as before all the recent changes/problems, though...

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc102"
Option "XkbLayout" "de"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "AOC SPECTRUM 7Vlr & 7VlrA & 7Vlr+ & 7VlrA+"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 130.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 02-21-2004, 02:52 PM   #2
janisj
Member
 
Registered: Jul 2003
Location: Hesse, Germany
Distribution: Fedora Core 1
Posts: 38

Original Poster
Rep: Reputation: 15
I found that /etc/sysconfig/hwconfig has entries for video, audio, mouse, hard/floppy drives but nothing for keyboard. Does this mean it *is* a driver problem? How do I fix it? Help!?
 
Old 02-22-2004, 12:52 PM   #3
janisj
Member
 
Registered: Jul 2003
Location: Hesse, Germany
Distribution: Fedora Core 1
Posts: 38

Original Poster
Rep: Reputation: 15
I have fixed almost all the problems mentioned in the first post, except keyboard entry. The situation is as follows:

1) Virtual terminals display all special characters entered using <ALT-GR>+<whatever character I want on my German keyboard> correctly. Instead of German characters, the terminal displays special characters for the corresponding key on the US keyboard. I read that the virtual terminal supports UTF-8 natively;

2) I can not type the special characters produced with <Alt-Gr> nor German characters into OO, /usr/bin/gnome-terminal or here.

For some reason echo $TERM produces "xterm" even though /usr/bin/gnome-terminal has been started.

I have also noticed that my /etc/fstab may be looking differently than before:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/hdb3 swap swap defaults 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda4 /osshare vfat umask=000 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

I tried putting charset=ISO-8858-1 ... on some lines, but that did not work. I am also thinking that, if fstab were the problem, then virtual terminals would display the same symptoms that gnome-terminal and OO does. Is that correct? Can you spot a problem above?

As you can see, I am stuck? Help, please!?
 
Old 02-28-2004, 12:15 PM   #4
janisj
Member
 
Registered: Jul 2003
Location: Hesse, Germany
Distribution: Fedora Core 1
Posts: 38

Original Poster
Rep: Reputation: 15
I found the answer:
1) right click on the panel --> Add to panel --> utility --> keyboard layout switcher ;
2) right click on the switcher --> preferences --> add the German keymap and make it the active one (move to top).

I did not have to do this when I had the regular GNOME. Ximian makes it necessary.

What I described previously is the fuctionality of the Gnome keyboard default.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.0: X setting won't "stick"; mouse & keyboard not properly detected Livino SUSE / openSUSE 1 10-30-2005 04:51 AM
Debian Boot Up Problem - stuck at "BR" & "I" jc70417 Debian 2 08-30-2005 05:36 PM
kde "keyboard shortcuts": can't change modifiers & says no windows key peb Linux - Newbie 0 01-02-2004 05:41 PM
Keyboard & Display "VGA" xmeson Linux - Laptop and Netbook 1 09-23-2003 11:49 AM
Ximian crashes when I enter "special chars" into message borbjo Linux - Software 0 01-28-2003 08:31 AM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration