LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-23-2006, 11:37 PM   #16
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31

Ok... another update I increased the size of RAMDISK support to 20 megs (everybody said 10, so I decided to go above and beyond just to make sure) and I checked the Root Plug option, it was already disabled. Any other ideas??

Thanks
DragonM15
 
Old 01-23-2006, 11:40 PM   #17
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,108

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Hmmm ... I would've thought my idea would fix it. Are you using LVM (Logical Volume Manager) on your partitions? If so, do you have support for it compiled into your kernel? What filesystem is on the root partition?
 
Old 01-23-2006, 11:42 PM   #18
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
I am not sure what LVM is.... How do I tell? As for my root partition, it is reiserfs (I did spell that right I hope). and it is compiled directly, not a module. I made sure of that

DragonM15
 
Old 01-24-2006, 11:25 AM   #19
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by DragonM15
I read this post, and recompiled my kernel and made sure that my filesystems were set as yes rather than modules. My filesystem is reiserfs. As far as the initrd, I read in /boot/README.initrd to run the command 'mkinitrd -c -k 2.6.13 -m reiserfs' and added initrd=/boot/initrd.gz to my lilo.conf. and I still got the same error. I looked on the page that paragn recommended... and I came across 2 things. "try increasing the size of RAMDISK support, if it's loading to RAMDISK to boot, you'll need that to be bigger than your kernel, and Disable root plug option (security options) if not needed" can I change RAMDISK size in Kernel? I am going to look around when I boot into it and find out. And I have read that the root plug is in the kernel config, so I am going to take a look. Ill let you know how things work out. This is just an update on how things are coming.

Thanks,
DragonM15
You were using mkinitrd incorrectly....
Code:
$Id: mkinitrd,v 1.201 2004/05/16 22:00:48 herbert Exp $

Usage: /usr/sbin/mkinitrd [OPTION]... <-o outfile> [version]

Options:
  -d confdir  Specify an alternative configuration directory.
  -k          Keep temporary directory used to make the image.
  -m command  Set the command to make an initrd image.
  -o outfile  Write to outfile.
  -r root     Override ROOT setting in mkinitrd.conf.

See mkinitrd(8) for further details.
You need to make an initrid.img file, you would use it as such:
#mkinitrd -o <image name> <kernel name>
You can get the name by what's in your modules dir: /lib/modules/
#mkinitrd -o initrid.img-2.6.15-1-amd64-k8 2.6.15-1-amd64-k8
That's just an example based off the image I'm using now. That file will be loaded into your boot directory and then you'll have to do update-grub again. It will automatically detect what initrid.img is used for what kernel, you CAN name the initrid.img anything you want I just name it like that for simplicity and orginization. Basicially initrid.img so I know what it is and then the appended -<image name> so I know which ones are which when I want to delete older kernels. I hope this makes sense.

Last edited by mushroomboy; 01-24-2006 at 11:31 AM.
 
Old 01-24-2006, 02:07 PM   #20
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Ok, so I am using 2.6.13 so would I do
Code:
mkinitrd -o initrd-2.6.13.img vmlinuz-2.6.13
vmlinuz-2.6.13 is the name of my kernel in '/boot' Is this correct?

thanks,
DragonM15
 
Old 01-24-2006, 03:44 PM   #21
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by DragonM15
Ok, so I am using 2.6.13 so would I do
Code:
mkinitrd -o initrd-2.6.13.img vmlinuz-2.6.13
vmlinuz-2.6.13 is the name of my kernel in '/boot' Is this correct?

thanks,
DragonM15
vmlinuz is just the kernel image, you'd probably just use 2.6.13. vmlinuz is actually added by the program, for the same reason I used the initrd.img thing. try this though:

#mkinitrd -o initrd.img-2.6.13 2.6.13
#update-grub

That should finish it.

That should work, then reboot and enjoy!

Note: There's a reason for why I named it slightly off from what you did, if you want to know PM me, though I don't think it matters, just try and stay as close to the examples. I'm not sure if the update-grub actually looks for initrid.img in file names or not, but I'd just say make sure it's initrid.img and then add whatever to the end.
 
Old 01-24-2006, 03:47 PM   #22
ivangetov
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Rep: Reputation: 0
What is type of you disk SCSI or IDE
 
Old 01-24-2006, 04:33 PM   #23
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by ivangetov
What is type of you disk SCSI or IDE
It's not a SCSI or IDE problem. This actually happens a lot with initrd images that aren't configured properly.

Last edited by mushroomboy; 01-24-2006 at 04:38 PM.
 
Old 01-24-2006, 07:42 PM   #24
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Okie dokie, Ill give it a try! But I have to ask, why havent I gotten this error when updating before??

DragonM15
 
Old 01-24-2006, 09:42 PM   #25
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Hey man, that worked great!! Thanks!!

DragonM15
 
Old 01-25-2006, 07:20 AM   #26
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
=) Glad to help mate, I actually had to fix that through google myself. =P
 
Old 01-30-2006, 04:14 PM   #27
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Alright, that is all fine and dandy, but now if I try to go to 2.6.15, I get the same error as I was before, and I did the mkinitrd -o initrd.img-2.6.15 2.6.15 And umm.... I get that same stupid error as before.... and one more little problem.... in 2.6.13 when I boot up blackbox, or any other gui, when I try to open xterm, or any other terminal besides konsole, it opens for a split second, and then disappears.... however in 2.4.26 everything works fine..... and it boots up in a quarter the time as 2.6..... neways.... update.... Reason I want 2.6.15 is because it has an actual option in the config for my wireless... I dont have to go through the whole 50 step process.... Well, there is my update.... any ideas???

Thanks,
DragonM15

P.S. I will go through the config, and use the same config as 2.6.13 ... you can do that with make oldconfig correct? Or do I have to specify where the old config is.... seems I have 2.4.26, and 2.6.13 before 2.6.15?
 
Old 02-01-2006, 04:52 AM   #28
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by DragonM15
Alright, that is all fine and dandy, but now if I try to go to 2.6.15, I get the same error as I was before, and I did the mkinitrd -o initrd.img-2.6.15 2.6.15 And umm.... I get that same stupid error as before.... and one more little problem.... in 2.6.13 when I boot up blackbox, or any other gui, when I try to open xterm, or any other terminal besides konsole, it opens for a split second, and then disappears.... however in 2.4.26 everything works fine..... and it boots up in a quarter the time as 2.6..... neways.... update.... Reason I want 2.6.15 is because it has an actual option in the config for my wireless... I dont have to go through the whole 50 step process.... Well, there is my update.... any ideas???

Thanks,
DragonM15

P.S. I will go through the config, and use the same config as 2.6.13 ... you can do that with make oldconfig correct? Or do I have to specify where the old config is.... seems I have 2.4.26, and 2.6.13 before 2.6.15?
I don't know, I just did the config from scratch mainly and just enabled most of the default support for things. Though I used gconfig (because xconfig or kconfig wouldn't work). And really the #mkinitrd -o initrd.img-2.6.15 2.6.15 should work but if you read my earlier post then you'd understand when I say what does the /lib/modules/2.6.15 folder say, what is it's exact name? Is it /lib/modules/2.6.15 or is it /lib/modules/2.6.15-1 or something?
 
Old 12-20-2006, 10:41 AM   #29
speut
LQ Newbie
 
Registered: Jul 2006
Posts: 10

Rep: Reputation: 0
btmiller had it.

make xconfig

added to block devices section. ram disk support. initrd support.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Upgrade now Kernel Panic saltireboy Slackware 9 01-23-2006 11:44 PM
Kernel panic after motherboard upgrade TarouSatomi Linux - Hardware 1 11-13-2005 03:24 PM
kernel panic after kernel upgrade flebber Debian 8 04-08-2005 07:26 AM
framebuffer causes kernel panic after RAM upgrade lezek Linux - Hardware 9 04-14-2003 04:23 PM
Kernel panic after Redhat 8.0 upgrade Kajtek Linux - Software 10 04-11-2003 05:21 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration