LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Kernel Upgrade causing Kernel Panic (http://www.linuxquestions.org/questions/linux-software-2/kernel-upgrade-causing-kernel-panic-403178/)

DragonM15 01-14-2006 12:48 AM

Kernel Upgrade causing Kernel Panic
 
Ok... I am running Slackware 10.2 and I am trying to upgrade from 2.4.31 to 2.6.8 (That is the first kernel that supports my wireless card)

Code:

VFS: Cannot open root device "305" or unknown-block(3,5)
Please append a correct "root=" boot option
Kernel Panic: VFS: Unable to mout root fs on unknown-block(3,5)

I thought that I might have accidentally put something wrong in my lilo config, however... I have it exectly the same as my previous 2.4.31 kernel verson.... any ideas how I might be able to fix this? Thanks

DragonM15

paragn 01-14-2006 01:12 AM

Hi,
I dont know whether following link will help you or not but you can give a try
http://linuxgazette.net/111/krishnakumar.html
Also check following link to check that whether you followed correct procedure to install 2.6 kernel
http://www.linuxgazette.com/node/9060

DragonM15 01-14-2006 01:26 AM

I followed the first link to the T (Nothing different from any other previous kernel versions as far as compiling) The second one I am taking a look at... Do I have to install module-init-tools-3.0.tar.gz?? I have never done this....??

Thanks
DragonM15

paragn 01-14-2006 01:43 AM

hi,
yes if you have your linux OS already installes with 2.4 kernel then you need to use module-init-tools-3.0.tar.gz but follow step wise procedures otherwise you will face problems as 2.4 and 2.6 uses different modules format.

DragonM15 01-14-2006 02:16 AM

Okie dokie, Ill give it a try :) Get back to you on exactly what happens :D

DragonM15 01-19-2006 12:54 AM

Ok, I installed the module-init-tools-3.0.tar.gz, and recompiled my kernel just for the heck of it, AND I am still getting the same exact error

paragn 01-19-2006 01:02 AM

ok if possible go in single mode i.e. init 1 and copy grub.conf somewhere and post it here. i want to look that

ken.mr47 01-19-2006 08:01 AM

Quote:

Originally Posted by DragonM15
Ok... I am running Slackware 10.2 and I am trying to upgrade from 2.4.31 to 2.6.8 (That is the first kernel that supports my wireless card)

Code:

VFS: Cannot open root device "305" or unknown-block(3,5)
Please append a correct "root=" boot option
Kernel Panic: VFS: Unable to mout root fs on unknown-block(3,5)

I thought that I might have accidentally put something wrong in my lilo config, however... I have it exectly the same as my previous 2.4.31 kernel verson.... any ideas how I might be able to fix this? Thanks

DragonM15

I have the same problem as DragonM15 and i can't boot into my slackware now. Any ideas on how to go about installing a new kernel from a live rescue disk such as knoppix?

DragonM15 01-20-2006 02:28 PM

Quote:

Originally Posted by paragn
ok if possible go in single mode i.e. init 1 and copy grub.conf somewhere and post it here. i want to look that

yeah, I used one of my live linux versions, and ended up with this:
Code:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
# vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda2
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda5
  label = Linux
  read-only
# Linux bootable partition config ends
image=/boot/vmlinuz-generic-2.6.13
  root=/dev/hda5
  label = Generic-2.6.13
  read-only

I got into in enough to take out my 2.6.8 config, and tried a 2.6.15 (Same error booting), and so I read around and noticed that some people had the 2.6.13 version on the second install disk (I was not fortunate enough to have that, but I found it and downloaded it, as well as the kernel modules/headers/newer version of alsa that really wasnt any newer, it was the same version I had installed. I did the generic as you see in the config, however I still am getting the same error! I then tried to install the source for the 2.6.13 kernel, but ran out of room on my partition :p I was just curious, if I could how do I completely delete the 2.6.15 kernel? Do I just delete my /usr/src/linux-version folder and be done with it, I was under the impression there was more to it than that? But neways... I will wait patiently for a reply

Thanks,
DragonM15

paragn 01-20-2006 10:45 PM

DragonM15,
To remove any kernel just remove its entry from grub.conf/lilo.cong then go to /lib/modules/(KERNEL_VERSION)/ delete this directory.
e.g. if you want to delete 2.6.13 kernel then delete its /lib/modules/2.6.13 directory and then in /boot directory remove its initrd image as well as kernel's vmlinuz image file. thats it:)
if you are able to in linux os by live cd. then run df command on console. then check on which hda partition your / partition resided and then replace lilo's boot as
boot=/dev/{partition no. e.g.hda1,hda2}
and run lilo and reboot

paragn 01-20-2006 11:20 PM

Also it seems that=>
your boot config ( grub or lilo ) is configured to look for /dev/hda5 for your root files ( / )
if it's not there .. you need too use root=/dev/someplace-else
and redo lilo/grub once yo got it going again
thats it
or go to http://kerneltrap.org/node/970 i hope this will definitely solve your problem. do reply back

btmiller 01-20-2006 11:21 PM

The problem is likely that you didn't compile support for your root filesystem into your kernel and didn't make an initrd containing that module. Make sure support for the type of root filesystem type you have (e.g. ext3 or reiserfs) is compiled directly into the kernel, not as an module. This is critical, or else you will get the exact error you describe.

Also, btw, the Slackware module-init-tools has supported 2.6 kernels since Slack 9.1.

cranium2004 01-21-2006 08:36 AM

hello,
I check this thread and i have question to btmiller that if we do make install isn't all happens automatically. I mean initrd and copying kernel image to /boot?

DragonM15 01-22-2006 10:29 PM

Quote:

Originally Posted by paragn
DragonM15,
To remove any kernel just remove its entry from grub.conf/lilo.cong then go to /lib/modules/(KERNEL_VERSION)/ delete this directory.
e.g. if you want to delete 2.6.13 kernel then delete its /lib/modules/2.6.13 directory and then in /boot directory remove its initrd image as well as kernel's vmlinuz image file. thats it:)
if you are able to in linux os by live cd. then run df command on console. then check on which hda partition your / partition resided and then replace lilo's boot as
boot=/dev/{partition no. e.g.hda1,hda2}
and run lilo and reboot

Okie dokie, thank helped.... (Removing the kernel I mean) However, my root partition is /dev/hda5. I made it so when installing, and my default kernel boots to that partition as well. So there is no question that my root partition is hda5.

DragonM15

DragonM15 01-22-2006 10:47 PM

Quote:

Originally Posted by btmiller
The problem is likely that you didn't compile support for your root filesystem into your kernel and didn't make an initrd containing that module. Make sure support for the type of root filesystem type you have (e.g. ext3 or reiserfs) is compiled directly into the kernel, not as an module. This is critical, or else you will get the exact error you describe.

Also, btw, the Slackware module-init-tools has supported 2.6 kernels since Slack 9.1.

I read this post, and recompiled my kernel and made sure that my filesystems were set as yes rather than modules. My filesystem is reiserfs. As far as the initrd, I read in /boot/README.initrd to run the command 'mkinitrd -c -k 2.6.13 -m reiserfs' and added initrd=/boot/initrd.gz to my lilo.conf. and I still got the same error. I looked on the page that paragn recommended... and I came across 2 things. "try increasing the size of RAMDISK support, if it's loading to RAMDISK to boot, you'll need that to be bigger than your kernel, and Disable root plug option (security options) if not needed" can I change RAMDISK size in Kernel? I am going to look around when I boot into it and find out. And I have read that the root plug is in the kernel config, so I am going to take a look. Ill let you know how things work out. This is just an update on how things are coming.

Thanks,
DragonM15


All times are GMT -5. The time now is 08:55 AM.