LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-19-2006, 04:57 AM   #1
hategiants
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Rep: Reputation: 0
Angry Kernel Update Caused Panic, Howto Downgrade


I am using SuSE 9.2 2.6.8-24 and I inadvertantly upgraded to 2.6.8.24-20. I am running a Broadcom BC4852 Raid 5 array and currently there is not driver support for 2.6.8.24-20. While rebooting after this upgrade the boot process fails giving me the error:

Waiting for device to appear /dev/sda2: ....... not found : device nodes:
...prints a bunch of tty stuff...
No root device found; exiting to /bin/sh

I am able to boot into the Rescue Disk off the SuSE install dvd and I can load the proper drivers and then remount the array. The rescue disk loads the older kernel I have driver support for. How can I downgrade my kernel to its previous version?

BTW I used `apt-get upgrade` to perform this task. I am hoping I can use apt-get again to downgrade the kernel. Any thoughts?
 
Old 04-19-2006, 05:15 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,753
Blog Entries: 1

Rep: Reputation: 238Reputation: 238Reputation: 238
You said you can use the rescue disk to load the old kernel? If it's using the old kernel from your hard drive, just edit your grub.conf (menu.lst) to use your previous kernel.
 
Old 04-19-2006, 05:47 AM   #3
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Hi

I don't if this will help, but I just experienced the same problem trying to boot into a new (self compiled) kernel with the same error message. It turned out that the new kernel did not have the correct SATA driver installed (in my case, I had to recompile and change it to nVidia SATA.) Once this was installed and recompiled, sda2 (same location on my drive) was found and mounted,

Hope this helps

Bob
 
Old 04-19-2006, 06:06 PM   #4
hategiants
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Original Poster
Rep: Reputation: 0
It is clear that within the /boot directory it is currently configured to boot using 2.6.8-24.20. From the rescue disc (ram disk runtime) how can I run use apt-get to uninstall the kernel and revert to my previous configuration of 2.6.8-24

Within menu.lst for grub there was no mention of the kernel. I could not pick my old version to boot into. Is there a way to manually configure this within grub because that would be an acceptable work around as well.
 
Old 04-19-2006, 06:11 PM   #5
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 12.04
Posts: 913

Rep: Reputation: 33
Quote:
Originally Posted by hategiants
It is clear that within the /boot directory it is currently configured to boot using 2.6.8-24.20. From the rescue disc (ram disk runtime) how can I run use apt-get to uninstall the kernel and revert to my previous configuration of 2.6.8-24

Within menu.lst for grub there was no mention of the kernel. I could not pick my old version to boot into. Is there a way to manually configure this within grub because that would be an acceptable work around as well.
You did not "update" your kernel instead of installing the new one parallel to the old one, did you?

Assuming you didn't, then you should be able to edit your /boot/grub/grub.conf to default to the old kernel. The list of kernels in grub.conf correspond to numbers staring from 0 (i.e. the top entry is 0, the next one is 1, etc). Just find the number for the kernel you'd like to boot and set the "default" parameter (near the top of the file) to that number.
 
Old 04-19-2006, 08:43 PM   #6
hategiants
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I know exactly what you are talking about through experience with this using Fedora. However this is a bit different and I am unfamilar with it in SuSE. Here is my menu.lst which is equivalent to grub.conf:

Code:
# Modified by YaST2. Last modification on Tue Jul 19 21:51:19 2005


color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,1)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.2
    kernel (hd0,1)/boot/vmlinuz root=/dev/sda2 vga=0x31a selinux=0 splash=silent resume=/dev/sda1 desktop elevator=as showopts
    initrd (hd0,1)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX 9.2
    kernel (hd0,1)/boot/vmlinuz root=/dev/sda2 showopts ide=nodma apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0  3
    initrd (hd0,1)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    root (fd0)
    chainloader +1
Additionally Here is a ls -l of /boot/
Code:
drwxr-xr-x   3 root root     496 Apr 11 22:22 .
drwxr-xr-x  22 root root     536 Apr 15 18:27 ..
-rw-r--r--   1 root root  739982 Feb 10 15:37 System.map-2.6.8-24.20-default
-rw-r--r--   1 root root     512 Jul 19  2005 backup_mbr
lrwxrwxrwx   1 root root       1 Jul 19  2005 boot -> .
-rw-r--r--   1 root root   57530 Feb 10 15:48 config-2.6.8-24.20-default
drwxr-xr-x   2 root root     480 Apr 19 22:00 grub
lrwxrwxrwx   1 root root      26 Apr 11 22:22 initrd -> initrd-2.6.8-24.20-default
-rw-r--r--   1 root root 1225145 Apr 11 22:22 initrd-2.6.8-24.20-default
-rw-r--r--   1 root root  107520 Jul 19  2005 message
-rw-r--r--   1 root root   79238 Feb 10 15:48 symvers-2.6.8-24.20-i386-default.gz
-rw-r--r--   1 root root 1857746 Feb 10 15:48 vmlinux-2.6.8-24.20-default.gz
lrwxrwxrwx   1 root root      27 Apr 11 22:22 vmlinuz -> vmlinuz-2.6.8-24.20-default
-rw-r--r--   1 root root 1556392 Feb 10 15:37 vmlinuz-2.6.8-24.20-defaul
Finally to round out the batch here is the entry regarding the kernel in my apt.log. The date of the crime was April 11th as you can see from the log:
Code:
Tue 11 Apr 2006 03:26:17 PM PDT;upgrade;kernel-source;2.6.8-24 => 2.6.8-24.20
Tue 11 Apr 2006 03:26:17 PM PDT;upgrade;kernel-default-nongpl;2.6.8-24 => 2.6.8-24.20

Last edited by hategiants; 04-19-2006 at 08:44 PM.
 
Old 04-22-2006, 08:10 PM   #7
hategiants
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I resolved this issue by simply reinstalling SuSE from the original 9.2 dvd. All the updated packages were overwritten and the drivers I had worked once again.
 
  


Reply

Tags
conflict, driver, kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic after lilo update aje Slackware 4 09-03-2005 02:39 PM
"make clean" caused system freeze, kernel panic on reboot jwhill2000 Linux - General 3 02-08-2005 08:59 PM
Restore kernel after panic howto ? wesleywest Linux - Software 1 11-10-2004 10:20 AM
kernel source update - howto? uji Fedora 1 09-23-2004 06:56 AM
YaST Online Update + AMD kernel patch = kernel panic THX1138 Linux - General 3 10-26-2003 05:25 PM


All times are GMT -5. The time now is 02:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration