LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Kernel Panic not syncing: IO APIC+timer dos'nt work! (http://www.linuxquestions.org/questions/linux-software-2/kernel-panic-not-syncing-io-apic-timer-dosnt-work-852852/)

klarsin 12-28-2010 12:27 PM

Kernel Panic not syncing: IO APIC+timer dos'nt work!
 
After searching other similar posts I have not found an answer. I have recently installed Ubuntu 10.4.1 after reformatting the computer from the previous Ubuntu Edgy. When rebooting get this msg (in title). I used the live CD to get into the grub files to see if I could ad 'noacip' option. But was looking for 'menu lst' file and found none. Currently when I boot I don't get any menu list and therefore no options at the bottom. Should be an easy problem to resolve, I think!

Powerspec B364/160gb/856Ram/ATI raedon 200 express onboard/Geforce 8400GS PCI-e

nickle79 12-28-2010 01:05 PM

You should be able to add this at boot. When grub comes up select your kernel and press "E" to edit, add your option and press "B" to boot.

klarsin 12-28-2010 04:18 PM

Quote:

Originally Posted by nickle79 (Post 4205694)
You should be able to add this at boot. When grub comes up select your kernel and press "E" to edit, add your option and press "B" to boot.

The problem is that there is no selection menu. The screen brings up only the Kernel Panic msg. I can get into BIOS, though, but that doesn't help, unless there is a setting there that might fix the problem. But I have already checked it, and it all worked great unitl I reformatted and installed Lucid. There is no other OS on this computer (not dual boot w/ Windows). I can boot with the live CD but don't know if I can make any changes from there.

nickle79 12-28-2010 04:58 PM

Quote:

Originally Posted by klarsin (Post 4205867)
The problem is that there is no selection menu. The screen brings up only the Kernel Panic msg. I can get into BIOS, though, but that doesn't help, unless there is a setting there that might fix the problem. But I have already checked it, and it all worked great unitl I reformatted and installed Lucid. There is no other OS on this computer (not dual boot w/ Windows). I can boot with the live CD but don't know if I can make any changes from there.

In that case boot your live CD, open a terminal and mount your root partition(/dev/sda1 in the example). Hopefully this helps.

Example:
Code:

mount /dev/sda1 /mnt/foo
vi /mnt/foo/boot/grub/menu.lst


klarsin 12-29-2010 10:18 AM

Quote:

Originally Posted by nickle79 (Post 4205895)
In that case boot your live CD, open a terminal and mount your root partition(/dev/sda1 in the example). Hopefully this helps.

Example:
Code:

mount /dev/sda1 /mnt/foo
vi /mnt/foo/boot/grub/menu.lst


The file system appears to be already mounted on the desktop in live CD boot. And when I open the GUI folder boot/grub there is no menu.lst file present. Then I used the terminal with the following commands and responses. (The following is not copied but hand typed)

root@ubuntu:~# mount /dev/sda1
mount: /dev/sda1 already mounted or /media/241607e7-4e3e........busy
mount: according to mtab, /dev/sda1 is already mounted on /meda/241607e7

root@ubuntu:~# mount /dev/sda1 /mnt/foo
mount: mount point /mnt/foo does not exist


root@ubuntu:~# vi /mnt/foo/boot/grub/menu.lst
-
-
-
"mnt/foo/grub/menu.lst" [new directory]

What I get from all this is that the menu.lst did not install?

nickle79 12-29-2010 02:53 PM

Interesting... could you post the output of "fdisk -l"?

klarsin 12-29-2010 07:17 PM

Quote:

Originally Posted by nickle79 (Post 4206944)
Interesting... could you post the output of "fdisk -l"?

root@ubuntu:~# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000f27ea

Device Boot Start End Blocks Id System
/dev/sda1 * 1 19084 153283584 83 Linux
/dev/sda2 19084 19458 3004417 5 Extended
/dev/sda5 19084 19458 3004416 82 Linux swap / Solaris
(sorry format problems)

I'm thinking of reinstalling and pay attention to the grub and where it installs supposed to be hd0 or sd0 and see if the installation has a tag for noacip selection. Maybe that will quickly resolve this. I'll have to find the installation tut for this and see.

nickle79 01-03-2011 03:37 PM

I think you'll find the answer in this link.

https://help.ubuntu.com/community/Grub2

Cheers :-)

klarsin 01-05-2011 08:03 PM

Quote:

Originally Posted by nickle79 (Post 4211847)
I think you'll find the answer in this link.

https://help.ubuntu.com/community/Grub2

Cheers :-)

This was very helpful. I'm up and installed with dual boot win xp this time. I havn't configured the grub 2 file for noapic yet, but it looks simple enough.


All times are GMT -5. The time now is 01:37 PM.