LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Kernel 3.10 (x86_64) and nvidia 319.32 driver (http://www.linuxquestions.org/questions/linux-software-2/kernel-3-10-x86_64-and-nvidia-319-32-driver-4175467995/)

3rensho 07-01-2013 08:52 AM

Kernel 3.10 (x86_64) and nvidia 319.32 driver
 
Built the new 3.10 kernel this morning and it boots fine. Wanted to compile a new nvidia driver to go with it and it pops up a message that it can't build it. Looking in the log I find -

/usr/src/linux-3.10/include/linux/compiler.h:152:40: note: in definition of macro 'likely'
# define likely(x) __builtin_expect(!!(x), 1)
^
/tmp/selfgz5126/NVIDIA-Linux-x86_64-319.32/kernel/nv-i2c.c: In function 'nv_i2c_del_adapter':
/tmp/selfgz5126/NVIDIA-Linux-x86_64-319.32/kernel/nv-i2c.c:327:14: error: void value not ignored as it ought to be
osstatus = i2c_del_adapter(pI2cAdapter);
^
make[4]: *** [/tmp/selfgz5126/NVIDIA-Linux-x86_64-319.32/kernel/nv-i2c.o] Error 1
make[3]: *** [_module_/tmp/selfgz5126/NVIDIA-Linux-x86_64-319.32/kernel] Error 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.


Anyone able to build the Nvidia module with kernel 3.10 (64 bit). Googling finds this error with earlier Nvidia modules but withno clear fix. Had no problems with the 3.98 kernel.

Thanks

bathory 07-01-2013 09:26 AM

Hi,

Yup it works here (Slackware64 with the new 3.10 kernel), after patching the driver
You can get the patch from this post

Regards

3rensho 07-01-2013 11:49 AM

Thanks for that. Created patch file and copied to the kernel directory of the uncompressed Nvidia driver. Patch won't apply for some reason

patch -p1 < patch-1
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- nv-procfs.c.orig 2013-05-27 18:51:04.361832467 -0430
|+++ nv-procfs.c 2013-05-27 18:52:30.267642126 -0430
--------------------------
File to patch:


Clearly I'm doing something wrong. How did you patch yours?? Thanks in advance.

bathory 07-01-2013 12:26 PM

Quote:

Clearly I'm doing something wrong. How did you patch yours?? Thanks in advance.
First ran
Code:

sed -i 's/319.17/319.32/g' pastie-7942599.diff
to adjust the driver version
Then changed into the NVIDIA-Linux-x86_64-319.32-no-compat directory (not inside the kernel subdir) and ran
Code:

patch -p1 < /path/to/pastie-7942599.diff

3rensho 07-02-2013 01:40 AM

Thank you for that. I applied the patch and that went OK.

tom@missi:~/nvidia/NVIDIA-Linux-x86_64-319.32$ patch -p1 < pastie-7942599.diff
patching file kernel/nv-i2c.c
patching file kernel/nv-procfs.c
Hunk #4 succeeded at 161 with fuzz 1.
tom@missi:~/nvidia/NVIDIA-Linux-x86_64-319.32$

Unfortunately I still get the identical error message in the Nvidia log and it says that patch can't be built.

3rensho 07-02-2013 03:54 AM

Well it finally worked. I deleted the unpacked directory for NVIDIA-Linux-x86_64-319.32 and then unpacked it anew. Applied the patch and now the module builds. The old unpacked directory must have been corrupted in some way. Many thanks for your help bathory. Really appreciated.

luis.nando 08-16-2013 09:15 AM

Kernel 3.10 and nVidia steps for a noob
 
Guys,

I made a set up which I use a bluetooth mouse and keyboard, but with the 3.8 kernel I keep getting kernel panics on ubuntu. This issue is solved in the newest 3.10 series, but unfortunately there is no support for the nVidia graphics card so far. Except for the patch you posted in this forum thread. The problem is I am a real noob in linux, is there any step-by-step way of configuring this? Did anyone packed the solution on a ppa?
I would really appreciate some help on finding a way of making my nVidia card 'talk' with the new kernel!

Here it goes other noob question, does bumblebee can be installed together with the new kernel?? Is there a ppa?

Well, thanks in advance.

bathory 08-16-2013 04:17 PM

Quote:

This issue is solved in the newest 3.10 series, but unfortunately there is no support for the nVidia graphics card so far. Except for the patch you posted in this forum thread.
FYI latest nvidia driver (version 325.15) does not need the patch in order to work

Regards

luis.nando 08-16-2013 07:02 PM

Thank you for your kind reply bathory, but how to install this version on Ubuntu 13.04 (runing the 3.10 kernel), in Synaptic I can only find the nvidia-310 and 304 packages....How to get the 325 version?

bathory 08-17-2013 03:13 AM

Quote:

Originally Posted by luis.nando (Post 5010662)
Thank you for your kind reply bathory, but how to install this version on Ubuntu 13.04 (runing the 3.10 kernel), in Synaptic I can only find the nvidia-310 and 304 packages....How to get the 325 version?

You can follow these instructions (from step 4) to install the binary driver from nvidia.

cheers


All times are GMT -5. The time now is 08:19 PM.