LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-01-2004, 07:46 PM   #1
mooreted
Member
 
Registered: May 2003
Posts: 598

Rep: Reputation: 30
Kernel 2.6.3. Agpgart not loading


I used rpmdrake to install Kernel 2.6.3 and all its dependencies and it boots fine until it gets to runlevel 5. At this point X complains that it can't find /dev/agpgart. My 2.4 kernel works fine.

How can I get my X server to load so I can get into KDE using the 2.6.3 kernel?

Ted.
 
Old 04-01-2004, 07:52 PM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
Did you check to see if /dev/agpgart exists?

If this is not a device that is used by your computer change X to not look for it as a video device, or you must not have devfs working in your new kernel.

there is UFS and DEVFS I belive, UFS was just added.
This may or may not be the problem.
 
Old 04-01-2004, 08:03 PM   #3
mooreted
Member
 
Registered: May 2003
Posts: 598

Original Poster
Rep: Reputation: 30
As it turns out, there is a simple solution that I know others will want to use....

Just add: intel-agp to /etc/modprobe.preload and reboot. Works great!

Ted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nVdia's AGPGART or Kernel 2.6.11.1 AGPGART slackermike Slackware 3 06-09-2005 03:26 PM
kernel agpgart issue flebber Slackware 3 05-13-2005 07:21 AM
New agpgart errors with the 2.6.7 kernel quilloneq Slackware 3 01-02-2005 03:54 PM
Is agpgart using ALL my RAM with my new 2.6 kernel? ChillingSilence Linux - General 0 01-03-2004 07:26 AM
Kernel 2.6.0 and AGPgart garr0323 Linux - General 1 12-18-2003 11:45 AM


All times are GMT -5. The time now is 12:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration