LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-15-2004, 09:44 PM   #1
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Rep: Reputation: 30
kernel 2.6.2


I have upgrade the the newest kernel but have now lost my internet connection. Was working before the upgrade. Any ideas?
 
Old 02-15-2004, 09:47 PM   #2
blanny
Member
 
Registered: Dec 2002
Location: CA,USA
Distribution: RHCE in training :)
Posts: 57

Rep: Reputation: 15
Did you keep your network modules?
 
Old 02-15-2004, 09:50 PM   #3
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
RE

I did not remove anything from network modules no.
 
Old 02-15-2004, 10:04 PM   #4
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
Update

Ok while as root I typed ifconfig and got:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric: 1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
Tx packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2352 (2.2kb) Tx bytes:2352 (2.2 kb)

Not sure if this will help.
 
Old 02-15-2004, 10:05 PM   #5
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
no thats just the local loopback ... thats not your network adapter ..
what model/name is your NIC ?
 
Old 02-15-2004, 10:10 PM   #6
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
It is a SiS 900-Based PCI ethernet card
 
Old 02-15-2004, 10:12 PM   #7
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
what is the output of the following command :
cat /usr/src/linux/.config | grep CONFIG_SIS900
 
Old 02-15-2004, 10:16 PM   #8
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
RE

CONFIG_SIS900=m
 
Old 02-15-2004, 10:17 PM   #9
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
ok so we see its a module ..
now is this module loaded ?

if not try :
modprobe sis900
 
Old 02-15-2004, 10:19 PM   #10
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
ok I tried to modprobe SIS900 and it gives me a fatal error that it was not found
 
Old 02-15-2004, 10:55 PM   #11
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
I am going to recompile the kernel.
 
Old 02-15-2004, 11:00 PM   #12
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
you didn't type SIS900 in all caps when you tried it by chance did you ?
 
Old 02-15-2004, 11:21 PM   #13
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
Post the error the modprobe gave you. Also, make sure you have the correct version of the module tools.
 
Old 02-15-2004, 11:44 PM   #14
JROCK1980
Member
 
Registered: Aug 2003
Distribution: FreeBSD
Posts: 490

Original Poster
Rep: Reputation: 30
re

I just recomplied the kernel. When I looked at the .config file the sis900 was not select to be in the kernel. I am now online and posting thru my Linux machine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4 in Zipslack (Waring: unable to open an initial console | Kernel Panic...) kurtamos Linux - General 2 05-10-2006 12:58 PM
Kernel-Patch Debian Logo 2.6.2 not correctly working for custom kernel 2.6.11 smp deepclutch Debian 3 06-27-2005 03:59 AM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 03:28 AM
Unable to build NVIDIA kernel module / determin kernel version Night Ink Fedora 2 05-31-2004 04:54 PM
Kernel 2.4.23 compile causes kernel panics on ATA RAID-1 (mirror) array Raptor Ramjet Slackware 3 12-18-2003 01:40 PM


All times are GMT -5. The time now is 12:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration