LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   KDE task switching (alt-tab) problem, also KDE XMMS problem (seperate problems) (http://www.linuxquestions.org/questions/linux-software-2/kde-task-switching-alt-tab-problem-also-kde-xmms-problem-seperate-problems-197269/)

Cohobin 06-24-2004 02:17 PM

KDE task switching (alt-tab) problem, also KDE XMMS problem (seperate problems)
 
Heya,

First off the vitals:

KDE: 3.2
Debain (unstable/sarge): as of yesterday (6/23)
pc104 keyboard (generic setting)

I have two problems; the first and most annoying is task switching in KDE. When I alt-tab to switch to another window, the task switch "sticks" -- as in I have to press enter to select the next window. Normally (and the way I would like to do it) is just to hold down alt, and press tab until I get to my window, let go, and have it automatically select it. I have been unable to figure out where / how to set this behavior, anyone know?

Secondly, XMMS in kde is screwy, when launched, it starts 6 processes; and after mp3's are associated by default with the XMMS player, kaboodle still opens the mp3.

If you have any suggestions or know how to fix these problems, or need my config files let me know. I don't need step by step, just what files to look in / what to set.

Thanks much in advance!

Cohobin 06-24-2004 04:25 PM

Fixed xmms problem
 
Well, fixed that annoying XMMS problem anyways; here's how:

-open up KDE control center, select KDE Components -> File associations
-select audio -> x-mp3
- on the right hand side, remove the existing entries (kaboodle and the others)
- add xmms (specify the WHOLE path, using the menu-like system to select xmms does not work - that's where my problem was)
- save. restart KDE to make sure settings held.

Still trying to figure out that damned alt-tab problem though... its really really annoying. :P

Cohobin 06-24-2004 04:40 PM

Update:

If I reassign the command to (Ctrl-tab) from (alt-tab) it works as it should. It must be something related to how KDE assigns ALT. Not sure though, any guesses?

Cohobin 06-26-2004 05:00 AM

bump. Still haven't been able to figure out that stupid alt-tab problem... any ideas from anyone? I'll take anything here

Cohobin 06-26-2004 05:47 AM

Problem Fixed! Read if you have KDE
 
go figure, I bump the post and I figure it out 2 minutes later... ugh. anyways.

The problem was the xlibs library v1-5, apparently the newest version breaks alot of keyboard functionality implementing new things. Just revert back to the xlibs v1-4 package, restart KDE and everything works spiffy.

Here's the command in debian:

dpkg -i --force-downgrade xlibs_4.3.0.dfsg.1-4

The package is located here: http://snapshot.debian.net/archive/2...sg.1-4_all.deb

non-debian users are on their own for this one, but it should be approximately the same.


All times are GMT -5. The time now is 10:08 PM.