LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   KDE Problem: my kmenu doesn't change with new packages, but other users' do. (http://www.linuxquestions.org/questions/linux-software-2/kde-problem-my-kmenu-doesn%27t-change-with-new-packages-but-other-users%27-do-384740/)

workman161 11-19-2005 06:43 PM

KDE Problem: my kmenu doesn't change with new packages, but other users' do.
 
I'm using fedora core 4. A while ago, I tried building KDE from sources (I was impatient, and didn't want to wait for the official RPMs), and I installed it successfully. Unfortunately, I didn't configure it right (I was impatient and naieve). Fortunately, I was the only one to use that compiled one, and the next day I installed the newly discovered packages. After I installed the sources, my KMenu wasn't there, but I could still edit it and such. But since other users didn't load KDE during this period, their KMenus weren't affected. Later, I installed a package, and their menus had the new icon that would launch this program, but mine didn't. KDE documentation isn't exactly up to snuff as other docs are, so I can't tell what is different about my configuration, or how to change where KDE looks for its menus. Would anyone know why this is?

reddazz 11-21-2005 03:27 AM

There entries in ~/.config and ~/.local that you need to delete for the menu to be restored to the default. Unfortunately I am not using KDE right now, so can't tell you exactly which files to delete but they are related to kmenu.

workman161 11-22-2005 08:33 PM

Woo. Thank you. I went into .share, renamed the menus folder, and then went into .local and renamed the applications folder.


All times are GMT -5. The time now is 07:57 PM.