LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-13-2003, 05:49 PM   #1
linux inside
LQ Newbie
 
Registered: Aug 2003
Distribution: red hat 9
Posts: 6

Rep: Reputation: 0
Angry kde problem


this is what i get when i start kde any clue of what i can do or is there anyway to remove kde?

$ startkde
startkde: Starting up...
kdeinit: relocation error: /usr/lib/libkdecore.so.4: undefined symbol: _ZN6KStyle12defaultStyleEv
startkde: Could not start kdeinit. Check your installation.
Warning: connect() failed: : No such file or directory
Session management error: Could not open network socket
kdeinit: kded: relocation error: /usr/lib/libkdecore.so.4: undefined symbol: _ZN6KStyle12defaultStyleEv
DCOP aborting call from 'anonymous-23493' to 'kded'
kdeinit: kwin -session 117f000001000105880891200000012440000_1060658675_417517:
relocation error: /usr/lib/libkdecore.so.4: undefined symbol: _ZN6KStyle12defaultStyleEv
kdeinit: kdesktop: relocation error: /usr/lib/libkdecore.so.4: undefined symbol: _ZN6KStyle12defaultStyleEv
DCOP aborting call from 'anonymous-23496' to 'kdesktop'
kdeinit: kicker: relocation error: /usr/lib/libkdecore.so.4: undefined symbol: _ZN6KStyle12defaultStyleEv
DCOP aborting call from 'anonymous-23498' to 'kicker'
kdeinit: kwrited: relocation error: /usr/lib/libkdecore.so.4: undefined symbol:
_ZN6KStyle12defaultStyleEv
DCOP aborting call from 'anonymous-23500' to 'kwrited'
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:10
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:11
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:13
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:15
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:16
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:21
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:24
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:26
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:27
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:28
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:29
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:30
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:31
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:33
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:34
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:35
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:38
Invalid entry (missing '=') at /usr/bin/rhn-applet-gui:41
ICE default IO error handler doing an exit(), pid = 23505, errno = 0
startkde: Shutting down...
KLauncher: Exiting on signal 1
bad md5 secret-cookie obtained from Arts::TmpGlobalComm - replacing it
startkde: Running shutdown scripts...
startkde: Done.
 
Old 08-13-2003, 08:16 PM   #2
PsychosisNode
Member
 
Registered: Apr 2003
Location: Reading, Berkshire, IN-GER-LUND!!!
Distribution: Mandriva 2006
Posts: 228

Rep: Reputation: 30
Three questions spring to mind:

Is it just you or do all users on that machine get the same?
Does Gnome and other window managers pack up as well?
Did you make any changes to the system before these problems began?

Sometimes the kde configs in your home dir get #ed up (very rare but it happens), if this is the case then other users shouldn't have the same problem. If all users get the same errors then it's worth going back over logs and stuff to see what changes could be causing it.

I use startx and kde starts automatic (because it's my default)

-Taiyo
 
Old 08-13-2003, 09:52 PM   #3
linux inside
LQ Newbie
 
Registered: Aug 2003
Distribution: red hat 9
Posts: 6

Original Poster
Rep: Reputation: 0
yeah all the other users get this issue ,gnome works fine and the only possible thing that could have damaged it that i always install themes from kdelook.org so im not sure and i really wanna aviod formatting because i have alot of items i wanna keep and they are hard to get back so i dont know what else to do im tring to get rid of kde and reinstall it.. gnome is ok but i really like the kde environment if anyone has anymore suggestions please post them
 
Old 08-13-2003, 11:53 PM   #4
teval
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Gentoo
Posts: 720

Rep: Reputation: 30
Go to kde.org
Download the newest sources or rpms however you wish, and install them.
The new ones should ovveride the old ones since you do have a few mangeled up libaries. Installing KDE is preety easy, just make sure you follow the order they give you, exactely (remember rtfm )
 
Old 08-14-2003, 02:38 PM   #5
PsychosisNode
Member
 
Registered: Apr 2003
Location: Reading, Berkshire, IN-GER-LUND!!!
Distribution: Mandriva 2006
Posts: 228

Rep: Reputation: 30
Quote:
so im not sure and i really wanna aviod formatting because i have alot of items i wanna keep and they are hard to get back
WHAT?! You're not using windoze here! A screwed up window manager doesn't mean a full re-install!, Not even a screwed up X means a reinstall! Many linux server machines don't even have X!

Like linux inside said, follow the instructions and you should be OK.

I got my themes from freshmeat:
http://themes.freshmeat.net/browse/61/?topic_id=61

-Taiyo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing new programs... KDE problem? seiyachan Mandriva 33 12-19-2005 10:18 AM
KDE task switching (alt-tab) problem, also KDE XMMS problem (seperate problems) Cohobin Linux - Software 4 06-26-2004 06:47 AM
Kde sound problem -It works but has a problem Magick211 Linux - Software 1 03-18-2004 08:24 PM
Problem with KDE Chemrok Linux - General 3 10-10-2002 11:06 PM
LiLo Installation problem ?and (GNOME and KDE problem) hitesh_linux Linux - Software 1 01-01-2002 05:56 AM


All times are GMT -5. The time now is 04:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration