LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   KDE Libs not found (http://www.linuxquestions.org/questions/linux-software-2/kde-libs-not-found-286466/)

jonlake 02-05-2005 02:17 AM

KDE Libs not found
 
I'm trying to install a program and it requires kdelibs.

checking for KDE... libraries /usr/lib, headers /usr/include/kde
checking if UIC has KDE plugins available... configure: error: not found - you need to install kdelibs first.

It looks like it is looking for those libs in /usr/lib. I belive they are located in /usr/lib/kde3 (I am running FC2). I tried to to a cp /usr/lib/kde3/* /usr/lib to put them in that directory. They are there now, however, I am still getting the same error. There aren't any options to specify where the kde libs should come from.

Also,
[root@jon jon]# rpm -qa | grep kde
kdelibs-devel-3.2.2-12.FC2
kdelibs-3.2.2-12.FC2
lockdev-1.0.1-2.3.1
kdegames-3.2.2-1
lockdev-devel-1.0.1-2.3.1
kdebase-3.2.2-4

My first question, is there a way to tell the computer as a whole (not just for this installation) to look in /usr/lib/kde3 for the kde libs? If not, what should I try to resolve this issue.

reddazz 02-05-2005 02:47 AM

Do you have the kdelibs development (kdelibs-devel) installed? If you don't install it and run ./configure again.

jonlake 02-05-2005 09:46 AM

Re: KDE Libs not found
 
Quote:

Originally posted by jonlake

Also,
[root@jon jon]# rpm -qa | grep kde
kdelibs-devel-3.2.2-12.FC2
kdelibs-3.2.2-12.FC2
lockdev-1.0.1-2.3.1
kdegames-3.2.2-1
lockdev-devel-1.0.1-2.3.1
kdebase-3.2.2-4

First one listed on rpm -qa | grep kde

reddazz 02-05-2005 10:35 AM

What exactly is this application that you are trying to install?

jonlake 02-05-2005 10:43 AM

ksmoothdock-3.5.1

reddazz 02-05-2005 10:49 PM

Try configuring it this way,

$./configure --prefix=`kde-config --prefix`
$make
$make install

hopefully it will recognise your kde-libs devel files. It's still puzling though as to why it says it xan't find them.

jonlake 02-06-2005 09:18 AM

[root@jon ksmoothdock-3.5.1]# ./configure --prefix='kde-config --prefix'
configure: error: expected an absolute directory name for --prefix: kde-config --prefix

Also, just to make sure, would these my kde libs?
[root@jon lib]# cd /usr/lib/kde3
[root@jon kde3]# ls -la | more
total 21992
drwxr-xr-x 3 root root 16384 Feb 5 02:36 .
drwxr-xr-x 106 root root 65536 Feb 6 04:24 ..
-rwxr-xr-x 1 root root 1101 May 4 2004 appletproxy.la
-rwxr-xr-x 1 root root 3296 May 4 2004 appletproxy.so
-rwxr-xr-x 1 root root 1268 May 4 2004 childpanel_panelextension.la
-rwxr-xr-x 1 root root 830676 May 4 2004 childpanel_panelextension.so
-rwxr-xr-x 1 root root 1076 May 4 2004 clock_panelapplet.la
-rwxr-xr-x 1 root root 229560 May 4 2004 clock_panelapplet.so
-rwxr-xr-x 1 root root 1158 Jan 21 09:50 cupsdconf.la
-rwxr-xr-x 1 root root 3428 Jan 21 10:01 cupsdconf.so
-rwxr-xr-x 1 root root 1053 May 4 2004 cursorthumbnail.la
-rwxr-xr-x 1 root root 6688 May 4 2004 cursorthumbnail.so
-rwxr-xr-x 1 root root 959 Jan 21 09:59 dcopserver.la
-rwxr-xr-x 1 root root 3076 Jan 21 10:01 dcopserver.so
-rwxr-xr-x 1 root root 1157 May 4 2004 devices_panelapplet.la
-rwxr-xr-x 1 root root 89684 May 4 2004 devices_panelapplet.so
-rwxr-xr-x 1 root root 1031 May 4 2004 djvuthumbnail.la
-rwxr-xr-x 1 root root 8932 May 4 2004 djvuthumbnail.so
-rwxr-xr-x 1 root root 1106 May 4 2004 dockbar_panelextension.la
-rwxr-xr-x 1 root root 48852 May 4 2004 dockbar_panelextension.so
-rwxr-xr-x 1 root root 1122 May 4 2004 extensionproxy.la

Because I also tried installing a similar program (KXDocker) and used ./configure --with-extra-libs=/usr/lib/kde3 and still gave me an error that they were not installed.

reddazz 02-06-2005 11:57 AM

You typed it wrongly, those are not single quotes, look closely :)

jonlake 02-06-2005 12:18 PM

[root@jon ksmoothdock-3.5.1]# ./configure --prefix=`kde-config --prefix`
.
.
.
checking for KDE... libraries /usr/lib, headers /usr/include/kde
checking if UIC has KDE plugins available... configure: error: not found - you need to install kdelibs first.

reddazz 02-06-2005 01:57 PM

Mmmm, this is puzlling, I don't know what can fix you problems coz I am sure that the something is wrong with your kde-libs. Have you ever successfully compiled other KDE applications. I guess this could be a problem with the way Redhat packages KDE.


All times are GMT -5. The time now is 09:51 PM.