LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-08-2008, 12:35 PM   #1
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Rep: Reputation: 30
KDE - dialog windows maximized


I'm using KDE 3.5.6 and lately I've been having a problem with the dialog windows. They are always maximized now. (When I view the "Menu" from the uppermost left hand corner, "Maximize" is always checked off [active].) I have to keep clicking on the "Maximize" box to get the dialog window down to it's normal size. This happens in all apps.

How can I change the dialog windows for all apps so that those windows are back to normal?
 
Old 09-09-2008, 02:38 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
It's possible you have a "window-specific-setting" misconfigured so that it catches all window types and forces them to maximum. Look under the kde control center > desktop > window-specific settings and see if you have something with "maximize = force" or somesuch set up. If the window match settings are too loose, it will affect more than just the application it's designed for.
 
Old 09-09-2008, 03:18 PM   #3
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
Thanks I checked that and I have "Shaded = Force" set up for Art Of Illusion because it's dialog windows were scrolled up and I couldn't unshade them nor get them to show.
I just find this odd that other windows have not been affected for months until just a week or so ago.

What would be a better setting rather than "Force"?
 
Old 09-09-2008, 11:07 PM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
It's not necessarily the "force" setting itself, it's the way it's detecting what windows to apply it to; the settings in the "window" and "window-extra" tabs. Something seems to be thinking that ALL windows need to be maximized, not just the ones from one program.

But I'm not sure if the AOI is the one that's causing your problem. Shading isn't the same as maximizing. And of course, the problem could really be somewhere else instead. Have you changed any other display-related things recently?
 
Old 09-19-2008, 12:13 PM   #5
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
I think I got it now. It was a setting, I think.

In the "Control Center" in the "Window Behavior" section, then the "Moving" tab, it says, "Allow moving or resizing of maximized windows" Then below that:
Placement: (it it now set to "Smart")

It was set to "Maximize" before. By the wording of that, who would think that this setting would affect Dialog Boxes?!

Anyway, so far, the dialog boxes are behaving nicely (the right size).
 
  


Reply

Tags
dialog, kde, maximize, window


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting a program always maximized in KDE WebGraphics Slackware 4 07-25-2011 05:56 AM
xfce4 lock maximized windows compu73rg33k Linux - Software 0 01-23-2006 06:19 PM
Maximized windows stay maximized forever dreamtheater Linux - Software 0 01-23-2005 02:38 PM
Adjust KDE Maximized Window Size elempoimen Linux - Software 2 11-08-2004 05:19 PM
how to cause a program in kde to start up in a maximized window zensufi Linux - Newbie 2 08-05-2004 12:05 AM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration