LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   KDE - dialog windows maximized (http://www.linuxquestions.org/questions/linux-software-2/kde-dialog-windows-maximized-668430/)

gymnart 09-08-2008 01:35 PM

KDE - dialog windows maximized
 
I'm using KDE 3.5.6 and lately I've been having a problem with the dialog windows. They are always maximized now. (When I view the "Menu" from the uppermost left hand corner, "Maximize" is always checked off [active].) I have to keep clicking on the "Maximize" box to get the dialog window down to it's normal size. This happens in all apps.

How can I change the dialog windows for all apps so that those windows are back to normal?

David the H. 09-09-2008 03:38 AM

It's possible you have a "window-specific-setting" misconfigured so that it catches all window types and forces them to maximum. Look under the kde control center > desktop > window-specific settings and see if you have something with "maximize = force" or somesuch set up. If the window match settings are too loose, it will affect more than just the application it's designed for.

gymnart 09-09-2008 04:18 PM

Thanks I checked that and I have "Shaded = Force" set up for Art Of Illusion because it's dialog windows were scrolled up and I couldn't unshade them nor get them to show.
I just find this odd that other windows have not been affected for months until just a week or so ago.

What would be a better setting rather than "Force"?

David the H. 09-10-2008 12:07 AM

It's not necessarily the "force" setting itself, it's the way it's detecting what windows to apply it to; the settings in the "window" and "window-extra" tabs. Something seems to be thinking that ALL windows need to be maximized, not just the ones from one program.

But I'm not sure if the AOI is the one that's causing your problem. Shading isn't the same as maximizing. And of course, the problem could really be somewhere else instead. Have you changed any other display-related things recently?

gymnart 09-19-2008 01:13 PM

I think I got it now. It was a setting, I think.

In the "Control Center" in the "Window Behavior" section, then the "Moving" tab, it says, "Allow moving or resizing of maximized windows" Then below that:
Placement: (it it now set to "Smart")

It was set to "Maximize" before. By the wording of that, who would think that this setting would affect Dialog Boxes?!

Anyway, so far, the dialog boxes are behaving nicely (the right size). :D


All times are GMT -5. The time now is 01:18 PM.