LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-14-2003, 03:24 PM   #1
Drogo
Member
 
Registered: Oct 2002
Distribution: RedHat 8 or 9 (shrike)- Fedora Core 1,2
Posts: 215

Rep: Reputation: 30
Question KDE and Liquid


im running RH9 and im unable to install liquid..

when i try to configure i get an error:

checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

any idea how can i install liquid ?
 
Old 06-14-2003, 03:36 PM   #2
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
It seems that it can't find qt-mt. It can be solved relatively easy...

Go to /usr/lib/qt3/lib
Check to see if there's any file named libqt-mt*.so* . It should be an executable (not a symlink). If it exists, simply create a symlink named libqt-mt.so that points to it!

If you don't have such a file, you can risk and link the symlink (libqt-mt.so) to libqt.so

The difference is that libqt-mt is responsible for multithreading, while libqt is the standard, no-multithreading. Try now. Run configure again.

Post any possible error messages...
 
Old 06-14-2003, 03:59 PM   #3
Drogo
Member
 
Registered: Oct 2002
Distribution: RedHat 8 or 9 (shrike)- Fedora Core 1,2
Posts: 215

Original Poster
Rep: Reputation: 30
theres a symlink name libqt-mt.so pointing to libqt-mt.so.3.1.1 executable ..



what can i do ?

Last edited by Drogo; 06-14-2003 at 04:41 PM.
 
Old 06-15-2003, 06:23 AM   #4
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Make sure that /etc/ld.so.conf has this line
Code:
/usr/lib/qt3/lib
Also check if the path to qt is in you path... Type:
Code:
echo $QTDIR
If nothing is displayed, edit your ~/.basrc file and add to your PATH this directory: /usr/lib/qt3/bin

Try again
 
Old 06-15-2003, 06:26 AM   #5
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
I forgot something... In your ~/.basrc add this line:
Code:
QTDIR=/usr/lib/qt3
and in the end on the file there's an 'export' line... Add QTDIR to it (like this
Code:
export USERNAME ENV PATH QTDIR
 
Old 06-15-2003, 07:52 AM   #6
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
~/.bashrc I think is what he means

Last edited by Proud; 06-15-2003 at 07:53 AM.
 
Old 06-15-2003, 09:29 AM   #7
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Sorry... Typo!
 
Old 06-15-2003, 09:47 AM   #8
Drogo
Member
 
Registered: Oct 2002
Distribution: RedHat 8 or 9 (shrike)- Fedora Core 1,2
Posts: 215

Original Poster
Rep: Reputation: 30
Hey mad_ady i have a question, on my box the directory to qt is :
[root@localhost root]# echo $QTDIR
/usr/lib/qt-3.1

my /etc/ld.so.conf looks like this

/usr/kerberos/lib
/usr/X11R6/lib
/usr/lib/sane
/usr/lib/qt-3.1/lib
/usr/lib/mysql

i think the .bashrc is diff , but im not understanding how to edit the file , here is what it looks like

# .bashrc

# User specific aliases and functions

alias rm='rm -i'
alias cp='cp -i'
alias mv='mv -i'

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi
 
Old 06-15-2003, 11:56 AM   #9
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
post your /etc/bashrc if there's one...

I'm not sure why it can't see qt...
 
Old 06-15-2003, 12:48 PM   #10
Drogo
Member
 
Registered: Oct 2002
Distribution: RedHat 8 or 9 (shrike)- Fedora Core 1,2
Posts: 215

Original Poster
Rep: Reputation: 30
Here it is

# /etc/bashrc

# System wide functions and aliases
# Environment stuff goes in /etc/profile

# by default, we want this to get set.
# Even for non-interactive, non-login shells.
if [ "`id -gn`" = "`id -un`" -a `id -u` -gt 99 ]; then
umask 002
else
umask 022
fi

# are we an interactive shell?
if [ "$PS1" ]; then
if [ -x /usr/bin/tput ]; then
if [ "x`tput kbs`" != "x" ]; then # We can't do this with "dumb" terminal
stty erase `tput kbs`
elif [ -x /usr/bin/wc ]; then
if [ "`tput kbs|wc -c `" -gt 0 ]; then # We can't do this with "dumb" terminal
stty erase `tput kbs`
fi
fi
fi
case $TERM in
xterm*)
if [ -e /etc/sysconfig/bash-prompt-xterm ]; then
PROMPT_COMMAND=/etc/sysconfig/bash-prompt-xterm
else
PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\007"'
fi
;;
screen)
if [ -e /etc/sysconfig/bash-prompt-screen ]; then
PROMPT_COMMAND=/etc/sysconfig/bash-prompt-screen
else
PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\033\\"'
fi
;;
*)
[ -e /etc/sysconfig/bash-prompt-default ] && PROMPT_COMMAND=/etc/sysconfig/bash-prompt-default
;;
esac
# Turn on checkwinsize
shopt -s checkwinsize
[ "$PS1" = "\\s-\\v\\\$ " ] && PS1="[\u@\h \W]\\$ "

if [ "x$SHLVL" != "x1" ]; then # We're not a login shell
for i in /etc/profile.d/*.sh; do
if [ -r "$i" ]; then
. $i
fi
done
fi
fi
# vim:ts=4:sw=4
 
Old 06-16-2003, 03:00 AM   #11
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Hmm... odd... I don't know what's wrong... There's a command that updates your library paths (or something), but I don't remember what it's called... (ld something...)

Question: Can you compile other programes that require qt?
 
Old 06-16-2003, 02:50 PM   #12
Drogo
Member
 
Registered: Oct 2002
Distribution: RedHat 8 or 9 (shrike)- Fedora Core 1,2
Posts: 215

Original Poster
Rep: Reputation: 30
i havent being able to complie anything.... im installing from rpms only
 
Old 06-17-2003, 10:35 AM   #13
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Why didin't you say it!
Try this:
1. Install liquid from rpm's
or
2. Install the development packages (gcc, kernel sources, x sources, and various -devel packages) and maybe it will work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mosfet's liquid theme on Redhat 8 and 9.. wheres the kde dir.? unclean Linux - Newbie 2 12-31-2003 10:32 PM
How can I get rid of the High-performance liquid theme for KDE? JoeLinux Linux - Software 2 08-23-2002 11:26 AM
Liquid for KDE 3.0 Install Errors RodDog Linux - Software 2 04-24-2002 07:11 PM
install liquid ? elite Linux - Newbie 7 04-08-2002 02:36 AM
Installing liquid... nutshell Linux - General 1 03-04-2002 06:21 AM


All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration