LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-27-2012, 01:04 PM   #1
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 261

Rep: Reputation: 5
KDE 4.8 effects don't work.


After upgrading to KDE 4.8, I get the follow error when trying to get the desktop effects that worked in my previous KDE version working again:
Code:
Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.
window effects error.png
And these effects are disabled:
window effects error1.png
So, I added the following to my /etc/X11/xorg.conf:
Code:
Section "Extensions"
    Option "Composite" "Enable"
EndSection
But that didn't help. I still get this message in my ~/.xsession-errors:
Code:
OpenGL vendor string:                   Tungsten Graphics, Inc
OpenGL renderer string:                 Mesa DRI Intel(R) Ironlake Mobile  
OpenGL version string:                  2.1 Mesa 7.9.2
OpenGL shading language version string: 1.20
Driver:                                 Intel
GPU class:                              i965
OpenGL version:                         2.1
GLSL version:                           1.20
Mesa version:                           7.9.2
X server version:                       1.9.5
Linux kernel version:                   3.2.2
Direct rendering:                       yes
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
kwin(2751): KWin requires at least Mesa 7.10 for OpenGL compositing. 
kwin(2751): Failed to initialize compositing, compositing disabled 
kwin(2751): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up
For some reason KWin thinks I have an older OpenGL version.

Interestingly, switching my compositing type from OpenGL to XRender is a small improvement, but many desktop effects still don't work.

Also, I get a KWin segmentation fault occasionally, too, which is related to this.

Thanks for the help

Last edited by Geremia; 02-27-2012 at 01:07 PM.
 
Old 02-28-2012, 03:52 PM   #2
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 261

Original Poster
Rep: Reputation: 5
Installed Mesa again

So, I re-installed Mesa, and now it works...
 
  


Reply

Tags
kde, kde configuration, kwin, opengl, x11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 13.37 KDE Desktop Effects only work for root Maestro485 Slackware 1 04-29-2011 08:39 PM
fedora 13 desktop effects don't work on core i3 LUHSHAH Linux - Newbie 3 03-16-2011 01:20 AM
Desktop Effects used to work now they don't! hudsonryde Linux - Software 8 02-22-2010 03:15 PM
Rain effects In XGL on SuSE 10.1 don't work Alex777 Linux - Desktop 2 12-25-2006 01:42 AM
GDM, WM's Don't work. Only KDE ReasonPointZero Linux - General 14 03-05-2003 04:14 AM


All times are GMT -5. The time now is 03:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration