LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   KDE 3.5.2, hal, pmount: can't access floppy from media:/ in konqueror (http://www.linuxquestions.org/questions/linux-software-2/kde-3-5-2-hal-pmount-cant-access-floppy-from-media-in-konqueror-451291/)

DaneM 06-03-2006 04:21 PM

KDE 3.5.2, hal, pmount: can't access floppy from media:/ in konqueror
 
Hello.

I have recently installed pmount and hal in my Gentoo box (fully updated), and have run into a problem. When I go to media:/ in Konqueror, I can access all my drives except for the floppy. When I click on the floppy icon, it mounts, but displays nothing. I know it mounts because when I navigate to /media/floppy in the BASH prompt, I am able to read the contents of the disk. If I go back and click on the floppy icon again, it gives me the following error (and still displays nothing):

Quote:

Could not mount device.
The reported error was:
mount: according to mtab, /dev/floppy/0 is already mounted on /media/floppy
mount failed
I have tried with and without any fstab entry for the floppy, and have tried using fs type "auto" and "vfat", but to no avail (except that it will mount more quickly when I have the fstab entry). Here is my current fstab entry:

Code:

/dev/fd0                /media/floppy  auto            noauto,group,sync 0 0
Any ideas?

Thanks in advance.

--Dane

rkelsen 06-04-2006 07:29 PM

Quote:

Originally Posted by DaneM
When I go to media:/ in Konqueror, I can access all my drives except for the floppy. When I click on the floppy icon, it mounts, but displays nothing. I know it mounts because when I navigate to /media/floppy in the BASH prompt, I am able to read the contents of the disk.

What version of KDE? I've seen this behaviour with KDE 3.5.2.

While things can probably be made to work properly, I couldn't resolve the problem you've described. Another problem I found was that Audio CDs stop playing whenever I inserted a USB key or tried to access the 'Storage Media' folder. I hope these issues will be resolved in future KDE releases.

If you have an /etc/fstab entry for it, you might be better off creating a "link to device" icon on your desktop and using that to mount & unmount it.

Alternatively, you could use MtoolsFM to access the floppy disk without mounting it at all.

DaneM 06-04-2006 09:18 PM

Thanks for the reply!

Bummer that you were unable to fix it on your computer. I have put a floppy icon on my desktop, and that seems to be working. Maybe somebody else will have an idea that will help us both.

Cheers!

--Dane


All times are GMT -5. The time now is 11:16 PM.