LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-25-2004, 01:08 AM   #1
KungFuHamster
Member
 
Registered: Feb 2003
Location: Middle of frickin' nowhere
Distribution: The One True Distro
Posts: 230

Rep: Reputation: 30
KDE 3.2 Screwed Up My Sound, Can't Fix


On a whim, I decided to give KDE 3.2 a try. I emerged kdelibs and kdebase, and went from there. Everything was going good, until I decided to include kdemultimedia.

Big mistake.

Once that was installed, my sound began acting up. I'd hear a bit of static, and the occasional morse code-like beeping. This, combined with a few other things that turned me off about KDE, led me to simply remove the whole damned thing, thinking that would restore the sound. So I unmerge kdemultimedia, kdelibs, and kdebase. No luck.

Every time I restart, I get a big burst of static into my headphones, followed my intermittent bursts every few seconds. It gets worse once I go into X; every time I click on something or try loading a web page, I get static while whatever program I'm using is working.

I've re-emerged alsa-lib, with no luck.

I've stopped, started, and restarted alsasound at least a dozen times. No luck.

I've fiddled with the volumes with alsamixer. No luck.

I haven't changed anything kernel-wise (running 2.6.2 ATM), and I've purged my entire system of anything KDE-related, and still no luck.

Ideas?
 
Old 02-25-2004, 01:14 AM   #2
jarib
Member
 
Registered: Jun 2003
Location: British Columbia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
Try alsaconf?
 
Old 02-25-2004, 01:23 AM   #3
KungFuHamster
Member
 
Registered: Feb 2003
Location: Middle of frickin' nowhere
Distribution: The One True Distro
Posts: 230

Original Poster
Rep: Reputation: 30
No dice.
 
Old 02-27-2004, 10:48 AM   #4
hyperlink1uk
Member
 
Registered: Mar 2003
Posts: 37

Rep: Reputation: 15
Hi, Your problem is with the following file (At least on SuSE 9.0)

/etc/asound.state

My solution might not work for you since I had the correct file from a second installation of SuSE 9.0 I had.

//For newbes replace username in all commands and files with your username:

Type the following

//No Idea whether this will work on non SuSE 9 systems

/etc/init.d/alsasound stop

rm /etc/asound.state

/etc/init.d/alsasound start

Reboot

Log into gnome and see if you can play a CD (Make sure the program you use is not an ARTS driven one)

If you have sound working well done copy that file for example

cp /etc/asound.state /etc/asound.state.new
___________________________________

Now log into KDE 3.2 does it mess your sound up?

If it does I use the following work around, its far from idealy but untill I find a better solution its all that I could get to work

//You need to stop the alsa server copy the backup asound.state file and restart the alsa
//This is how I do it

visudo
//add the following
%users ALL=(ALL) NOPASSWD /etc/init.d/alsasound stop
%users ALL=(ALL) NOPASSWD /etc/init.d/alsasound start
%users ALL=(ALL) NOPASSWd /home/username/.alsafix/TextFile

Now save the file by pressing esc and typing :wq
NOTE:above should be %users and not your username


Ok now in a terminal type the following

mkdir .alsafix
cd .alsafix

//CREATING COPY ASOUND FILE
vi TextFile
//Type the following
#! /bin/bash
cp /etc/asound.state.new /etc/asound.state
//Now save the file
press esc and then :wq

//CREATING ALSA FIX FILE

vi run
//Type the following
#! /bin/bash
sleep 10
sudo /etc/init.d/alsasound stop
sudo /home/username/.alsafix/run
sudo /etc/init.d/alsasound start
//Now save the file
press esc and then :wq

________________________

//SETTING FILE PERMISSIONS

open konqueror up at /home/username/.alsafix


Right Click on TextFile and go to properties then permissions
Click the make executable
Change the top pull down list to can read only
Click ok
---------------------------------------------------------------------------------------
Right Click on run
And do as above for TextFile

//TEST
type /home/username/.alsafix/run

Has the hissing stopped? If it has not check that you have done all of the above

If it has type
cp /home/username/.alsafix/run /home/username/.kde/Autostart/run
//Make sure the file permissions are still ok

Now reboot and login to Kde has the hissing etc stopped does sound work?

WARNING the arts server still seems to be able to muck system settings up, for example my version of xine is a nightmere

To get round this you could run the run command with your xine command for example

Hope this helps you in someway and don't stop using KDE 3.2 its much better than gnome or Kde 3.1 etc: The instructions above are basic I know you prolly know all this having installed kernel 2.6 but some people might not
I am new to bash so sorry. Just added the sleep command as on my system run is run to early and has no effect the sleep command allows arts to mess up then fixes alsa for it



Anyone got a better fix

Last edited by hyperlink1uk; 02-27-2004 at 11:04 AM.
 
Old 02-27-2004, 11:27 AM   #5
KungFuHamster
Member
 
Registered: Feb 2003
Location: Middle of frickin' nowhere
Distribution: The One True Distro
Posts: 230

Original Poster
Rep: Reputation: 30
That didn't help. I removed asound.state and rebooted, and I still get the hissing and popping.

I didn't try the KDE fix because I removed KDE in an attempt to get the sound working again.

Could you email me your asound.state file (or post it here)? Maybe if I use yours instead it'll fix itself.
 
Old 02-27-2004, 11:53 AM   #6
hyperlink1uk
Member
 
Registered: Mar 2003
Posts: 37

Rep: Reputation: 15
Hi,
Sorry that did not work, i throught you might need a replacement asound.state file since it kept happening to me :

Download

http://www.linuxuinfo1.org.uk/files/asound.state

run /etc/init.d/alsasound stop

copy file across

run /etc/init.d/alsasound start

Give that ago might not work though since this file might be sound card dependant let me know if that file does not work
 
Old 02-27-2004, 12:04 PM   #7
KungFuHamster
Member
 
Registered: Feb 2003
Location: Middle of frickin' nowhere
Distribution: The One True Distro
Posts: 230

Original Poster
Rep: Reputation: 30
That didn't help. Still getting the hissing and popping.
 
Old 02-27-2004, 01:16 PM   #8
hyperlink1uk
Member
 
Registered: Mar 2003
Posts: 37

Rep: Reputation: 15
Hi,

The only further advice i can give you is to run alsaconfig and go to the amplifer section and press M. Some people said that has worked for them. It could just be you need the correct asound.state file for your sound card and thats why mine did not fix it. Just out of interest was it kde3.2 or one of the betas or rc builds. Just to check you did stop alsa before copying the file across? Otherwise alsa will overwrite it when it shuts down or is restarted. What sound card do you have? What distro?
 
Old 02-27-2004, 02:01 PM   #9
KungFuHamster
Member
 
Registered: Feb 2003
Location: Middle of frickin' nowhere
Distribution: The One True Distro
Posts: 230

Original Poster
Rep: Reputation: 30
I don't have alsaconfig on my system. Did you mean alasconf?

I ran that, and it doesn't think I have any sound cards installed at all. Is this a 2.6 thing, or is it because I compiled my sound card support into the kernel rather than as a module?

As for KDE, I installed kde-3.2.0. And yes, I did stop alsa (/etc/init.d/alsasound stop) before copying over the new asound.state. My sound card is the onboard nforce2 card using the intel i8x0 driver.
 
Old 02-28-2004, 03:17 AM   #10
hyperlink1uk
Member
 
Registered: Mar 2003
Posts: 37

Rep: Reputation: 15
Hi,
I have never had my sound card driver built into the kernel so not to sure, in your modules.conf file have you still got an entry for your sound card? Also on SuSE 9.0 the file /etc/init.d/alsasound needed to be changed because the script used modprobe -c which does not exist any more, for the new mod-utils for kenerl 2.6.
My advice would be to try using a module, and check the entry in modules.conf matches the name of the driver in kernel 2.6.
At the moment does dmesg give any errors after you have run /etc/init.d/alsasound config, because if it does not believe a sound card is installed it might be giving an error message.
If you do decide to config a module remeber to replace your kernel with the new one as well otherwise you will prolly get problems loading it.
What version of Geneto are you using?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
screwed up, wife will force windows on me if I don't fix this elsmack Linux - Newbie 6 03-18-2005 03:01 AM
Help!!! Kde Screwed Up!!! whishkah Linux - Software 1 02-10-2005 02:17 PM
KDE screwed my sound over sirgregsalot Linux - Software 2 07-30-2004 10:12 PM
I screwed up my /etc/rc.d/rc.local...How do I fix it? tjt Linux - Newbie 4 07-27-2004 10:46 PM
my dad screwed up mozilla, help fix it ShawnD Linux - Software 2 07-22-2002 01:55 AM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration