LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-16-2004, 03:00 AM   #1
muzicman82
Member
 
Registered: Nov 2003
Posts: 79

Rep: Reputation: 15
KDE 3.2 - How do I get anti aliased fonts?!


Ok, my specs are in my signature... but...

I just installed KDE 3.2 for Debian, and now my fonts are all jagged... I enabled Anti-aliased fonts in the Fonts Panel, but it doesn't do anything... I am using the nvidia driver. What do I need to do? What packages do I need? I am using whatever XFree86 that Debian comes with.. I think its 4.2.??. I see on Debian's package search that 4.3.0pre1 is listed as Experimental... so... is it worth trying that??

Any info would rock!
 
Old 02-16-2004, 08:58 AM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Just to let you know, your specs aren't in your signature.

Are you using woody (stable) or sarge/sid (testing/unstable)?
How did you do the install? apt sources? from where?

I'm looking at doing the same thing in the next couple days, but KDE 3.2 is kinda shaky on Debian, as of yet. There are some dependancy issues, needing to mix packages between testing/unstable, and things don't always play nice. Those issues are described here:

http://wiki.debian.net/?DebianKDE

Now, it sounds like you don't have fonts properly configured. This might be a relic from installation - maybe the right font packages weren't installed. These should have come with the basic X installation though... Read section 4 of the FONT HOWTO:

http://www.tldp.org/HOWTO/Font-HOWTO/

and make sure your font paths exist and are properly referenced in configuration files.

Let me know how things go - like I said, I'm going to be doing the same thing sometime this week, so if you can post more detailed information I'm happy to help you out. Or at least share the pain.

--Rounan
 
Old 02-16-2004, 09:41 AM   #3
ghostwalker
Member
 
Registered: Jun 2003
Posts: 160

Rep: Reputation: 30
Select Configure anti-aliasing fonts http://jetblackz.cjb.net/
 
Old 02-16-2004, 09:45 AM   #4
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
make sure you have some true type fonts somewhere and that you have specified them in /etc/X11/XF86Config
 
Old 02-16-2004, 10:38 AM   #5
muzicman82
Member
 
Registered: Nov 2003
Posts: 79

Original Poster
Rep: Reputation: 15
Thanks so much guys...

Well, I verified my XF86Config-4 and XftConfig files and they were all correct as per some tutorials I found already.. I did notice that the TrueType fonts folder didn't exist, but I created it even though there's no fonts in there yet.

It turned out that my KDE was using the Helvetica font, which for whatever reason just looks nasty. I changed to Nimbus Sans L and it looks WAY better... it appears to be anti-aliased correctly...

I don't get why I can see Bitstream Vera Sans in some program font lists, but it doesn't appear in others, such as KDE's Font Panel.

Individual programs also anti-alias fonts correctly... I guess they built the program with it? Or is my anti-alias really working and its just font issues?

I'm going to start a new thread for KDE 3.2 / Debian issues. I'll post there some of the things I've noticed and... what I still need help with...

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anti-Aliased fonts in aMSN? imanex Linux - Software 1 10-18-2005 04:38 AM
kde fonts are no longer anti-aliased after XFree86 upgrade (apt) but gnome is fine? scobiej Red Hat 0 11-25-2003 07:28 AM
anti-aliased fonts sridharinfinity Slackware 1 10-25-2003 06:00 PM
Anti Aliased fonts? justiceisblind Linux - Newbie 2 01-30-2003 10:11 AM
how to enable anti-aliased fonts? neo_nirvane Slackware 3 01-28-2003 06:29 AM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration