LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-28-2003, 04:53 PM   #1
Oricon
LQ Newbie
 
Registered: Dec 2002
Posts: 17

Rep: Reputation: 0
Kde 3.1.1


I'm tring to upgrade to the newest KDE so I went and got QT got it configured and installed and everything but I'm still getting this.

qt >= 1:3.1.2 is needed by kdelibs-3.1.1-0.8x.2


Any help? I'd really like to get 3.1.1 working.


Thanks in advance.
 
Old 03-28-2003, 05:09 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
I guess you try RPM KDE version. Have you installed QT from source or from RPM? If you'd like to have KDE from RPMs, you need QT from RPM, too.
 
Old 03-28-2003, 05:10 PM   #3
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
The QT file might have gone bad in the download. Try getting it again. I got all the files from ftp://mirrors.midco.net/pub/kde/stab...edHat/8.0/i386 and it worked perfectly.
 
Old 03-28-2003, 05:16 PM   #4
Oricon
LQ Newbie
 
Registered: Dec 2002
Posts: 17

Original Poster
Rep: Reputation: 0
I did source and it went all good from the looks of it....... I guess I'll try to download them from there and try again
 
Old 03-28-2003, 05:55 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
Quote:
Originally posted by Oricon
I did source and it went all good from the looks of it....... I guess I'll try to download them from there and try again
KDE RPMs won't find QT compiled from source. You need QT from RPM to satisfy dependencies.

I guess the source package was downloaded correctly. It unpacked without problems and you were able to compile it.
 
Old 03-28-2003, 06:10 PM   #6
Oricon
LQ Newbie
 
Registered: Dec 2002
Posts: 17

Original Poster
Rep: Reputation: 0
feh.... where can I get the rpms of QT?
 
Old 03-28-2003, 06:26 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
ftp://ftp.kde.org/pub/kde/stable/3.1...0.8x.1.src.rpm is a link to a src.rpm, you need to rebuild it. If unsure how to do it, please read this thread: http://www.linuxquestions.org/questi...ce+rpm+install
 
Old 03-28-2003, 09:07 PM   #8
Oricon
LQ Newbie
 
Registered: Dec 2002
Posts: 17

Original Poster
Rep: Reputation: 0
Feh.....


this is what I get now after I rebuilt the source rpm.....

-points to screenshot-

http://www.eternalgamers.com/images/Screenshot.jpg
 
Old 03-28-2003, 09:17 PM   #9
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
Are you trying to install them one-by-one? Maybe try exitting X and running rpm -Uvh /root/kdein/*.rpm .
 
Old 03-29-2003, 04:29 AM   #10
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
Quote:
Originally posted by Oricon
Feh.....


this is what I get now after I rebuilt the source rpm.....

-points to screenshot-

http://www.eternalgamers.com/images/Screenshot.jpg
You have rebuild it. But have you installed it after rebuild?
rpm -Uvh /usr/src/packages/RPMS/i386/pakcage.i386.rpm (or different location).
 
Old 03-29-2003, 11:16 AM   #11
Oricon
LQ Newbie
 
Registered: Dec 2002
Posts: 17

Original Poster
Rep: Reputation: 0
I got it fixed it all works now and I got KDE 3.1.1 thanks
 
Old 03-29-2003, 11:36 AM   #12
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
Just in case others have the same problem, what was the winning combination?
 
Old 03-29-2003, 11:59 AM   #13
Oricon
LQ Newbie
 
Registered: Dec 2002
Posts: 17

Original Poster
Rep: Reputation: 0
I rebuilt the source rpm of QT and then did rpm -Uvh /root/kdein/*.rpm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker SUSE / openSUSE 1 02-13-2005 09:01 PM
Why wont my KDE 3.2 FC2 setup run make commands w/KDE 1.x packages? rusty_slacker Linux - Newbie 1 09-19-2004 06:40 PM
dpi font | gdm | kde DE | xinitrc.kde | Slackware 10 acummings Slackware 2 07-28-2004 11:28 PM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 10:54 AM
[REDHAT KDE] Disable KDE boot? Apache down after 10min losing monitor signal bjwesselink Linux - Software 2 08-11-2003 02:52 PM


All times are GMT -5. The time now is 01:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration