LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-02-2003, 01:15 PM   #1
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Rep: Reputation: 15
Karamba


Hi all i am runing Redhat 9 . tryin to install Karamba 0.17
but no luck.

configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
[root@10 karamba-0.17]#


what 2 do .
 
Old 08-02-2003, 01:19 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
install ">= Qt 3.0" like it says in the error
 
Old 08-02-2003, 01:36 PM   #3
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
from where ?
 
Old 08-02-2003, 01:38 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
ftp://ftp.rpmfind.net/linux/redhat/9...1.1-6.i386.rpm
 
Old 08-02-2003, 01:39 PM   #5
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
great i will install it . and let u know how it doing .
 
Old 08-02-2003, 01:49 PM   #6
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
ok install it and still got the same eror
 
Old 08-02-2003, 01:52 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Sorry - it probably wants the development files:
ftp://ftp.rpmfind.net/linux/redhat/9...1.1-6.i386.rpm

You may want to install libjpeg as well:
ftp://ftp.rpmfind.net/linux/redhat/9...6b-26.i386.rpm
 
Old 08-02-2003, 02:09 PM   #8
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
this 2 Packes are installd .
and still i got the same eror !

what 2 do ?
 
Old 08-02-2003, 02:28 PM   #9
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Try:
./configure --help

There may be an option to point to a specific location for the qt headers and libraries.
 
Old 08-02-2003, 02:29 PM   #10
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
you have to configure karamaba with the proper qt directory...i am almost willing to bet that your qt directory is named:
/usr/lib/qt-3.1 and that is not in the configure script which in turn is why you are getting the error....so you have 1 of 2 choices.
manually edit the configure script to point to the qt directory on your box or pass the qt argument in the configure script like so:
./configure --with-qt-dir=/usr/lib/qt-3.1 which may or may have to be changed to whatever yours is named, but i am pretty confident that this will be the name of your qt directory.
 
Old 08-02-2003, 02:31 PM   #11
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
thx for the tip m8 but its give me a long list of command that i have no idea what too do with that
 
Old 08-02-2003, 03:10 PM   #12
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
ok I try ./configure --with-qt-dir=/usr/lib/qt-3.1

my qt dir is /usr/lib/qt-3.1

but still no luck.
 
Old 08-02-2003, 03:20 PM   #13
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
Any Ideas why ?
 
Old 08-02-2003, 03:45 PM   #14
Born^Dead
Member
 
Registered: Mar 2003
Posts: 87

Original Poster
Rep: Reputation: 15
Please Help Me . , .

thx
 
Old 08-02-2003, 03:53 PM   #15
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well if your positive that that is in fact the right path to qt, and if that didn't work (which boggles my mind) then your going to have to manually edit the configure file.
actually post the exact message that it says when you throw in that command line argument --with-qt-dir
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
karamba *not super karamba* whishkah Linux - Software 1 09-28-2004 09:59 AM
Please help...karamba.... Veteq Linux - Newbie 3 04-01-2004 09:56 PM
****Karamba**** iLLuSionZ Linux - General 3 11-22-2003 11:03 AM
karamba iLLuSionZ Linux - Newbie 4 11-20-2003 10:36 PM
Karamba Help Evohack Linux - Software 2 08-07-2003 10:19 PM


All times are GMT -5. The time now is 07:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration