LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-22-2007, 06:44 PM   #1
john2
Member
 
Registered: Aug 2004
Location: UK
Distribution: SolydK, Kubuntu, Mageia, OpenSUSE
Posts: 81

Rep: Reputation: 22
Kaffeine problem - DVB radio and audio CDs


I have a Hauppauge WinTV Nova-T USB digital terrestrial TV stick. It works fine on a desktop PC under both XP Home and Ubuntu Feisty 64-bit (using Kaffeine), and on a laptop (Dell Inspiron 9400 with ATI graphics) using XP Media Center Edition. If I try to use it in Feisty 32-bit (again with Kaffeine) on the Dell, it works fine with TV stations, but if I try to use a radio station, Kaffeine crashes.

The same thing happens if I try to play audio CDs using Kaffeine, but audio CDs play OK using Sound Juicer.

It looks as if there is a problem where there is audio but no video.

Messages from tuning to BBC FOUR, then BBC NEWS 24, then attempting to tune to BBC Radio 3 (all work fine except the radio station) are:
Code:
Tuning to: BBC FOUR / autocount: 0
DvbCam::probe(): /dev/dvb/adapter0/ca0: : No such file or directory
Using DVB device 0:0 "DiBcom 7000PC"
tuning DVB-T to 666000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
. LOCKED.
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 467 ms
pipe opened
xine pipe opened /home/user1/.kaxtv.ts
Asked to stop
pipe closed
Live stopped
dvbstream::run() end
dvbEvents 0:0 ended
fdDvr closed
Frontend closed
Tuning to: BBC NEWS 24 / autocount: 1
Using DVB device 0:0 "DiBcom 7000PC"
tuning DVB-T to 618000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
. LOCKED.
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 393 ms
pipe opened
xine pipe opened /home/user1/.kaxtv1.ts
Asked to stop
pipe closed
Live stopped
dvbstream::run() end
dvbEvents 0:0 ended
fdDvr closed
Frontend closed
Tuning to: BBC Radio 3 / autocount: 2
Using DVB device 0:0 "DiBcom 7000PC"
tuning DVB-T to 642000000 Hz
inv:2 bw:0 fecH:9 fecL:9 mod:6 tm:2 gi:4 hier:4
. LOCKED.
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 390 ms
pipe opened
xine pipe opened /home/user1/.kaxtv.ts
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  141
  Minor opcode:  17
  Resource id:  0x3c00003
KCrash: Application 'kaffeine' crashing...
kaffeine: Fatal IO error: client killed
ICE default IO error handler doing an exit(), pid = 6536, errno = 104
With audio CDs:
Code:
Checking /dev/cdrom for cdrom...
        Testing /dev/cdrom for SCSI/MMC interface
                SG_IO device: /dev/scd0

CDROM model sensed sensed: TSSTcorp DVD+-RW TS-L532B DE04 

Checking for SCSI emulation...
        Drive is ATAPI (using SG_IO host adaptor emulation)

Checking for MMC style command set...
        Drive is MMC style
        DMA scatter/gather table entries: 1
        table entry size: 131072 bytes
        maximum theoretical transfer: 55 sectors
        Setting default read size to 13 sectors (30576 bytes).

Verifying CDDA command set...
        Expected command set reads OK.
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  141
  Minor opcode:  17
  Resource id:  0x3c00003
KCrash: Application 'kaffeine' crashing...
kaffeine: Fatal IO error: client killed
ICE default IO error handler doing an exit(), pid = 7050, errno = 104
 
Old 01-04-2008, 05:04 PM   #2
john2
Member
 
Registered: Aug 2004
Location: UK
Distribution: SolydK, Kubuntu, Mageia, OpenSUSE
Posts: 81

Original Poster
Rep: Reputation: 22
Kaffeine eventually stopped working altogether - I presume an upgrade to something did it. I have finally found a solution though (sort of)...

I installed xserver-xgl. Kaffeine (and the underlying Xine engine) now work normally. The downside is a large increase in CPU usage. Some other things may also not work - Google Earth for instance.

To disable Xgl after you install it, create directory xserver-xgl under the .config directory in your home directory (unless it already exists), then create an empty file called disable in this directory, and reboot. To enable Xgl, rename the file to enable and reboot.
 
  


Reply

Tags
audio, cd, dvb, kaffeine, ubuntu, xine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kaffeine DVB and paytv Murmlrmpf Linux - Software 5 02-26-2008 10:41 AM
Problem with DVB-T passthrough audio Jykke Linux - Hardware 1 08-15-2007 05:08 AM
Kaffeine recognizes DVB cards, scans channels, but DVB icon remains dim. Ekkume Ubuntu 5 01-24-2006 11:45 AM
How can I set up DVB - T with Kaffeine? Apappasmurf Linux - Software 0 11-27-2005 05:47 AM
Audio CDs will only play in xine or kaffeine if I am connected to the internet Marrea Linux - Software 3 05-11-2004 12:55 PM


All times are GMT -5. The time now is 11:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration