LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-02-2005, 01:27 AM   #1
Toonses82
Member
 
Registered: Sep 2004
Location: Olympia, WA, USA
Distribution: Linux Mint 16 Cinnamon
Posts: 117

Rep: Reputation: 15
Arrow Kaffeine 0.5 crashes - signal 11 (SIGSEGV)


Ladies and gentlemen. I can't play a DVD in Mandrake.

Kaffeine was playing DVDs fine before but I had to do a clean reinstall to fix some other problems. Ever since then, Kaffeine Crashes when playing a DVD. Totem crashes. And Mplayer freezes up. I like Kaffeine and would like to continue using it as I did before. Since I discovered the problem, I've upgraded to the newest release of Kaffeine, reinstalled (clean) Mandrake 2 or 3 times, and did a jig. Twice. All for nothing. The problem persists. I was thinking it had something to do with libdvdcss, but then again, I never had to install that before and it worked. I tried installing it anyway, but I don't think I did it correctly.

I tried playing DVDs in Knoppix 3.3 and MandrakeMove 2.0. Same result. They were all running on the KDE desktop.

I tried playing the movie in Windows XP. It works! I've had a taste of victory watching DVDs in Mandrake before so I KNOW it's possible. Here's what happens when I run Kaffeine:
Code:
[root@localhost kris]# kaffeine
Main: XInitThreads()
[INFO] If Kaffeine hangs here run 'configure --with-xorg' and recompile/reinstall.
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
kaffeine: Window manager: not KWin - using save fullscreen mode
kaffeine: SystemTray: Create System Tray
kaffeine: Kaffeine:: Try to load service: kaffeine_part
kaffeine: This is a KMediaPart...
kaffeine: KaffeinePart: Creating new KaffeinePart...
kaffeine: PlayList: add 1 items to playlist
kaffeine: PlayList: Check for kaffeine/noatun/m3u/pls/asx playlist
kaffeine: PlayList: Try loading kaffeine playlist
kaffeine: PlaylistImport: kaffeine: /root/.kde/share/apps/kaffeine/playlists/Playlist1.kaffeine
kaffeine: Kaffeine: Set screensaver timeout to: 2 min
[root@localhost kris]#
Then I select "Play DVD" in the menu in the Kaffeine GUI. Then I get this:
Code:
[root@localhost kris]# kaffeine: KXineWidget: Display aspect ratio (v/h): 1.01234
kaffeine: KXineWidget: Using xine version 1-rc5
kaffeine: WARNING: KXineWidget: No config file found, will create one...
kaffeine: KXineWidget: Post-init xine engine
kaffeine: KXineWidget: Use audio driver auto
kaffeine: KXineWidget: Use video driver auto
kaffeine: KXineWidget: Init video driver
kaffeine: KXineWidget: Init audio driver
kaffeine: KXineWidget: Init OSD
kaffeine: KXineWidget: Font for OSD: sans
kaffeine: KXineWidget: Unscaled OSD available
kaffeine: KXineWidget: Start event loop...
kaffeine: KXineWidget: xine init successful
kaffeine: KaffeinePart: load config
kaffeine: Set volume to: 70
kaffeine: KXineWidget: New visualization plugin: goom
kaffeine: PostFilter: Create Postprocessing Filter: tvtime
kaffeine: PostFilter: Parameter: method
kaffeine: PostFilter: Parameter: enabled
kaffeine: PostFilter: Parameter: pulldown
kaffeine: PostFilter: Parameter: framerate_mode
kaffeine: PostFilter: Parameter: judder_correction
kaffeine: PostFilter: Parameter: use_progressive_frame_flag
kaffeine: PostFilter: Parameter: chroma_filter
kaffeine: PostFilter: Parameter: cheap_mode
kaffeine: PostFilter: Get input
kaffeine: PostFilter: Get output
kaffeine: PostFilter: SetConfig tvtime:method=LinearBlend,enabled=1,pulldown=none,framerate_mode=half_top,judder_correction=0,use_progressive_frame_flag=1,chroma_filter=0,cheap_mode=1
kaffeine: PostFilter: tvtime Apply integer value 1 on offset 4
kaffeine: PostFilter: tvtime Apply integer value 0 on offset 16
kaffeine: PostFilter: tvtime Apply integer value 0 on offset 16
kaffeine: PostFilter: tvtime Apply integer value 1 on offset 20
kaffeine: PostFilter: tvtime Apply integer value 0 on offset 24
kaffeine: PostFilter: tvtime Apply integer value 1 on offset 28
kaffeine: PostFilter: tvtime Apply integer value 1 on offset 28
kaffeine: KXineWidget: Deinterlace enabled: 1
kaffeine: PostFilter: Get output
kaffeine: PostFilter: Get input
kaffeine: KXineWidget: Playing: /usr/share/apps/kaffeine/logo
[mpeg4 @ 0x41dcd950]frame skip 8
[mpeg4 @ 0x41dcd950]frame skip 8
kaffeine: KXineWidget: New video frame size: 640x364 - aspect ratio: 1
kaffeine: KXineWidget: Switch to audio channel -1
kaffeine: KaffeinePart::openURL(): dvd:/
kaffeine: KaffeinePart: Got single track
kaffeine: KaffeinePart::slotPlay()
kaffeine: KXineWidget: New video frame size: 640x364 - aspect ratio: 1
kaffeine: KXineWidget: Playing: dvd:/
libdvdnav: Using dvdnav version 1-rc5 from http://xine.sf.net
libdvdread: Encrypted DVD support unavailable.
libdvdnav: DVD Title: OPEN_WATER
libdvdnav: DVD Serial Number: 4196B715___MVB__
libdvdnav: DVD Title (Alternative):
libdvdnav: Unable to find map file '/root/.dvdnav/OPEN_WATER.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fe0000. Regions: 1
kaffeine: KXineWidget: Wait for valid length information
kaffeine: KXineWidget: Switch to audio channel -1
kaffeine: KaffeinePart: xine is playing
kaffeine: KXineWidget: New video frame size: 640x364 - aspect ratio: 1
kaffeine: KaffeinePart: got new frame size from xine
kaffeine: Kaffeine: new video frame size: 640x364
libdvdread: Invalid IFO for title 13 (VTS_13_0.IFO).
libdvdnav: ifoOpenVTSI failed - CRASHING!!!
libdvdnav: ifoRead_VTS_PTT_SRPT failed - CRASHING!!!
libdvdnav: ifoRead_PGCIT failed - CRASHING!!!
libdvdnav: ifoRead_PGCI_UT failed - CRASHING!!!
libdvdnav: ifoRead_VOBU_ADMAP vtsi failed - CRASHING
libdvdnav: ifoRead_TITLE_VOBU_ADMAP vtsi failed - CRASHING
KCrash: Application 'kaffeine' crashing...
kaffeine: Fatal IO error: client killed
kaffeine: KXineWidget: xine event: channels changed
kaffeine: KXineWidget: xine event: ui set title
kaffeine: KXineWidget: New video frame size: 640x364 - aspect ratio: 1
kaffeine: Fatal IO error: client killed
Mutex destroy failure: Device or resource busy
ICE default IO error handler doing an exit(), pid = 7028, errno = 0
Anyone know what's going on here? I appreciate the help and I apologize for the ridiculously long post.
 
Old 02-02-2005, 02:46 AM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
It looks like there's an error in the libdvdread? I'm just guessing.

Do you know how to use URPMI and setting up sources? If you find a good PLF source, then you can just urmpi libdvdcss and libdvdread and it will install it correctly for you.
 
Old 02-02-2005, 10:11 AM   #3
Toonses82
Member
 
Registered: Sep 2004
Location: Olympia, WA, USA
Distribution: Linux Mint 16 Cinnamon
Posts: 117

Original Poster
Rep: Reputation: 15
Talking

Micro420, you are the smartest person in the world. That fixed it! I went to the control center and made sure that both libdvdcss and libdvdread were removed. And then I found a libdvdcss rpm by PLF and installed that. I couldn't find any libdvdread rpms for my distro so I just got the one off the Mandrake DVD. Now it works!

It's so weird that I had to do this though. I never had to deal with any of this before I did the clean install, but everything worked. Unsolved mystery I guess. At least it works now.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple applications crash with Signal 11 in SIGSEGV k41184 Linux - Software 14 04-18-2006 02:19 AM
Program received signal SIGSEGV, Segmentation fault ims_mca Linux - Distributions 0 03-09-2005 05:16 AM
k3b crashes with signal 11 sigsegv cf050 Linux - Software 0 11-19-2004 10:39 AM
signal handling (SIGSEGV) in threads Sinner6 Programming 1 11-09-2004 05:52 PM
Konqueror crashed and caused the signal 11 (SIGSEGV) bill.692 Linux - Software 1 04-29-2004 12:15 PM


All times are GMT -5. The time now is 07:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration