LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-04-2004, 03:54 PM   #1
tjclancy
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
kacpid eating cpu 99% cpu time!


Hey All,

I have just installed Fedora Core 2 and have been happy, but every once in a while, randomly it seems, a process called kacpid will pop up out of no where and start eating cpu time thus dragging the system down to a crawl... what is it and how can I stop it? Its pid is always 5. And I think it has something to do with the kernel. I could find little help using google. Most hits pertained to laptop problems. I'm running linux a 2GHz pentium IV with 512K ram, a flat panel monitor, 120gig hd, standard stuff, really. any thoughts?

Thomas J. Clancy
 
Old 08-04-2004, 04:05 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Hi,

and welcome to LQ!


The thing is indeed a kernel-daemon process, it handles
power-saving functionality and a few other things that are
specific to ACPI compliant motherboards (like monitoring
temperatures, rpm's of fans, ... ) ...

You probably don't need it on your machine, if it hogs
99% CPU something is definitely wrong with your machine,
either with FUDora's set-up, or with your BIOS' ACPI
implementation...

It should be fairly safe to kill it as root ...


Cheers,
Tink
 
Old 08-04-2004, 05:36 PM   #3
tjclancy
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
That's the problem... Even as root, I cannot kill this process. How do I even prevent it from running? Is there a way to prevent it altogether?

tom
 
Old 08-04-2004, 05:46 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
There certainly is, it's most likely distro-dependent, though.
In slack I'd just
chmod a-x /etc/rc.d/rc.acpid

No idea how fc handles that kind of thing, but since it's
a RH spawn I'm sure there's a graphical gadget for it ;)



Cheers,
Tink
 
Old 08-04-2004, 06:13 PM   #5
tjclancy
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the info. You know, I used to use slackware back in the old days (way way way way back when before there was a 1.0 kernel) and I should have stuck with it... I dont like this FC or RH stuff any more. Still, it's what I have. Of course perhaps I ought to just download slack and be done with it. :-)
 
Old 08-05-2004, 01:12 PM   #6
tjclancy
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
by the way, chmoding the acpid files (I found it in two places) didn't work. There still remains a kacpid process that somehow gets spawned (by the kernel, I'm guessing) and at some random time (I'm still guessing here) it goes nuts and starts chewing up processor time for no apparent reason. Sucks. :-(
 
Old 06-04-2005, 07:36 PM   #7
amon
Member
 
Registered: May 2004
Location: UK
Distribution: Debian, Ubantu, CentOS
Posts: 146

Rep: Reputation: 17
debian also

I had the same problem with debian on a HP nx5000 laptop.

i updated to the latest kernel (via apt-get) and kacpid stopped hogging all the cpu time. but now sometimes (normaly when the laptop is under heavy load) or after the screensaver has ben running the laptop goes slow and in the case of heavy load such as updating my packages the whole thing hangs and arround the processor feels very hot.

any ideas?

I think the issue is to do with the pentium m cooling fan and have started a new thread here:
http://www.linuxquestions.org/questions/showthread.php?s=&threadid=335401

Last edited by amon; 06-20-2005 at 09:32 AM.
 
Old 06-04-2005, 10:24 PM   #8
tjclancy
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Ever since I'd posted that problem oh so long ago and had gone through so many distros I finally switched back to Fedora Core, but this time verion 3 and haven't had a problem since. It's been running smoothly on my Dell every since. As for running it on a laptop, no idea. Sorry.

tom
 
Old 10-05-2005, 12:55 PM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Hi,

Does your fan works?

I think I had the exact same problem when the modules "fan" and "thermal" were not loaded.

So,

Code:
modprobe fan
Code:
modprobe thermal
Now I have them compiled in the kernel

Hope it helps
 
Old 03-15-2006, 10:47 AM   #10
amon
Member
 
Registered: May 2004
Location: UK
Distribution: Debian, Ubantu, CentOS
Posts: 146

Rep: Reputation: 17
An update

Just to help anyone else who is having this problem (or similar symptoms) the solution turned out to be cooling related and was discussed in this thread:
http://www.linuxquestions.org/questi...hreadid=335401

The problem was that acpi and acpid packages weren't installed on my laptop causing the proessor to over heat and slow to a crawl.

in debian:
Code:
apt-get install acpi acpid
 
Old 09-21-2007, 04:01 PM   #11
steve8072@msn.com
LQ Newbie
 
Registered: Sep 2007
Location: Spokane, Washington
Distribution: Xandros Desktop 4 Professional
Posts: 2

Rep: Reputation: 0
possible easy solution

Take this with a grain of salt because I’m an absolute Linux beginner, but I had the same problem with Xandros Desktop 4 Professional (on a new eMachines, P4, 1.5 Gb, SATA, NTFS, Vista preinstalled computer) and the following worked for me: I reinstalled Xandros but omitted “KDE3 Supplemental” from the install process and the problem was gone. The description of “KDE3 Supplemental” in the Xandros installation program indicates that , at least for users who are not part of a LAN, it doesn’t do anything you would miss. There were various other solutions proposed on Linux websites but I wasn’t knowledgeable enough to understand them, grub?, debug?, what!?

Caveats:

1) Don’t waste your time contacting Xandros Installation Tech Support, they don’t have a clue. If, like me, you purchased Xandros you paid your $80.00 for nothing (although I do really like Xandros). Accept it as a lesson and go on. I came up with what worked for me using the old tried and true try-this-and-if-it-doesn‘t-work-try-that method of problem solving;

2) since this was an intermittent problem with my computer and sometimes Xandros worked fine and “kacpid” didn’t eat up 98% of my system resources I’m not certain this is a permanent solution, but so far so good; and

3) I have no idea if this is a workable solution for Linux builds other than Xandros but the problem was frustrating enough for me that I wanted to pass on what worked for me and was fairly simple to implement in case it would work for somebody else who, like me, is mystified by Linux esoterica.

Steve8072@msn.com
 
Old 09-21-2007, 04:48 PM   #12
steve8072@msn.com
LQ Newbie
 
Registered: Sep 2007
Location: Spokane, Washington
Distribution: Xandros Desktop 4 Professional
Posts: 2

Rep: Reputation: 0
kacpid uses most system resources and constantly runs hard drive

Take this with a grain of salt because I’m an absolute Linux beginner, but I had the same problem with Xandros Desktop 4 Professional (on a new eMachines, P4, 1.5 Gb, SATA, NTFS, Vista preinstalled computer) and the following worked for me: I reinstalled Xandros but omitted “KDE3 Supplemental” from the install process and the problem was gone. The description of “KDE3 Supplemental” in the Xandros installation program indicates that , at least for users who are not part of a LAN, it doesn’t do anything you would miss. There were various other solutions proposed on Linux websites but I wasn’t knowledgeable enough to understand them, grub?, debug?, what!?

Caveats:

1) Don’t waste your time contacting Xandros Installation Tech Support, they don’t have a clue. If, like me, you purchased Xandros you paid your $80.00 for nothing (although I do really like Xandros). Accept it as a lesson and go on. I came up with what worked for me using the old tried and true try-this-and-if-it-doesn‘t-work-try-that method of problem solving;

2) since this was an intermittent problem with my computer and sometimes Xandros worked fine and “kacpid” didn’t eat up 98% of my system resources I’m not certain this is a permanent solution, but so far so good; and

3) I have no idea if this is a workable solution for Linux builds other than Xandros but the problem was frustrating enough for me that I wanted to pass on what worked for me and was fairly simple to implement in case it would work for somebody else who, like me, is mystified by Linux esoterica.

Steve8072@msn.com
 
Old 05-23-2008, 01:12 PM   #13
manoj_isi
LQ Newbie
 
Registered: May 2008
Posts: 8

Rep: Reputation: 0
Thumbs up solution to kacpid

Solution to kacpid which works fine for me :
After booting windows when boot linux kacpid starts, to stop it just cut the power supply to your PC including UPS if any , without shutting down (obviously after saving data) when linux desktop is active. yes i am saying that take the power cord out.

Now switch on the power of ur machine & boot linux, kacpid will not appear.(hopefully)




Remember acpi=off will not work on dual core machines , if you use this only one core will get active
Happy Linuxing,
 
Old 09-19-2011, 04:08 PM   #14
AndyWouters
LQ Newbie
 
Registered: Sep 2011
Location: Diest, Belgium
Distribution: Fedora
Posts: 1

Rep: Reputation: Disabled
Thanks

[QUOTE=Tinkster;1088594]There certainly is, it's most likely distro-dependent, though.
In slack I'd just
chmod a-x /etc/rc.d/rc.acpid

No idea how fc handles that kind of thing, but since it's
a RH spawn I'm sure there's a graphical gadget for it

Indeed there is a graphical gadget for it, just deselect the power management from the startup applications 'gadget' in the system menu (2.6.35.14-96.fc14.i686)
That worked for me. Thanks guys!
 
  


Reply

Tags
cpu, kacpid, linux, power, resolved, solution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
courier-imap eating CPU time izghitu Linux - Newbie 14 11-30-2005 05:22 PM
XFS is eating my CPU xKintaro Debian 0 09-27-2005 10:01 AM
kacpid using 90+% cpu when plugging in pcmcia card marcushell Linux - Laptop and Netbook 0 11-05-2004 12:43 PM
ksoftirqd eating >60% of my CPU subaruwrx Fedora 0 09-22-2004 02:10 AM
KDE problem, eating away CPU apokryphos Linux - Software 4 08-24-2004 01:30 PM


All times are GMT -5. The time now is 10:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration