LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-16-2006, 12:50 PM   #1
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 233

Rep: Reputation: 30
k9copy


while trying to install this program i got the following error message when entering the "make" command
" No targets specified and no makefile found. Stop."
does anyone know what the problem is and how to fix this
 
Old 07-16-2006, 01:13 PM   #2
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
Did you run ./configure first, before make ?
And did it run successfully, without any errors ?
 
Old 07-16-2006, 03:39 PM   #3
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 233

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by hfawzy
Did you run ./configure first, before make ?
And did it run successfully, without any errors ?
yes i did here are the commands used
cd ~
tar xvf k9copy-1.0.4-2.tar.gz
cd k9copy-1.0.4-2
./configure
make(this is where the error)
 
Old 07-16-2006, 03:41 PM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
What configure said?
 
Old 07-16-2006, 03:47 PM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
It seems like configure didn't finish successfully so no makefiles were created. Can you post the last 10 - 20 lines from the configure process.
 
Old 07-16-2006, 04:13 PM   #6
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 233

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by reddazz
It seems like configure didn't finish successfully so no makefiles were created. Can you post the last 10 - 20 lines from the configure process.
here are those lines
checking crt_externs.h usability... no
checking crt_externs.h presence... no
checking for crt_externs.h... no
checking for _NSGetEnviron... no
checking for vsnprintf... yes
checking for snprintf... yes
checking for X... libraries /usr/lib, headers .
checking for IceConnectionNumber in -lICE... yes
checking for libXext... yes
checking for pthread_create in -lpthread... yes
checking for extra includes... no
checking for extra libs... no
checking for libz... -lz
checking for libpng... -lpng -lz -lm
checking for libjpeg6b... no
checking for libjpeg... -ljpeg
checking for perl... /usr/bin/perl
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

well i hope this helps you help me
 
Old 07-16-2006, 04:19 PM   #7
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
You'll have a chance when you have Qt installed.

checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!

- didn't you think this is a complaint?
 
Old 07-16-2006, 05:17 PM   #8
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 233

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by raskin
You'll have a chance when you have Qt installed.

checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!

- didn't you think this is a complaint?
yes i figured that when i posted it. but i am installing it now and i probably will be for the next week(yes that much command lines generated by Qt)
 
Old 07-16-2006, 05:20 PM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by thebiggiantmouse
yes i figured that when i posted it. but i am installing it now and i probably will be for the next week(yes that much command lines generated by Qt)
Why would it take a week to install qt? most distros have binaries for qt, so just install the ones for your distro.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
K9copy help ElJollyRancher Linux - Software 3 07-18-2006 08:13 AM
k9copy/dvdauthor error ncsuapex Linux - Software 3 06-03-2006 07:32 PM
k9copy rpm for suse 9.3 pepeq Linux - Software 2 01-16-2006 05:16 PM
k9copy guide and Ubuntu repository crispy_420 Linux - Software 0 12-24-2005 10:30 PM
k9copy and sigsegv crash gallan Linux - Software 0 08-09-2005 10:27 AM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration