LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-25-2005, 08:53 PM   #1
apachedude
Member
 
Registered: Aug 2004
Location: California
Distribution: SuSE 10.0 (SUPER)
Posts: 356

Rep: Reputation: 31
K3b inexplicably stopped working


I'm now running Slackware 10, kernel 2.6.10. I believe that the last time my k3b worked, I was still running 2.4.26, but I can't identify that for certain as the cause of my problem.

In any case, I installed the package via the .tgz binary on linuxpackages.net. k3b loads fine, but when I choose to Burn a CD image or anything like that, it will just crash on me. I get this backtrace, which I have no idea how to interpret:

Quote:
Using host libthread_db library "/lib/libthread_db.so.1".
0x41346497 in waitpid () from /lib/libpthread.so.0
#0 0x41346497 in waitpid () from /lib/libpthread.so.0
#1 0x40b485b0 in KCrash::defaultCrashHandler ()
from /opt/kde/lib/libkdecore.so.4
#2 0x41344be5 in pthread_barrierattr_setpshared () from /lib/libpthread.so.0
#3 0x00000007 in ?? ()
#4 0x00000000 in ?? ()
#5 0x0000007b in ?? ()
#6 0xc010007b in ?? ()
#7 0x08272d10 in ?? ()
#8 0x08476068 in ?? ()
#9 0xbfffe838 in ?? ()
#10 0xbfffe820 in ?? ()
#11 0x40419f90 in __JCR_LIST__ () from /opt/kde/lib/libk3bproject.so.2
#12 0x00000000 in ?? ()
#13 0x08272d10 in ?? ()
#14 0x00000000 in ?? ()
#15 0x0000000e in ?? ()
#16 0x00000004 in ?? ()
#17 0x40301042 in K3bWriterSelectionWidget::slotRefreshWriterSpeeds ()
from /opt/kde/lib/libk3bproject.so.2
 
Old 01-26-2005, 06:52 PM   #2
apachedude
Member
 
Registered: Aug 2004
Location: California
Distribution: SuSE 10.0 (SUPER)
Posts: 356

Original Poster
Rep: Reputation: 31
I did some searching on bugs.kde.org. I found several instances of this occuring, but most of the reports were marked as duplicates (but still UNCONFIRMED), which I find ridiculous. Apparently, the problem has to do with udev. There's a fix via the CVS, but I don't know how to use that.

Can anyone else confirm whether the CVS code works?
 
Old 01-27-2005, 01:59 PM   #3
apachedude
Member
 
Registered: Aug 2004
Location: California
Distribution: SuSE 10.0 (SUPER)
Posts: 356

Original Poster
Rep: Reputation: 31
Fixed when I reverted back to 2.4.26. I'm unaware if k3b crash is due to incompatibility with 2.6.10 or because I failed to compile something.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
su stopped working bulldogzerofive Linux - Software 5 01-17-2005 03:05 AM
X stopped working sueno Fedora 15 10-02-2004 01:23 PM
It stopped working. UmneyDurak Fedora 8 08-15-2004 03:41 PM
mozilla stopped working master Linux - General 13 07-05-2004 11:39 AM
My X just stopped working??? freeindy Linux - Newbie 4 11-30-2002 11:53 AM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration