LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-23-2007, 08:40 PM   #1
dralexpe
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Rep: Reputation: 15
Unhappy k3b doesn't run on Centos 5 x86_64


I cannot get k3b to copy a DVD. The debugging info is:

System
-----------------------
K3b Version: 0.12.17

KDE Version: 3.5.4-11.el5.centos CentOS
QT Version: 3.3.6
Kernel: 2.6.18-8.1.8.el5
Devices
-----------------------
LITE-ON DVDRW LH-20A1L BL02 (/dev/scd1, ) at [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-RAM; DVD-R; DVD-RW; DVD-R DL; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R Sequential; DVD-R Dual Layer Sequential; DVD-R Dual Layer Jump; DVD-RAM; DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Restricted Overwrite; Layer Jump]

LITE-ON DVD SHD-16S1S ES03 (/dev/scd0, ) at [CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM] [None]
Used versions
-----------------------
growisofs: 7.0

growisofs
-----------------------
:-( unable to anonymously mmap 33554432: Resource temporarily unavailable

growisofs command:
-----------------------
/usr/bin/growisofs -Z /dev/scd1=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -use-the-force-luke=break:1646448 -dvd-compat -speed=16 -use-the-force-luke=bufsize:32m


Should I expect this to be a hardware failure? It's on a brand new machine.

I am running Centos 5 x86_64 and this is the k3b that came with the distro. I tried running it both as root and as a regular user.

Thank you.
 
Old 07-23-2007, 10:37 PM   #2
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
Try shutting the automount off. If it is the same problem as fedora used to have K3b wants to be the only thing accessing the disk. If automount is on it also has access to the drive, then k3b gets mad.
 
Old 07-24-2007, 07:42 PM   #3
dralexpe
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Original Poster
Rep: Reputation: 15
It still doesn't work. I turned off automount, using /etc/rc.d/init.d/autofs stop and tried again with the exact same error message.

Even if I turned off automount, whenever I insert a CD/DVD I get a prompt about either opening the device or doing nothing. When I select "Do nothing" I still get the icons on the desktop; if I right click on them and select "Unmount" nothing happens. I tried to issue the command "umount /dev/scd1" and I get the message that it is unmounted.

Another thing is that k3b prompts me to insert a blank CD/DVD even though there is one in there, which is being correctly recognized as a writeable DVD. I have to select "Force" to start the copying process, which then ends in the shown error.

Any help would be appreciated.
Thanks.
 
Old 07-24-2007, 07:52 PM   #4
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
If it is still showing up on the desktop then the automount (the gnome one, assuming gnome) is not getting shut off. In Fedora it would be: System->Preferences->Hardware->Removable Drives and Media, uncheck- Mount removable media when inserted.
 
Old 07-24-2007, 09:17 PM   #5
dralexpe
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Original Poster
Rep: Reputation: 15
I was using KDE, so I switched to Gnome but to no avail. I am checking if automount is running with /etc/rc.d/init.d/autofs status and I am getting that automount is stopped. Then I checked in System->Preferences->Removable Drives and Media where I unchecked Mount removable media when inserted, but I keep getting the same error.

When I insert the DVD's, I don't see any icon for the source, but I still can see the destination (the blank one) icon as "Blank DVD-R disc" on the desktop. I tried to unmount manually, but it tells me they are already unmounted.

It still doesn't work.
 
Old 07-30-2007, 07:28 PM   #6
dralexpe
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Original Poster
Rep: Reputation: 15
I finally got it to work.

I added the option -use-the-force-luke=bufsize:16m in the user configuration section of k3b and I burned 2 DVD DL on the fly with no problem.

At the first DVD I turned off autmount using /etc/rc.d/init.d/autofs stop, but at the second one I left automount running and it still worked.

Thanks
 
Old 08-04-2007, 05:59 PM   #7
archo
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Rep: Reputation: 0
I had this same problem, and another workaround was to run k3b as root, and set ulimit before running it:

su -
ulimit -l unlimited
k3b &

It's annoying that the bug is resolved and invalid at bugs.kde.org/show_bug.cgi?id=139645
 
Old 08-05-2007, 12:37 PM   #8
dralexpe
LQ Newbie
 
Registered: Jun 2007
Posts: 27

Original Poster
Rep: Reputation: 15
Thank you for your info. I tried both as root and as a regular user, and tried the ulimit -l unlimited and it still didn't work.

It worked only when I set Settings -> Configure k3b -> Programs -> User Parameters -> growisofs: -use-the-force-luke=bufsize:16m.

Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Installing Oracle 10.2.0.1 on CentOS 5.0 (x86_64) LXer Syndicated Linux News 0 04-29-2007 12:31 PM
LXer: Release for CentOS-5 i386 and x86_64 LXer Syndicated Linux News 0 04-13-2007 02:46 AM
CentOS 4.4 x86_64 on AMD Athlon 64 X2 4200+ mikey Linux - Hardware 8 01-30-2007 04:24 PM
CentOS 4 (x86_64 or i386) Mithrilhall Linux - Newbie 2 07-14-2006 11:36 AM
installing Intel Server Manager on CentOS 4.2 x86_64 istvank Linux - Hardware 0 02-25-2006 07:25 AM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration