LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-30-2007, 01:20 PM   #1
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Rep: Reputation: 15
k3b can not "talk" to klauncher


The result is that I cannot access my files from k3b. What is klauncher?. And, how can I fix the problem? Thanks a lot for your help. I'm using Suse 10.2 with Gnome.
P.S. I reviewed "Find Similar Threads", but couldn't find anything useful.
 
Old 04-30-2007, 10:58 PM   #2
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Pumalite
The result is that I cannot access my files from k3b. What is klauncher?. And, how can I fix the problem? Thanks a lot for your help. I'm using Suse 10.2 with Gnome.
P.S. I reviewed "Find Similar Threads", but couldn't find anything useful.
I found out I can run k3b from the terminal as root, so, it's all a matter of permissions. Granting permission to <username> doesn't work. I have to grant permission to specific files. Which ones?. Help appreciated.
 
Old 05-01-2007, 06:58 AM   #3
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Pumalite
I found out I can run k3b from the terminal as root, so, it's all a matter of permissions. Granting permission to <username> doesn't work. I have to grant permission to specific files. Which ones?. Help appreciated.
Well guys, problem solved. I had to grant permission to file /.ICEauthority and I did. Now Amarok as well as k3b work fine as user. Thanks anyway.I hope this helps someone in the future.

Last edited by Pumalite; 05-01-2007 at 07:05 AM.
 
Old 05-22-2007, 09:37 AM   #4
yinrunning
LQ Newbie
 
Registered: Mar 2003
Location: Kansas City, MO, USA
Distribution: Debian
Posts: 13

Rep: Reputation: 0
puma, this did nothing for me. I chmod 777 on ~/.ICEauthority. No effect. finally went back to 600. Was there anything else you did?
 
Old 05-23-2007, 03:26 PM   #5
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by yinrunning
puma, this did nothing for me. I chmod 777 on ~/.ICEauthority. No effect. finally went back to 600. Was there anything else you did?
No, that's all I did. It worked for me. Run dcopserver and find out what else is wrong with your system.

Last edited by Pumalite; 05-23-2007 at 03:48 PM.
 
Old 06-06-2007, 03:53 AM   #6
Splatt
LQ Newbie
 
Registered: Jun 2007
Posts: 3

Rep: Reputation: 0
Hi! I just had the same problem. I tried the same thing with changing the permissions but it didn't work. Then i got pissed of and deleted the file. (.ICEsomething) and when i restarted amarok the file was created again and everything worked perfect...

PS. (had u just changed the permission of your home dir? that was the reason for me...) DS
 
Old 06-07-2007, 04:58 PM   #7
Pumalite
Member
 
Registered: Apr 2007
Location: All over
Distribution: Suse 10.2
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Splatt
Hi! I just had the same problem. I tried the same thing with changing the permissions but it didn't work. Then i got pissed of and deleted the file. (.ICEsomething) and when i restarted amarok the file was created again and everything worked perfect...

PS. (had u just changed the permission of your home dir? that was the reason for me...) DS
I just changed the permission, but deleting the file is just as good because whoever uses the socket recreates the file. Good luck.
 
Old 08-03-2007, 05:18 PM   #8
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
Just found out that running "kdeinit" in a terminal solves this prob.
 
Old 12-13-2011, 01:53 PM   #9
Abdrahim
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Rep: Reputation: 0
Thanks for the help folks. kdeinit4 finally did it for me. Then I had to change the permissions for the files it indicated (./home/user/.kde/share/k3brc). Man, Oeiric is like going ten steps back. I hope they restore all of the user friendly features to the next version, because Oneiric is very disappointing. I much prefer Gnome2. And Unity is for the birds.

Last edited by Abdrahim; 12-13-2011 at 02:00 PM.
 
  


Reply

Tags
suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"KLauncher could not be reached via DCOP" - Error in KDE itz2000 Linux - Newbie 5 06-02-2006 05:11 AM
K3b: - Howto re-dock "Directories" and "Contents" windows back into the main window? hagies Linux - Software 4 04-26-2006 08:38 AM
chrooted user: "write" and "talk" don't work. ldp Linux - Software 2 04-12-2005 02:05 AM
"Could not start process - Can't talk to Klauncher" ?? Sean Murphy Linux - Newbie 3 10-21-2003 11:28 AM
why cannot "talk" to others,since mesg is yes and disable = no(in /etc/xinetd.c/talk) whepin Linux - Newbie 0 12-31-2001 02:04 AM


All times are GMT -5. The time now is 11:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration