LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 07-17-2004, 04:34 AM   #1
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Rep: Reputation: 30
Question Just installed linux and....


... I got questions. (I've actually been using linux for a few months on a junk box but now its on my main pc).

Feel free to answer all or any (though they are ranked in decending order of precedence)

But first my configuration:
Running Slackware 10
HDA: 100% windows
HDB: cdrom
HDC: 100% linux
HDD: dvd drive
HDE: swap space and home dir (2 partitions)
HDF: 50% windows 50% linux (programs go here)
HDG: 100% Windows
(i know alot of drives )

Anyways all mounts and works well but:

1. On system startup I get the following errors repeated ALOT (and I emphasize ALOT!):
hdc: dma_intr: status=0x51 {DriveReady SeekComplete Error}
hdc: dma_intr: error 0x84 {DriveStatusError BadCRC}

This not only occurs a multitude of times for hdc but also many times for both hde and hda. All of the hard drives are less than a year old (hde is less than a week old!) and I was wondering what was causing this

2. GRUB wont boot windows. I got grub up and running (had to install seperately from slack) and it boots linux nicely (except for the previous error). But it wont load windows. Here is my menu.lst entry for windows:

title WinXP
unhide (hd0,0) #ive tried removing this, didnt work though
rootnoverify (hd0,0)
chainloader +1
makeactive

If I try running these commands at the grub command line I find that it is the chainloader command that is causing the problem. The error I get is:
"Error 13: Invalid or unsupported executable format"

I know windows works cause I can change my bios to load from HD0 and windows works fine. Been doing alot of searches on this one but all solutions haven't helped. Any one got any ideas? (on a side note I DONT want to use NTLDR as my boot loader -- ignoring the problem is not an option for me )

3. slackware starts in multiuser text mode by default. When I run startx, X starts. How do I shutdown/stop X (I know I can return to console by typing ctrl-alt-F# but I want to figure out how to stop x completely) Can i do this without issuing a 'kill' command? This one should be easy to you linux guru's out there.

4. Upon Installation I specified gnome as my default window manager. Is there anyway to change which one starts up when x starts (right now when I issue startx, gnome just pops up) Just curious on this one.

Thank you all in advance. I find these forums very usefull and the people very nice. Look forward to hearing from you!

Movitto
 
Old 07-17-2004, 04:53 AM   #2
scius
Member
 
Registered: Jul 2003
Location: Berkeley
Distribution: gentoo (kernel 2.6.7)
Posts: 39

Rep: Reputation: 15
I don't know much, but i do know how to change your runlevel on boot. What you're looking for is the file "/etc/inittab".
find the entry saying "default runlevel 5" and change the 5 to 3. Had to do this alot when installing nvidia drivers(that i never could get to work...).
I forget, you can probably find some other useful stuff in inittab (maybe not KDE/gnome, but maybe)
Anyway, hope that helps,
graham
 
Old 07-17-2004, 10:01 AM   #3
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Original Poster
Rep: Reputation: 30
scius;

Thanks alot for you reply. I looked at my runlevel but I found that the default is 3 (multiuser not x). Which is wierd cause i can launch x (and it wont change my runlevel).

Anyways all questions are still up for answering, and I need to add a few more:

5. I am mounting the three windows partitions that I have when I start my system. The thing is everything mounts ok and when I issue a mount I see that each partition is mounted as 'rw'. But when I try to copy ANYTHING or create a file (like a simple text file) on one of those partitions I get an error saying that the filesystem is mounted as read only". Here are the relavent entries in /etc/fstab:

/dev/hda1 /windows ntfs defaults 1 0
/dev/hdf1 /winapp ntfs defaults 1 0
/dev/hdg1 /shared ntfs defaults 1 0

And in mtab (i still am clueless to what this file actually does):

/dev/hda1 /windows ntfs rw 0 0
/dev/hdf1 /winapp ntfs rw 0 0
/dev/hdg1 /shared ntfs rw 0 0

Anyone want to give this question a go?

2. When I start x at the command prompt I get the following:
_XSERVTransSocketOpenCOTSServer: Unable to open sockets for inet6
_XSERVTransOpen: transport open failed for inet6/movitto:0
_XSCRUTransMakeAllCOTServerListeners: failed to open listener for inet6
.... (messages saying that x is starting up)
(WW)VESA: No matching source section for instance (BUSID PCI:0:9:0) found
....(a few more irrelavent messages)
AUDIT: Sat Jul 17 09:39:05 2004: 1586 X: client 5 rejected from local host

I have no idea why I am getting these messages. (X startsup fine after this)

Anyways; any and all help is appreciated, thx.
 
Old 07-17-2004, 10:33 AM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
It looks like you have ipv6 support in your kernel, either as part of the kernel, or as a module. Since there are few ipv6-enabled servers, its "looking" for something that's not there. Disable ipv6 support and likely those messages will go away. I haven't explored with Slack enough to tell for sure where everything is yet, so my experience as to how to do this is limited as of yet (GUI is runlevel 4 with Slack, btw - everybody else uses 5). Try with the pkgtool. It might be easier than you think.

If you have other windowmanagers installed, you can specify by entering them in an .xinitrc file on your /home. Or, you could install gdm and use it to control which you startwith as your whim decides, but that would be a graphical bootup.

Last edited by vectordrake; 07-17-2004 at 10:38 AM.
 
Old 07-17-2004, 11:00 AM   #5
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Code:
title=Windows XP
rootnoverify (hd0,0)
chainloader +1
makeactive
That's my line and it boots. Wierd.


As far as your driveseek errors, there seems to be a discussion that may bring to light your problem here. Its premise is that either your drive is going bad prematurely (which you can find out with fsck) and you should exercise your warranty rights if bad blocks are found, or perhaps the driver for your controller is not the best. Are you running with the default 2.4.26 kernel that came with Slack 10? Try compiling a 2.6 kernel and see if that makes it go away. Or, as the page suggests, try a different IDE cable. If your drives are UDMA (as in ATA 66,100,133), you will want to try an 80-wire cable instead of a 40-wire one, if you don't already have one installed. Good luck.
 
Old 07-17-2004, 11:15 AM   #6
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Original Poster
Rep: Reputation: 30
Yay, solved a few of my problems.

Let me first extend my thanks to vectordrake, I will try you suggestions after this post.

But onto my solution....
I solved problem 2 by editing my menu.lst entry to look like:
map (hd0) (hd1)
map (hd1) (hd0)
makerootactive (hd1,0)
chainloader +1

Maybe I just dont understand how grub works but I find this very wierd. In essence I am saying "let hd1 be hd0 and let hd0 be hd1 and now load hd1" why loading hd0 didnt work before... i dont know but oh well

I also think I found out to why I cannot load my ntfs drives as rw. It seems to me that linux only supports reading only for ntfs drives. If I am wrong please correct me on this one. Oh well....

Once again thank you vectordrake, and to all that have helped and will help. Anyone that wants to take a jab at the rest of the questions, be my guest.

Thanks!
Movitto
 
Old 07-17-2004, 12:22 PM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Red face First let me finish blushing....

I ain't done yet.........lol



You have a few unsolved mysteries and i think I've already come across the answers, so I owe it to you and the rest of the confused world to share what I've found

"Maybe I just dont understand how grub works but I find this very wierd. In essence I am saying "let hd1 be hd0 and let hd0 be hd1 and now load hd1" why loading hd0 didnt work before... i dont know but oh well"

Its not GRUB that has the problem. Its Windows. It wants to be the first OS on the first drive always. WAIT! It wants to be the only OS. You're using GRUB's (and LILO does this too) ability to "fool" Windows into thinking everything's okay and it's the first and best. Whatever works.

For the read/write issue, its my understanding that the NTFS project hasn't fully ported its 2.6 driver backwards, so the 2.4 kernel doesn't have write support. 2.6 does, so if you want to write to NTFS, you will have to get a 2.6 kernel (of course you can boot both...I usually keep the last kernel I compiled until a newer one comes along to make three, and then I retire the older one..but I have had several kernels, both 2.4 and 2.6). Of course the write support still has a disclaimer, but you can do it, if you have to.

Pay it forward...
 
Old 07-17-2004, 12:33 PM   #8
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Original Poster
Rep: Reputation: 30
Once again thanks for the clarification vectordrake.

I will start looking into compiling 2.6 in the near future (i've compiled 2.4 before and I cant imagine that the processes are going to be too much different. I want to say thanks for the link you gave me above concerning the disk seek errors. I noticed whenever my system starts, bios yells at me sayinging to use type 80 cables, and i have type 40. So I replaced one of my cables (the one that was connected to hde) and sure enough the errors for that drive dissapeared (of course it so happens that I have a bag FULL of type 40 cables and only one 80 lol ).

Next Im gonna I think Im gonna try and compile the 2.6 kernel next, but its gonna have to wait cause I got stuff in the real world to do ( )

Thanks for all the help vectordrake, I'll be sure to keep this thread updated!

Movitto
 
Old 07-18-2004, 10:25 AM   #9
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Original Poster
Rep: Reputation: 30
Question Cant start kde

Hi again;

This is a bit of a sidetrack but i cant start KDE. I changed my .xinitrc file so that it reads "startkde" instead of "gnome-session" but when I run startx, it says "KDE could not be started in a gui window". Here is my .xinitrc file:

Code:
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# This nag screen isn't going to save anybody.
export NAUTILUS_OK_TO_RUN_AS_ROOT=1

# Start the window manager:
# For gnome:"gnome-session" and kde:"startkde"
exec startkde
These are all the errors that it gives me:

Quote:
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/movitto:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.4.26 i686 [ELF]
Current Operating System: Linux movitto 2.4.26 #6 Mon Jun 14 19:07:27 PDT 2004 i686
Build Date: 05 June 2004
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 18 10:13:14 2004
(==) Using config file: "/etc/X11/xorg.conf"
(WW) VESA: No matching Device section for instance (BusID PCI:0:9:0) found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
xset: bad font path element (#58), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
/opt/kde/bin/startkde: line 129: lnusertemp: command not found
/opt/kde/bin/startkde: line 133: lnusertemp: command not found
/opt/kde/bin/startkde: line 137: lnusertemp: command not found
/opt/kde/bin/startkde: line 140: dcopserver_shutdown: command not found
startkde: Starting up...
kreadconfig: error while loading shared libraries: libkdecore.so.4: cannot open shared object file: No such file or directory
ksplash: error while loading shared libraries: libkio.so.4: cannot open shared object file: No such file or directory
/opt/kde/bin/startkde: line 165: kdeinit: command not found
startkde: Could not start kdeinit. Check your installation.
/opt/kde/bin/startkde: line 182: kwrapper: command not found
startkde: Shutting down...
/opt/kde/bin/startkde: line 192: kdeinit_shutdown: command not found
/opt/kde/bin/startkde: line 193: dcopserver_shutdown: command not found
startkde: Running shutdown scripts...
/opt/kde/bin/startkde: line 1: kde-config: command not found
startkde: Done.

waiting for X server to shut down
Based on the errors it looks like that KDE is not installed but I am 100% sure it is (it evenstarts up briefly to yell at me saying that it cant start). Do I have to do anything in addition to changing the .xinitrc file to get kde up and running?

Thanks alot!
Movitto
 
Old 07-18-2004, 10:28 AM   #10
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Excellent! You're going to find 2.6 easier to play with. The steps are fewer steps involved.
Code:
make menuconfig(or config or xconfig)
make
make modules_install
That's usually about it. Move the new kernel, system map (and .config incase) to /boot and add it to your bootloader. When you get down to it, one of the mods here on LQ has written an excellent kernel compile guide. Check it out when the time comes.

/Cliff on

I see those 40 wire cables on ebay all the time being auctioned in bundles of 100 or more. LOL. With todays newer drives, they're becoming a thing of the past, as the data transfer is too great (I understand from reading about it that the transfer is actually done in parallel, so its still 40 signals, so to speak, but it eliminates a lot of cross-talk, so the signals are "cleaner" - or maybe I'm bullshittin' ya). That's why they can be had for $1 or less usually, but the 80-wire variety are still over $5, if the store even will sell them to you (the flat ones, that is - pretty round or lighted ones are for sale, of course).

/Cliff off (any "Cheers" fans out there?)
 
Old 07-18-2004, 11:21 AM   #11
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
I don't think you actually do have KDE installed. Fire up a terminal window and go to /opt (or use your filemanager). See if the files are there. I suspect that you'll need to install it. I know that when I selected Gnome for my Slack install, it didn't install KDE either (although it installed fvwm, windowmaker, xfce, and fluxbox, without really asking me - and they say Slack's not bloated! Its as bloated as you let it be. LOL). If you haven't downloaded swaret, perhaps now would be a good time. Then you can "swaret --install kde" and it should install every damn kde package known.
 
Old 07-18-2004, 12:26 PM   #12
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Original Poster
Rep: Reputation: 30
vectordrake;

Once again thanks for your reply. Actually my slackware install did install kde, i know this because most of the kde files are present (including the ones in the /opt dir). I dont think all the kde packages got installed though. I know that lnusertemp and a few other files are located in the kdelib package, so I am working on installing that and playing with my startkde file.

Thanks for the help and I'll keep this thread updated!
Movitto
 
Old 07-18-2004, 12:33 PM   #13
Jose Muņiz
Member
 
Registered: Jul 2003
Location: Mexico City
Distribution: Slackware 9.1, SuSE 9.1
Posts: 248

Rep: Reputation: 31
Do you have enough disk space? Because Slackware Installation sometimes just keeps writing (and of course failing) whenever you have exceeded your disk space. And since package K is one of the last ones I think, maybe you didn't get it correctly installed?


About the init thingie... since you're using slackware... doing

Code:
init 4
as root will start gdm/kdm/xdm for you to start your session.

When you want to stop the x server just issue a

Code:
init 3
And everything will be back to M mode.
 
Old 07-18-2004, 12:52 PM   #14
movitto
Member
 
Registered: May 2004
Distribution: Fedora 4 and Slackware
Posts: 179

Original Poster
Rep: Reputation: 30
Jose Muniz;

Thank you very much for the help, all is appreciated. I do have enough space (actually a ton of it ). I think I solved my problem by downloading kdelib-3.2.3 source from www.kde.org and installing it. For some reason this wasnt installed during slack installation and when everything was where it should be kde worked (actually Im typing this from kde right now (perfer gnome though lol) ). Thanks for all the help jose and vectordrake.

About you reply jose;
I know on other distro's that X cannot be started if you are in multiuser mode (non-x). But slackware seems a bit wierd (not that it is a bad thing) in the sense you can start x from runlevel 3. But I think I will follow your suggestion and simply switch to runlevel 4 if I want to use x and switch back if im done. Thanks alot!
 
Old 07-18-2004, 01:53 PM   #15
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Yeah, the runlevel thing is a bit different. Its 4 for Slack, and 5 for most of the rest.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installed windows after linux and cant get linux to boot stuboo Linux - Hardware 1 10-22-2004 03:30 PM
Best Linux once installed el_pajaro! Linux - General 5 09-22-2004 05:35 PM
Linux installed, linux partitions lost, computer scragged, need serious help. B4UTRUST Linux - Newbie 4 01-23-2004 11:21 AM
after i installed linux and tried start linux it hangs at the message (in post) adamshreves Linux - General 5 10-30-2003 02:44 PM
Well I installed Linux. tmccort Linux - Newbie 6 07-27-2003 11:13 PM


All times are GMT -5. The time now is 04:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration