LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-04-2004, 06:47 PM   #1
ababkin
Member
 
Registered: Apr 2004
Location: Toronto, Canada
Posts: 76

Rep: Reputation: 15
Just installed Gnome2.6


Hi

finally managed to install gnome2.6 winmanager w/o Garnome or such.
It was a pain! but i did it.
It feels raw, but looks cute.

For those of you who who cant wait till it comes out in distro here is the installation sequence of the packages and some intermediate instructions:

(d/l) = need download separately

glib-2.4.0
(or d/l newest glib rpm - worked for me)
(d/l)fcpackage.2_1/fontconfig
/Xft

xft-2.1.2
pkgconfig-0.15.0
atk-1.6.0
pango-1.4.0
gtk+-2.4.0
libIDL-0.8.3
libwnck-2.6.0.1
libxml2-2.6.8
libxslt-1.1.5
libgtop-2.5.2
libgtkhtml-2.6.0
ORBit2-2.10.0
libbonobo-2.6.0
libglade-2.3.6
GConf-2.6.0
libart_lgpl-2.3.16
gail-1.6.0
librsvg-2.6.4
libxklavier-1.00
libgnomecanvas-2.6.0
gnome-mime-data-2.4.0

(here one would need to do the following, as the bzip2 package is needed for gnome-vfs)
install apt
apt-get update
aprt-get install bzip2-devel

gnome-vfs-2.6.0 (run ./configure with --disable-openssl option if returns error)
libgnome-2.6.0
libbonoboui-2.6.0
gnome-keyring-0.2.0
libgnomeui-2.6.0
gtk-engines-2.2.0
gnome-themes-2.6.0
(download latest hicolor theme from freedesktop.org/Software/icon-theme/releases)
gnome-icon-theme-1.2.0
libgnomeprint-2.6.0
libgnomeprintui-2.6.0
gnome-desktop-2.6.0.1
(d/l)gal-2.1.6
eel-2.6.0
audiofile-0.2.5
(d/l)esound-0.2.33
gnome-panel-2.6.0
nautilus-2.6.0
metacity-2.8.0
control-center-2.6.0.3
gnome-utils-2.6.0
startup-notification-0.5
vte-0.11.10
gnome-terminal-2.6.0
gnome-session-2.6.0
gstreamer-0.8.0
scrollkeeper-0.3.14
gtksourceview-1.0.0
gedit-2.6.0
gnome-netstatus-2.6.0.1
dasher-3.2.8
file-roller-2.6.0
eog-2.6.0
zenity-2.6.0
yelp-2.6.0
at-spi-1.4.0
gok-0.10.0
gconf-editor-2.6.0
gdm-2.6.0.0
ggv-2.6.0
gcalctool-4.3.51


cheers
Alex

PS: oh and it seems to have some retardations with scrolls
 
Old 04-04-2004, 08:20 PM   #2
coder_ma
LQ Newbie
 
Registered: Mar 2004
Distribution: redhat9
Posts: 18

Rep: Reputation: 0
thank you :-)
so helpfull
 
Old 04-04-2004, 08:25 PM   #3
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
I just installed it using apt in fedora...you are correct sir it was PITA. But I am using it although it has broken a few things but nothing major...and I'll fix 'em as I get time but, I dig it so far.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME2.4 dependancies fasta Slackware 3 11-07-2003 12:10 PM
Anyone get GTK:Perl installed with Gnome2 Makyver Linux - Newbie 10 04-26-2003 01:54 PM
Gnome2 and MetaCity RefriedBean Linux - Software 0 11-28-2002 09:17 PM
Evolution on Gnome2 Ratclaws Linux - Software 0 11-17-2002 03:09 PM
Gnome2 Mike Blick Linux - General 3 06-27-2002 02:30 AM


All times are GMT -5. The time now is 10:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration