LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-18-2004, 11:10 AM   #1
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Rep: Reputation: 15
Just installed Fedora, fatal error when it looks for floppy, i have no floppy


I dont understand, when it searches for the floppy, which i dont have, gives this error

modprobe: FATAL: Error inserting floppy (/lib/modules/2.6.5-1.358/kernel/drivers/block/floppy.ko):No such device

Thier has to be a easy fix for this, is their a way to tell it thier is no floppy?? thanks
 
Old 07-18-2004, 12:02 PM   #2
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I am not exactly sure what mechanism is used to load the module for your floppy. I could take a guess. Open your file(as root) /etc/fstab and check if there is a line for a floppy. If there is comment it out. That means place a "#" in front of it. This line will not get read, so it might not try and load the module. below would be an example

Code:
#/dev/fd0     /mnt/floppy     vfat      noauto       0   0
 
Old 07-18-2004, 12:52 PM   #3
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
I wish i could get access to that module, i have the GNU GRUB boot screen, and then after i hit enter, it goesthrough some error checking, then it freezes at that error. I did notices that at OS selction screen it does give me some optons, e to edit command, a to modify the kernel arguments, or c for a command line,,, The command line isnt like anything im falmair with and doesnt take linux commands, so im a bit lost.
 
Old 07-18-2004, 01:11 PM   #4
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I did not realize that it froze completely at that error. I would still try to edit that file. The easiest way would be with knoppix. Boot your system with knoppix and edit that file using knoppix. You do have the option of editing files with your fedora install CDs. I think it walks you through the procedure for mounting(accsessing) your file system. After it is mounted you can edit the file /etc/fstab.
 
Old 07-18-2004, 01:13 PM   #5
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
This program? where do i find it? if i use the fedora disk, all it lets me do is a new isntall of fedora, no other editing options. thanks for your input, hopefull i might get this thing to the next screen
 
Old 07-18-2004, 01:19 PM   #6
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I was basing that assumption on redhat, fedoras predesessor. It gave you an option of rescue mode, so you could edit files.

Knoppix is a live version of linux that runs of a cd. It is a full working version of linux. I use it as a tools to fix my installed systems all of the time.
 
Old 07-18-2004, 01:20 PM   #7
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
ahh, ill dig arround and DL it, maybe it may help, thank you for your input once again!
 
Old 07-18-2004, 06:06 PM   #8
RHELL
Member
 
Registered: Feb 2004
Location: Outermost mingetty
Distribution: RHEL3,RH4U4,Sol9, Sol10
Posts: 321

Rep: Reputation: 31
You should be able to boot from the CD#1, get an 'isolinux' prompt.and type 'linux rescue'. This would allow the fstab edit mentioned above.

You may also be able to use the 'e' option at the boot screen to remove any 'mount /dev/fd0' reference, but I don't have one in front of me, and sadly havent' committed it to memory yet.

Also, does your BIOS indicate that there is a floppy? Fedora could be getting confused from there.
 
Old 07-18-2004, 06:43 PM   #9
RHELL
Member
 
Registered: Feb 2004
Location: Outermost mingetty
Distribution: RHEL3,RH4U4,Sol9, Sol10
Posts: 321

Rep: Reputation: 31
Just to follow up, went through the Fedora CD#1 'linux rescue' routine on my machine. Good review for the RHCE exam anyway.

Prompt is actually 'boot', but all good. It does start anaconda, which looks like it's installing, but a stout heart will get you to the rescue shell.

Your hard drive will be mounted under /mnt/sysimage, so easiest to 'chroot /mnt/sysimage' to jailroot you there, then vi /etc/fstab will let you fix the problem. You might also look in grub.conf in case there's a failsafe 'mount' sequence there. My benumbed memory tells me there is.
 
Old 07-19-2004, 12:19 PM   #10
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
Ok, looked in both places, neither place loads my floppy, Interesting, guess ill have to dig somemore on the forums. sorry for the long reply, went out last night, this got me so mad i could have cussed.
 
Old 07-19-2004, 12:35 PM   #11
RHELL
Member
 
Registered: Feb 2004
Location: Outermost mingetty
Distribution: RHEL3,RH4U4,Sol9, Sol10
Posts: 321

Rep: Reputation: 31
Anything in /etc/modules.conf or /etc/sysconfig/hwconf ?

I'm really suspecting the BIOS, maybe the boot order, or I suppose even the damned 'startup floppyseek' might cause it.

What is trying to access the drive? Anything in dmesg?
 
Old 07-19-2004, 01:01 PM   #12
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
thiers a hwconfig,,, but thiers no floppy listed. Read on another forum to add "alias floppy off " to my /etc/modprobe.etc, but i think i have butcherd it do too confusion at this point, me and elvis arent getting alot, i can never get it to save.
 
Old 07-19-2004, 02:36 PM   #13
RHELL
Member
 
Registered: Feb 2004
Location: Outermost mingetty
Distribution: RHEL3,RH4U4,Sol9, Sol10
Posts: 321

Rep: Reputation: 31
OK, floppy drives are loaded as static devices by the kernel.

Try this:
boot through linux-rescue, (make sure NOT to mount drives read-only).
In /boot there's a file called something like config-2.6.5-1.FC2.
edit that file and set the flag:
CONFIG_BLK_DEV_IDEFLOPPY=n
 
Old 07-19-2004, 04:48 PM   #14
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
AHHH!! found it!! um... one problem,.. o can insert the n, but,,,, um,, im not that good with this elvis things,,,, how do i save and quit lol...
 
Old 07-19-2004, 04:55 PM   #15
Zieroth
Member
 
Registered: Jul 2004
Posts: 35

Original Poster
Rep: Reputation: 15
Never mind, i finally found the help file on that one,,, lets see what happens////
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Floppy error during fedora 1 install. teookie Linux - Software 1 05-11-2004 12:28 AM
Making dualboot w/o cd-rom, floppy but XP installed manrico Linux - Newbie 4 03-15-2004 12:15 AM
Debian Woody floppy install problems with ATAPI floppy jturnicate Linux - Newbie 0 02-17-2004 10:45 AM
Installed 9.1 floppy not working cjstm Mandriva 3 11-08-2003 09:02 PM
Floppy Not Installed? RED HAT 9 Penguin-novice Linux - Newbie 1 10-09-2003 11:43 PM


All times are GMT -5. The time now is 04:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration