LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-09-2003, 05:14 PM   #1
zho40
LQ Newbie
 
Registered: Nov 2003
Distribution: SuSE 9.1
Posts: 5

Rep: Reputation: 0
jdk 1.3.1_06 not working in mandrake 9.2


I'm trying to install two different versions of jdk 1.4.1 which works and 1.3.1_06 which gives me an error on the most basic command java -version. I know both the rpms are good because I installed the same ones on a box I have running SuSE and everything works fine. If I do a java -version in the /usr/java/jdk1.3.1_06/bin dir i get the /usr/java/jdk1.3.1_06/bin/i386/native_threads/jav following: a: error while loading shared libraries: libstdc -libc6.1-1.so.2: cannot open shared object file: No such file or directory
Any help would be great.
 
Old 12-09-2003, 05:26 PM   #2
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
do you have both 1.3.1 and 1.4 in the system? because java needs you uninstall the older verson ....

2 version of java shouldn't be appear on the same system.
if you got 1.4 running, you shouldn't need to install 1.3.1 (is it because u try to learn j2ee, jsp and servelt? and the book recommand you use 1.3?)

1.4 has all the function that is needed, if you want to do jsp, servlets , etc. just go ahead and get tomcat. delete 1.3 if u got 1.4

regard,
 
Old 12-14-2003, 11:00 AM   #3
lazat
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Rep: Reputation: 0
I can't run java -version. PAX is killing it.
WHY and how can I get it to work?
 
Old 12-14-2003, 01:49 PM   #4
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
Quote:
Originally posted by lazat
I can't run java -version. PAX is killing it.
WHY and how can I get it to work?



are there's error msg? what verson java u got? where u downloaded? how u installed? .... there can be alot of things go wrong if u don't have detail...
 
Old 12-15-2003, 01:09 PM   #5
lazat
LQ Newbie
 
Registered: Dec 2003
Posts: 7

Rep: Reputation: 0
I fund a good FAQ. I try to follow it first.
othervise i will be back with the anwnsers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
jdk not working crash_override_me Ubuntu 3 10-18-2005 01:35 PM
jdk 5.0 not working in Ubuntu crash_override_me Ubuntu 5 09-08-2005 01:13 PM
how to use Jdk 1.3.1 in RH 9 Egyptian_Isis Linux - Newbie 1 11-06-2003 05:15 AM
netscape 7/java 1.3.1_06 westside Linux - Software 1 07-08-2003 08:05 AM
Mandrake 9.0 and Java jdk + Forte problems lolmc Linux - Software 0 12-14-2002 01:02 AM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration