LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-21-2011, 01:04 AM   #1
Howlingstar89
LQ Newbie
 
Registered: May 2010
Location: Southern California
Distribution: Ubuntu 10.04 Lucid Lynx, Gnome
Posts: 3

Rep: Reputation: 0
Japanese fonts in Skype via Anthy. (ubuntu 10.04)


I have successfully installed Japanese language packages and Anthy as well as Skype. These were simple. There is a problem though and that is when I use the keyboard shortcut to activate the switch between language fonts in Skype there is no effect. What do I have to do to get the fonts to work within Skype? It works just fine with firefox, gedit and other programs; just Skype. Could this perhaps be a bug within Skype that I have no control over? Please help.

P.S.
I am a casual user, I am not a superior 1337 haxor, but I do like linux because of it's open source. Usually I can figure things out on my own but I am stuck in a rut.
 
Old 05-22-2011, 05:45 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
How exactly are you launching the program? Do you get any output when launching it from the terminal?

anthy is just the IM backend. Which input method framework are you using? ibus, scim, scim-bridge, uim?

skype appears to use qt4, so do you have all the necessary qt extensions for your framework installed also? ibus-qt4/scim-qtimm/scim-bridge-client-qt4/uim-qt? (I'm going from my debian sources here, *buntu may have different package names.)

What are your IM environment settings? What output do you get with the command
Code:
env | grep '[IX]M'
I've never used skype, and now thanks to Microsoft I never will, but some googling shows me that it's probably an environment setting issue. This page, for example: http://code.google.com/p/ibus/issues/detail?id=613
 
1 members found this post helpful.
Old 05-23-2011, 02:21 AM   #3
Howlingstar89
LQ Newbie
 
Registered: May 2010
Location: Southern California
Distribution: Ubuntu 10.04 Lucid Lynx, Gnome
Posts: 3

Original Poster
Rep: Reputation: 0
Thumbs up

>To launch these programs I have made GUI shortcuts.
>ibus is the input method framework I am using.
>I did not have all of the framework extensions needed. After installing them the issue was resolved.
> The code, env | grep '[IX]M' did not seem to have any effect when I put it into the terminal. I am not sure what was supposed to happen if anything, but skype is now accepting the fonts.

Skype is the best VoIP I've used that is free, though I am not sure if it'll stay nice with it in Microsofts hands, yet for the time being it is wonderful to speak with people all over the world via Skype. Thank you very much, this helps me out tremendously.
どうもありがとございます。
 
Old 05-24-2011, 12:01 AM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946Reputation: 1946
env displays your current environment settings. The grep command filters the output to show only lines that contain "IM" or "XM" (case-sensitive). The result should include those variables important to your IME, like this:
Code:
$ env | grep '[IX]M'
GTK_IM_MODULE=ibus
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
The IM_MODULE settings tell the GTK and QT programs you launch which input method to use, and XMODIFIERS is the fallback setting for everything else. When only certain programs don't work, this is often the reason.

Your system should set them automatically though. Or use the im-switch command to ensure that the IME you want to use is properly configured.

Unfortunately, my favorite page describing multi-language support seems to be down. I hope it's just temporary. The last archived version is here:

http://web.archive.org/web/200904010...nl/stestu.html

It's three years out-of-date though. The new ibus framework isn't mentioned, for example.

Last edited by David the H.; 05-24-2011 at 12:03 AM.
 
  


Reply

Tags
font, language, skype, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Japanese input with scim-anthy mattca Slackware 15 11-15-2010 01:39 PM
japanese fonts in x.org juanbobo Linux - Software 3 03-29-2005 11:06 PM
Japanese display, fonts. Danodare Slackware 8 02-29-2004 11:47 AM
Japanese fonts under Slackware 9.1 OmegaTemplar Slackware 3 11-15-2003 08:10 AM
How do I get Japanese fonts working rtaft Linux - Software 2 08-18-2003 09:45 AM


All times are GMT -5. The time now is 04:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration